Bug #56093 Unkown Exception with Canvas.h line 152
Submitted: 18 Aug 2010 17:50 Modified: 5 Nov 2010 17:15
Reporter: bennie vaughan Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.26 CE rev 6432, 5.2.27, 5.2.28, 5.2.29 OS:Microsoft Windows (Vista Business Service Pack 1 32 bit)
Assigned to: CPU Architecture:Any
Tags: Canvas.h, driver, exception, workbench

[18 Aug 2010 17:50] bennie vaughan
Description:
Workbench generates a exception any time a design block is connected to another block. After a few exception blocks acknowledgements. All is ok until cursor is over a connect line or block that is connected.

How to repeat:
create 2 tables then connect with 1:1 or any others connection type. After acknoledgement of exceptions move cursor over connecting line or table block; will get error.
[18 Aug 2010 18:31] Miguel Solorzano
Thank you for the bug report. I couldn't repeat or I didn't understand how to repeat, it is possible to attach a screen-shot which shows how to repeat?. Thanks in advance.
[18 Aug 2010 19:27] bennie vaughan
here is the error:

Unkown Exception caught in c:\documents and
settings\mysqldev\build\mysql-workbench-gpl-5.2.26\backend\window\wbpublic.wr\Canvas.h at line 152

unable to get a screen shot at this time...
[24 Aug 2010 11:49] Didier WEERTS
Please note that with the mwb I've provided, the bug is present with the 5.2.26 and 5.2.24rc but work fine with 5.2.21rc (all the versions a still have).

Working under Win Vista Pro SP2 x86.
[24 Aug 2010 19:39] Sveta Smirnova
Thank you for the feedback.

I can not repeat described behavior on Vista Business x86. Please, send the results from Help > System Info menu item.
[25 Aug 2010 13:42] Didier WEERTS
This is my workstation, I'll also try the same file on another computer with all 3 versions (5.2.21, 24 and 26).. expect feedback tomorow morning..

Result:

MySQL Workbench OSS for Windows version 5.2.21
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.0.6945 Release
OS: Microsoft Windows Vista Business Edition Service Pack 2 (build 6002), 32-bit
CPU: 2x Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz, 2.0 GiB RAM
Video adapter info:
Adapter type: 
Chip Type: ATI Radeon Graphics Processor (0x94C1)
BIOS String: 113-B27602-113
Video Memory: 262144 KB

Do you want the results for v5.2.24 and 26?
[26 Aug 2010 9:31] Didier WEERTS
HI!  Here is my results for this bug:

I've tested the 3 version (5.2.21, 24 and 26) on 5 different computer (see "System info" below).. 4 are working fine except my workstation (last on the list).

In the next post, I'll upload a movie showing the bug..

====================================================================================
Custom computer running W7 (running fine)
====================================================================================

Data Directory: P:\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 3.2.0
OS: Microsoft Windows 7 Ultimate Edition (build 7600), 64-bit
CPU: 4x Intel(R) Core(TM)2 Quad  CPU   Q9300  @ 2.50GHz, 4.0 GiB RAM
Video adapter info:
Adapter type: NVIDIA GeForce 9800 GT  
Chip Type: GeForce 9800 GT
BIOS String: Version 62.92.3a.0.8
Video Memory: 524288 KB

====================================================================================
Custom Computer running Vista (running fine)
====================================================================================

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 3.2.0
OS: Microsoft Windows Vista Home Premium Edition Service Pack 2 (build 6002), 32-bit
CPU: 2x AMD Athlon(tm) 64 X2 Dual Core Processor 6000+, 3.5 GiB RAM
Video adapter info:
Adapter type: NVIDIA GeForce 8800 GTX
Chip Type: GeForce 8800 GTX
BIOS String: Version 60.80.13.0.0
Video Memory: 786432 KB

====================================================================================
VM under W7 (running fine)
====================================================================================

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.1 Mesa 7.7.1-DEVEL
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: Intel(R) Core(TM)2 Quad  CPU   Q9300  @ 2.50GHz, 512 MiB RAM
Video adapter info:
Adapter type: VMware SVGA II
Chip Type: VMware SVGA II
BIOS String: VMware SVGA II
Video Memory: 131072 KB

====================================================================================
Dell Optiplex GX520 (running fine)
====================================================================================

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is not available on this system, so GDI is used for rendering.
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x Intel(R) Pentium(R) 4 CPU 3.00GHz, 1.0 GiB RAM
Video adapter info:
Adapter type: Intel(R) 82945G Express Chipset Family
Chip Type: Intel(R) 82945G Express Chipset Family
BIOS String: Intel Video BIOS
Video Memory: 229376 KB

====================================================================================
Dell Optiplex 755 (crashing with 5.2.26 but fine with 21 and 24)
====================================================================================

Data Directory: C:\Corsaire\Programs\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.0.6945 Release
OS: Microsoft Windows Vista Business Edition Service Pack 2 (build 6002), 32-bit
CPU: 2x Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz, 2.0 GiB RAM
Video adapter info:
Adapter type: 
Chip Type: ATI Radeon Graphics Processor (0x94C1)
BIOS String: 113-B27602-113
Video Memory: 262144 KB
[26 Aug 2010 9:41] Didier WEERTS
File "bug-data-56093-didier-weerts.zip" uploaded with the movie..
MD5: 5426a682b1f2fa265c639f9d6148342e
[1 Sep 2010 8:11] Valeriy Kravchuk
Please, check if this ever happens with a newer version, 5.2.27.
[13 Sep 2010 8:19] Didier WEERTS
Hi!

I'm back.. :)

Sorry for the delay but unfortunately, yes, the bug is still present with v.27..

MySQL Workbench CE for Windows version 5.2.27
Data Directory: C:\Corsaire\Programs\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.0.6945 Release
OS: Microsoft Windows Vista Business Edition Service Pack 2 (build 6002), 32-bit
CPU: 2x Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz, 2.0 GiB RAM
Video adapter info:
Adapter type: 
Chip Type: ATI Radeon Graphics Processor (0x94C1)
BIOS String: 113-B27602-113
Video Memory: 262144 KB
[20 Sep 2010 8:47] Valeriy Kravchuk
Please, check if this still happens with a newer version, 5.2.28.
[20 Sep 2010 9:33] Didier WEERTS
Yes, it's still present (canvas.h at line 171)..
[9 Oct 2010 13:48] Valeriy Kravchuk
Bug #57201 was marked as a duplicate of this one.

All reporters, please, check if starting Workbench from command line with -swrendering option prevents this problem.
[12 Oct 2010 13:58] Valeriy Kravchuk
Bug #57404 was marked as a duplicate of this one.
[12 Oct 2010 14:07] Didier WEERTS
Hi!

As of version 5.2.29CE, the bug is still present; BUT, with the parameter "-swrendering", all works fine in GDI mode on the faulty workstation.

(the NOD tricked my OpenGL driver? ;) )
[13 Oct 2010 20:03] bennie vaughan
The addition of "-swrendering" at the command line corrected the problem.
[28 Oct 2010 15:14] Alfredo Kojima
If anyone has access to other machines with ATI cards, could you please test if the same happens in these?
[28 Oct 2010 15:23] Alfredo Kojima
Also, please make sure you have the latest drivers for video.
[28 Oct 2010 15:23] Alfredo Kojima
Also, what drivers are you using? The one that comes with Windows or the ones provided by ATI?
[3 Nov 2010 9:57] Didier WEERTS
Hi!

I wasn't using the Windows's default drivers but the ones provided by Dell.

I've updated the drivers, downloading them directly at ATI and all works fine now.
[5 Nov 2010 17:15] Johannes Taxacher
so i'll close this as a driver issue. thanks for the update