Bug #55881 information_schema.events informations can't match with mysql.event
Submitted: 10 Aug 2010 13:47 Modified: 21 Aug 2010 13:14
Reporter: Justin Xu Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Information schema Severity:S2 (Serious)
Version:5.1.39 OS:Linux (centos)
Assigned to: CPU Architecture:Any
Tags: Event

[10 Aug 2010 13:47] Justin Xu
Description:
RT...

The informations of mysql.event's query:

justin@[(none)] 09:27:55>select * from mysql.event\G
*************************** 1. row ***************************  
                  db: ztest                                     
                name: sp_delete_ip                              
                body: BEGIN                                     
                                                                
call ztest.sp_delete_ip;                                        
                                                                
END                                                             
             definer: justin@%                                  
          execute_at: NULL                                      
      interval_value: 12                                        
      interval_field: HOUR                                      
             created: 2010-08-06 15:06:40                       
            modified: 2010-08-06 16:49:04                       
       last_executed: 2010-08-10 04:00:07                       
              starts: 2010-08-06 04:00:00                       
                ends: NULL                                      
              status: ENABLED                                   
       on_completion: DROP                                      
            sql_mode:                                           
             comment:                                           
          originator: 11100                                     
           time_zone: SYSTEM                                    
character_set_client: utf8                                      
collation_connection: utf8_general_ci                           
        db_collation: utf8_general_ci                           
           body_utf8: BEGIN                                     
                                                                
call ztest.sp_delete_ip;                                        
                                                                
END                                                             

The informations of information_schema.events's query:

justin@10.10.11.100[(none)] 09:28:09>select * from information_schema.events\G 
*************************** 1. row ***************************                 
       EVENT_CATALOG: NULL                                                     
        EVENT_SCHEMA: ztest                                                    
          EVENT_NAME: sp_delete_ip                                             
             DEFINER: justin@%                                                 
           TIME_ZONE: SYSTEM                                                   
          EVENT_BODY: SQL                                                      
    EVENT_DEFINITION: BEGIN                                                    
                                                                               
call ztest.sp_delete_ip;                                                       
                                                                               
END                                                                            
          EVENT_TYPE: RECURRING                                                
          EXECUTE_AT: NULL                                                     
      INTERVAL_VALUE: 12                                                       
      INTERVAL_FIELD: HOUR                                                     
            SQL_MODE:                                                          
              STARTS: 2010-08-06 12:00:00                                      
                ENDS: NULL                                                     
              STATUS: ENABLED                                                  
       ON_COMPLETION: NOT PRESERVE                                             
             CREATED: 2010-08-06 15:06:40                                      
        LAST_ALTERED: 2010-08-06 16:49:04                                      
       LAST_EXECUTED: 2010-08-10 12:00:07                                      
       EVENT_COMMENT:                                                          
          ORIGINATOR: 11100                                                    
CHARACTER_SET_CLIENT: utf8                                                     
COLLATION_CONNECTION: utf8_general_ci                                          
  DATABASE_COLLATION: utf8_general_ci                                          

but both of "last_executed" values cant be the same. Any suggestions,thanks.

How to repeat:
create the events in MySQL5.1.39 and query values of information_schema.events/mysql.event tables
[10 Aug 2010 16:13] Miguel Solorzano
Could you please try latest version 5.1.49 and comment the results here. Thanks in advance.
[18 Aug 2010 1:24] Justin Xu
thanks. It works in MySQL 5.1.49. Please look it:

mysql> select @@version;
+----------------------+
| @@version            |
+----------------------+
| 5.1.49-Community-log |
+----------------------+
1 row in set (0.00 sec)

mysql> select * from mysql.event\G
*************************** 1. row ***************************
                  db: ztest
                name: sp_get_error_info
                body: BEGIN

select now();

END
             definer: justin@%
          execute_at: NULL
      interval_value: 7
      interval_field: WEEK
             created: 2010-08-12 00:27:28
            modified: 2010-08-12 00:29:04
       last_executed: 2010-08-12 00:00:04
              starts: 2010-08-12 00:00:00
                ends: NULL
              status: ENABLED
       on_completion: DROP
            sql_mode: 
             comment: 
          originator: 1
           time_zone: SYSTEM
character_set_client: utf8
collation_connection: utf8_general_ci
        db_collation: utf8_general_ci
           body_utf8: BEGIN

select now();

END
1 row in set (0.01 sec)

mysql> select * from information_schema.events\G
*************************** 1. row ***************************
       EVENT_CATALOG: NULL
        EVENT_SCHEMA: ztest
          EVENT_NAME: sp_get_error_info
             DEFINER: justin@%
           TIME_ZONE: SYSTEM
          EVENT_BODY: SQL
    EVENT_DEFINITION: BEGIN

select now();

END
          EVENT_TYPE: RECURRING
          EXECUTE_AT: NULL
      INTERVAL_VALUE: 1
      INTERVAL_FIELD: WEEK
            SQL_MODE: 
              STARTS: 2010-08-12 08:00:00
                ENDS: NULL
              STATUS: ENABLED
       ON_COMPLETION: NOT PRESERVE
             CREATED: 2010-08-12 00:27:28
        LAST_ALTERED: 2010-08-12 00:29:04
       LAST_EXECUTED: 2010-08-12 08:00:04
       EVENT_COMMENT: 
          ORIGINATOR: 1
CHARACTER_SET_CLIENT: utf8
COLLATION_CONNECTION: utf8_general_ci
  DATABASE_COLLATION: utf8_general_ci
1 row in set (0.01 sec)
[18 Aug 2010 1:38] Justin Xu
any ideas.tks....
[18 Aug 2010 1:38] Justin Xu
any ideas.tks....
[21 Aug 2010 13:14] Sveta Smirnova
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments to the original bug instead.

Thank you for your interest in MySQL.

This is duplicate of bug #47967.