Bug #47967 mysql.event shows start in UTC instead of timezone server is running in
Submitted: 10 Oct 2009 8:05 Modified: 28 Oct 2009 14:35
Reporter: Geert Vanderkelen Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Documentation Severity:S3 (Non-critical)
Version:5.1.39 OS:Any
Assigned to: Paul Dubois
Tags: events, regression
Triage: Needs Triage: D2 (Serious)

[10 Oct 2009 8:05] Geert Vanderkelen
Description:
Documentation says:
"Beginning with MySQL 5.1.17, STARTS or ENDS uses the MySQL server's local time zone, as shown in the INFORMATION_SCHEMA.EVENTS and mysql.event tables, as well as in the output of SHOW EVENTS. Previously, this information was stored using UTC (Bug#16420)."

However, using 5.1.39, I dropped mysql.events and ran mysql_upgrade --force to recreate it (just making sure):

mysql> SELECT * FROM INFORMATION_SCHEMA.EVENTS WHERE EVENT_NAME = 'e1'\G
..
              STARTS: 2009-10-10 09:51:17

mysql> SHOW EVENTS LIKE 'e1'\G
..
              Starts: 2009-10-10 09:51:17

But!

mysql> SELECT * FROM mysql.event WHERE NAME = 'e1'\G
              starts: 2009-10-10 07:51:17

How to repeat:
mysql> delimiter //
mysql> CREATE EVENT e1 ON SCHEDULE EVERY 7 MINUTE DO BEGIN SELECT "hello from event"; END;//
mysql> delimiter ;
mysql> SELECT * FROM INFORMATION_SCHEMA.EVENTS WHERE EVENT_NAME = 'e1'\G
mysql> SHOW EVENTS LIKE 'e1'\G
mysql> SELECT * FROM mysql.event WHERE NAME = 'e1'\G
[28 Oct 2009 14:35] Paul Dubois
Thank you for your bug report. This issue has been addressed in the documentation. The updated documentation will appear on our website shortly, and will be included in the next release of the relevant products.

Added information describing time information in events here:

http://dev.mysql.com/doc/refman/5.1/en/events-metadata.html

Also updated information about event times here:

http://dev.mysql.com/doc/refman/5.1/en/create-event.html
http://dev.mysql.com/doc/refman/5.1/en/show-events.html
http://dev.mysql.com/doc/refman/5.1/en/events-table.html
[21 Aug 2010 13:15] Sveta Smirnova
Bug #55881 was marked as duplicate of this one.