Bug #55509 main.lowercase_table2 fails on Mac OSX (again)
Submitted: 23 Jul 2010 13:03 Modified: 29 Jan 2011 23:11
Reporter: Alexander Nozdrin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: General Severity:S1 (Critical)
Version:M3 (Celosia), M4 (Dahlia) OS:Mac OS X
Assigned to: Georgi Kodinov CPU Architecture:Any
Tags: experimental, pb2, regression, test failure
Triage: Needs Triage: D2 (Serious)

[23 Jul 2010 13:03] Alexander Nozdrin
Description:
According to Davi, it looks like lowercase_table2 started
failing after Bug#53095 was pushed.

Symptoms:

@@ -55,7 +55,7 @@
 CREATE DATABASE `TEST_$1`;
 SHOW DATABASES LIKE "TEST%";
 Database (TEST%)
-TEST_$1
+test
 DROP DATABASE `test_$1`;
 CREATE TABLE T1 (a int) engine=innodb;
 INSERT INTO T1 VALUES (1);
@@ -171,7 +171,7 @@
 select TABLE_SCHEMA,TABLE_NAME FROM information_schema.TABLES
 where TABLE_SCHEMA ='mysqltest_LC2';
 TABLE_SCHEMA    TABLE_NAME
-mysqltest_LC2    myUC
+mysqltest_lc2    myUC
 use test;
 drop database mysqltest_LC2;
 # End of 5.1 tests 

How to repeat:
Check out PB.
[23 Jul 2010 13:36] Valeriy Kravchuk
Verified on Mac OS X 10.5.x:

macbook-pro:mysql-test openxs$ ./mtr lowercase_table2Logging: ./mtr  lowercase_table2
100723 16:35:03 [Warning] Setting lower_case_table_names=2 because file system for /var/folders/dX/dXCzvuSlHX4Op1g-o1jIWk+++TI/-Tmp-/5DAmlnqfcg/ is case insensitive
100723 16:35:03 [Note] Plugin 'FEDERATED' is disabled.
100723 16:35:03 [Note] Plugin 'ndbcluster' is disabled.
MySQL Version 5.5.6
Checking supported features...
 - using ndbcluster when necessary, mysqld supports it
 - SSL connections supported
 - binaries are debug compiled
Collecting tests...
vardir: /Users/openxs/dbs/trunk/mysql-test/var
Checking leftover processes...
Removing old var directory...
Creating var directory '/Users/openxs/dbs/trunk/mysql-test/var'...
Installing system database...
Using server port 59146

==============================================================================

TEST                                      RESULT   TIME (ms)
------------------------------------------------------------

worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 13000..13009
main.lowercase_table2                    [ fail ]
        Test ended at 2010-07-23 16:35:19

CURRENT_TEST: main.lowercase_table2
--- /Users/openxs/dbs/trunk/mysql-test/r/lowercase_table2.result	2010-07-23 16:33:49.000000000 +0300
+++ /Users/openxs/dbs/trunk/mysql-test/r/lowercase_table2.reject	2010-07-23 16:35:19.000000000 +0300
@@ -55,7 +55,7 @@
 CREATE DATABASE `TEST_$1`;
 SHOW DATABASES LIKE "TEST%";
 Database (TEST%)
-TEST_$1
+test
 DROP DATABASE `test_$1`;
 CREATE TABLE T1 (a int) engine=innodb;
 INSERT INTO T1 VALUES (1);
@@ -171,7 +171,7 @@
 select TABLE_SCHEMA,TABLE_NAME FROM information_schema.TABLES
 where TABLE_SCHEMA ='mysqltest_LC2';
 TABLE_SCHEMA	TABLE_NAME
-mysqltest_LC2	myUC
+mysqltest_lc2	myUC
 use test;
 drop database mysqltest_LC2;
 # End of 5.1 tests

mysqltest: Result content mismatch

 - saving '/Users/openxs/dbs/trunk/mysql-test/var/log/main.lowercase_table2/' to '/Users/openxs/dbs/trunk/mysql-test/var/log/main.lowercase_table2/'
------------------------------------------------------------
The servers were restarted 0 times
Spent 0.000 of 16 seconds executing testcases

Completed: Failed 1/1 tests, 0.00% were successful.
[26 Jul 2010 8:48] Alexander Nozdrin
The test case has been declared experimental due to this bug.
[26 Jul 2010 21:47] Alexander Nozdrin
Ok, confirmed. The test case passes in trunk-merge.
Putting to Need Merge awaiting for pushing into main trees.
[28 Jul 2010 5:29] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/114494

3151 Alexander Nozdrin	2010-07-26
      Make lowercase_table2 experimental due to Bug#55509.
[14 Jan 2011 13:02] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/128741

3244 Georgi Kodinov	2011-01-14
      Bug #55509 : main.lowercase_table2 fails on Mac OSX (again)
      
      The test passes on MacOSX. removing it from the experimental list.
[14 Jan 2011 13:04] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/128742

3246 Georgi Kodinov	2011-01-14
      Bug #55509 : main.lowercase_table2 fails on Mac OSX (again)
      
      The test passes on MacOSX. removing it from the experimental list.
[14 Jan 2011 13:06] Bugs System
Pushed into mysql-5.5 5.5.10 (revid:georgi.kodinov@oracle.com-20110114125923-rhgdheizi9slej20) (version source revid:georgi.kodinov@oracle.com-20110114125923-rhgdheizi9slej20) (merge vers: 5.5.10) (pib:24)
[14 Jan 2011 13:08] Bugs System
Pushed into mysql-trunk 5.6.2 (revid:georgi.kodinov@oracle.com-20110114130600-98wfu8ne28icb2u2) (version source revid:georgi.kodinov@oracle.com-20110114130600-98wfu8ne28icb2u2) (merge vers: 5.6.2) (pib:24)
[14 Jan 2011 17:28] Paul Dubois
Changes to test suite. No changelog entry needed.