Bug #54604 Configuring server instance stops after Writing config file.
Submitted: 18 Jun 2010 4:04 Modified: 9 Aug 2010 21:24
Reporter: David Rogers Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S1 (Critical)
Version:(Essentials) 5.1.48 OS:Microsoft Windows (Vista Ultra with Service Pack 2)
Assigned to: CPU Architecture:Any
Tags: database corruption, Plugin 'InnoDB' init function returned error, server instance

[18 Jun 2010 4:04] David Rogers
Description:
In window that it checks off showing its status while configuring the MySQL server instance it completed the Prepare configuration and the Write configuration file; then it hangs, seems to be in a loop (evidenced in the ERR file).  Have to start the task manager to abort it.

I had disabled Norton Internet Security's antiVirus, and advanced protection, Smart Firewall and Intrusion Prevention.  I found the ERR file (hidden in c:\ProgramData\MySQL\MySQL Server 5.1\data folder).  In the installer I had done a Custom type install, including C Include File / Lib Files.  In the Config wizard I selected Detailed config; Developer Machine; Multifunctional Database; InnoDB Tablspace Settings (accepted defaults); Decision Support / OLAP, enalbing TCP/IPNetworking and Enable Strict Mode, checking Add Firewall exception for the port; Manual Selected Default Character Set / Collation with character set UTF-16 (I use Cyrillic and phonetic characters); Install 
as Window Service with service name MySQL, Launch the MySQL Server automatically checked; in Security Options gave password as my first name, did not enable root access from remote macines and did not check Create an anonymous account.

The first instance of error lines are the following:

100615 21:12:37 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: Shutdown complete

100615 21:12:38 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The first specified data file .\ibdata1 did not exist:
InnoDB: a new database to be created!
100615 21:12:38  InnoDB: Setting file .\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Error: all log files must be created at the same time.
InnoDB: All log files must be created also in database creation.
InnoDB: If you want bigger or smaller log files, shut down the
InnoDB: database and make sure there were no errors in shutdown.
InnoDB: Then delete the existing log files. Edit the .cnf file
InnoDB: and start the database again.
100615 21:12:38 [ERROR] Plugin 'InnoDB' init function returned error.
100615 21:12:38 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
100615 21:12:38 [ERROR] Unknown/unsupported table type: INNODB
100615 21:12:38 [ERROR] Aborting

I do not know how to edit the .cnf file.

Note:  Computer is HP PC having 4GB RAM, Intel Core (TM)2 Duo CPU at 2.20GHz, 32-bit OS, 249GB free on internal disk drive.

Would greatly appreciate your assistance.

How to repeat:
I varied some of above, e.g. went with the default character set, left Add firewall exception of the port unchecked.  Results were same.

Suggested fix:
?
[18 Jun 2010 4:06] David Rogers
In most attempts it seems to be in a loop; but sometimes it stops at Start service with a red X in the bullet.
[18 Jun 2010 4:46] Valeriy Kravchuk
Please, send the results of:

dir c:\ProgramData\MySQL\MySQL Server 5.1\data

from cmd.exe.
[18 Jun 2010 14:18] David Rogers
Received your email response.  Thanks.

C:\ProgramData\MySQL\MySQL Server 5.1\Data has 73 files, 60.0MB.
C:\ProgramData\MySQL\MySQL Server 5.1\Data\Test is empty.
C:\ProgramData\MySQL\MySQL Server 5.1\has 4 files:  ib_logfile0 [24,576KB], ib_logfile1 [24,576KB], ibdata1 [10,240DK]and Rogers-PC.ERR [1,112KB].
C:\ProgramData\MySQL\MySQL Server 5.1\Data\mysql has 69 files [964KB].

Which do you want and if I need to FTP them to you then I need permits.

Thanks.
[18 Jun 2010 14:31] Valeriy Kravchuk
No need to FTP anything. Just copy and paste the results of:

dir C:\ProgramData\MySQL\MySQL Server 5.1\Data 

from the cmd.exe command line window. I want to check file sizes and dates.
[18 Jun 2010 19:52] David Rogers
Command "dir C:\ProgramData\MySQL\MySQL Server 5.1\Data" did not work from command prompt (DOS box).  I navigated to C root where I did a Dir, which did not show ProgramData.  (Note:  I can see ProgramData in Windows directory (folder) navigator.) Tried a change to allow me to act with Administrative Privileges in the DOS box, but, as I thought, I still could not see the ProgramData folder in the DOS box.  So, I tried screen prints.  I can not paste them here.

Also, it has been years since I used the DOS box.

Sorry to be so weak.

What next?
[18 Jun 2010 20:04] David Rogers
Bug #54604 Print Screen of Data folder

Attachment: Print Screen 2.docx (application/vnd.openxmlformats-officedocument.wordprocessingml.document, text), 196.94 KiB.

[18 Jun 2010 20:09] David Rogers
Bug 54604 Print Screen of \Data\mysql

Attachment: Print Screen 3.docx (application/octet-stream, text), 309.01 KiB.

[18 Jun 2010 20:12] David Rogers
Bug 54604  2nd part of Print Screen of \Data\mysql

Attachment: Print Screen 4.docx (application/vnd.openxmlformats-officedocument.wordprocessingml.document, text), 249.08 KiB.

[18 Jun 2010 20:14] David Rogers
Bug 54604 Last of \Data

Attachment: Print Screen 5.docx (application/vnd.openxmlformats-officedocument.wordprocessingml.document, text), 267.83 KiB.

[18 Jun 2010 20:19] David Rogers
The last attemp was using Essentials 5.1.48.  Because the dates are from a much earlier attempt, when I was using Installer mysql-5.1.47-win32, I believe I should delete these files and try again.  However, I will not do this until you tell me what to do next, for you may want to look at a file currently from those attempts.

Thanks for all your help.
[22 Jun 2010 11:44] MySQL Verification Team
If you don't have data to preserve please deleting older files and removing any my.ini file could resolve the issue.
[22 Jul 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[27 Jul 2010 14:28] David Rogers
Last reply from someone out there indicated that I can not work both from Workbench (mysql-workbench-gpl-5.2.25-win32) and MySQL Command Line Client.  A friend in my city who uses MySQL as a webmaster for Kansas University said that if I cannot use the Command Line Client I will only lose facility to monitor remote user activity.  I do not intend to do that, so - case closed.

Thanks to all for their replies.
[9 Aug 2010 21:24] Sveta Smirnova
Thank you for the report.

This looks like duplicate of bug #42820 for me, so closing it as such.