Bug #53975 .NET connector 6.3.2 installation problem
Submitted: 25 May 2010 14:44 Modified: 22 Jul 2010 14:26
Reporter: Julien Beaumier-Ethier Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.3.2 OS:Microsoft Windows (Vista 32 bits)
Assigned to: Reggie Burnett CPU Architecture:Any
Tags: 32 bits, Connector .NET, installation, vista

[25 May 2010 14:44] Julien Beaumier-Ethier
Description:
I'm trying to install .net connector 6.3.2 on a Vista 32 bits machine, on which I have Visual Studio 2010 Professional and Visual Studio 2008 Professional installed.

During the installation process, it fails and then roll back changes. Here is a part of the installation log file:

CAQuietExec:  Microsoft (R) .NET Framework Installation utility Version 2.0.50727.3053
CAQuietExec:  Copyright (c) Microsoft Corporation.  All rights reserved.
CAQuietExec:  
CAQuietExec:  The installation failed, and the rollback has been performed.
CAQuietExec:  Error 0xffffffff: Command line returned an error.
CAQuietExec:  Error 0xffffffff: CAQuietExec Failed
Action ended 10:13:14: InstallFinalize. Return value 3.
Action 10:13:14: Rollback. Rolling back action:
Rollback: Registering data provider in machine.config
Rollback: Copying new files
Rollback: Creating folders
Rollback: Updating component registration
Action ended 10:13:15: INSTALL. Return value 3.

=== Logging stopped: 21/05/2010  10:13:18 ===
MSI (c) (4C:40) [10:13:18:255]: Product: MySQL Connector Net 6.3.2 -- Installation failed.

MSI (c) (4C:40) [10:13:18:256]: Windows Installer installed the product. Product Name: MySQL Connector Net 6.3.2. Product Version: 6.3.2. Product Language: 1033. Installation success or error status: 1603.

I tried installing the 6.3.0 and 6.3.1 versions and it did not worked either. I've read a lot of threads and bug reports about this and could not get it work. I've read that I should try renaming the "Config" folder in C:\Windows\Microsoft.NET\Framework\v2.0.50727. I tried to, but I don't have rights to rename it, even if I'm the administrator of my machine.

How to repeat:
Try installing .NET connector 6.3.2 on a machine having VS 2010 and VS 2008 Pro.
[17 Jun 2010 5:55] Tonci Grgin
Hi Julien and thanks for your report.

Does anything from Bug#51407 helps? There was a problem with .NET FW 1.x not having connection string entry thus failing but I haven't seen problems reported for .NET FW 2.x...

Assigning Wlad as he has proper environment.
[9 Jul 2010 15:18] Andre Hazelwood
Same results under Windows 7 Ultimate (x64).  Using latest beta distribution.
[10 Jul 2010 13:45] Vladislav Vaintroub
Can verify on Win7 x64 VS2008 Professional and VS2010 professional installed (2008 was installed after 2010, if it matters)

Will attach the full log.
If I understand it correctly, the error is returned from custom action that tries to install assembly

MSI (s) (40:FC) [15:20:01:877]: Executing op: CustomActionSchedule(Action=ManagedDataInstall,ActionType=3073,Source=BinaryData,Target=CAQuietExec,CustomActionData="C:\Windows\\Microsoft.NET\Framework\v2.0.50727\installUtil.exe" /LogToConsole=false /LogFile=  "C:\Program Files (x86)\MySQL\MySQL Connector Net 6.3.2\Assemblies\v2.0\MySql.Data.dll")

It is followed by
Exec:  Error 0xffffffff: Command line returned an error.
and 
ended 15:20:02: InstallFinalize. Return value 3.
and then installation rolls back
[10 Jul 2010 13:47] Vladislav Vaintroub
installer log

Attachment: install.log (application/octet-stream, text), 457.91 KiB.

[12 Jul 2010 11:24] Andrie Schoombee
Hi guys,

I had the same problem on a Windows 7 Enterprise machine, with Visual Studio 2010 Ultimate (fresh install).

I've tried any workaround I could find, nothing working, the setup for connector 6.3.2 kept crashing when "registering data provider in machine.config".

I then installed .NET Framework version 2.0, ran the setup again, and voila! Finished successfully!

It now even shows up in the "Add New Data Source" dialog, which was what I was struggling with in the first place. Hope this helps someone...
[19 Jul 2010 9:57] Louis B
Same thing on Seven 64bits and Vista 32bits.

How install framework 2.0 on Seven ? It seems to be impossible. I downloaded it but when I tried to install it, Windows said use control panel to activate / desactivate....

Hope we will have a solution quickly. Thank you !
[19 Jul 2010 11:38] Louis B
It works !
What I did (I don't know why it works finaly) :
- install the actual stable version 6.2
- uninstall it
- change the directory name "CONFIG" in all c:\Windows\Microsoft.NET\Framework\old_v... to "_CONFIG" 
- Same for \Framework64\old_v
- install the beta connector => installation done !

Hope this help you

(Win 7 64bits - VS2010 - VS2008)
[20 Jul 2010 19:55] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/113989

897 Reggie Burnett	2010-07-20
      Fixed an installer problem (bug #53975)
[20 Jul 2010 19:55] Reggie Burnett
fixed in 6.3.3
[22 Jul 2010 14:26] Tony Bedford
An entry has been added to the 6.3.3 changelog:

MySQL Connector/NET 6.3.2 failed to install on Windows Vista.
[22 Jul 2010 14:46] Fabio Visin
Where can I find the MySQL Connector/NET 6.3.3?
Thanks
Fabio
[23 Jul 2010 9:58] Tonci Grgin
Bug#55493 was marked as a duplicate of this report.
[29 May 2011 16:54] ARNAUD DUPUIS
Hi am having the same problem using Windoas XP and trying to instal the version 6.3.6.
I had previously installed the 6.2.2 version...
Let me know if any idea of how to upgrade.
thanks you
[13 Dec 2011 8:16] Michael Melander
Still not working using Connector/Net 6.4.4 and .NET Framework 3.5 sp1 on Windows 7 Professional and Visual Studio 2010. Getting 'MySql.Data.dll', or one of its dependencies, requires a later version of the .NET Framework than the one specified in the project.