Bug #53606 'External error ...' when [browse] button clicked in Manage Server Instances
Submitted: 12 May 2010 18:11 Modified: 17 May 2010 21:18
Reporter: Dave Nechodom Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S1 (Critical)
Version:5.2.21 RC OS:Microsoft Windows (XP Pro SP3)
Assigned to: Assigned Account CPU Architecture:Any
Tags: browse button, external error, Manage Server
Triage: Needs Triage: D1 (Critical)

[12 May 2010 18:11] Dave Nechodom
Description:
Manage Server Instances > System Profile > Configuration File > [Browse] button, after SSH login: Alert! Title = MySQL WorkBench Unexpected Error, excerpt from content = "MySQL Workbench has encountered a problem\n External component has thrown an exception. ..."

Help > System Info:
Unable to determine codepage from local shell: Check SSH connection.
x64 on x64Unable to fetch ProgramFiles value in local Windows machine: Check SSH connection.
Unable to fetch ProgramFiles(x86) value in local Windows machine: Check SSH connection.
get_server_version: parsed (5, 0, 24)
Unable to determine codepage from local shell: x64 on x64Unable to fetch ProgramFiles value in local Windows machine: Unable to fetch ProgramFiles(x86) value in local Windows machine: Checked server status: Server is stopped.Unable to determine codepage from local shell: x64 on x64Unable to fetch ProgramFiles value in local Windows machine: Unable to fetch ProgramFiles(x86) value in local Windows machine: Checked server status: Server is stopped./
Traceback (most recent call last):
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_grt.py", line 223, in openRemoteFileSelector
    return wba_ssh_ui.remote_file_selector(loginInfo, serverInfo)
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wba_ssh_ui.py", line 134, in remote_file_selector
    rfs.run()
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wba_ssh_ui.py", line 102, in run
    self.on_cd(0, 0)
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wba_ssh_ui.py", line 33, in on_cd
    if not self.cd(fname):
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/modules\wb_admin_ssh.py", line 93, in cd
    self.sftp.chdir(path)
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/python/site-packages\paramiko\sftp_client.py", line 515, in chdir
    if not stat.S_ISDIR(self.stat(path).st_mode):
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/python/site-packages\paramiko\sftp_client.py", line 337, in stat
    t, msg = self._request(CMD_STAT, path)
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/python/site-packages\paramiko\sftp_client.py", line 623, in _request
    num = self._async_request(type(None), t, *arg)
  File "C:\Program Files\MySQL\MySQL Workbench 5.2 OSS/python/site-packages\paramiko\sftp_client.py", line 642, in _async_request
    raise Exception('unknown type for %r type %r' % (item, type(item)))
Exception: unknown type for None type <type 'NoneType'>
MySQL Workbench OSS for Windows version 5.2.21
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 2.0.3
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x AMD Athlon(tm) 64 X2 Dual Core Processor 3800+, 1.9 GiB RAM
Video adapter info:
Adapter type: NVIDIA Quadro NVS 210S
Chip Type: Quadro NVS 210S
BIOS String: Version 5.51.28.50.18
Video Memory: 262144 KB

How to repeat:
When setting up the server System Profile in Manage Server Instances, I entered the path to the configuration file (/local/apollo/var/env/CSQAdb/etc/my.cnf) in the Configuration File box, then clicked the [...] button (I assume it's a Browse button, but there is no ToopTip text!); received exception noted above. This is repeatable with no exceptions in this installation. WorkBench is running on Windows XP SP3, MySQL 5.0.24 running on 8-CPU Opteron-based Dell host w/ 16gb, connection is SSH.

Suggested fix:
Unknown
[13 May 2010 8:59] Valeriy Kravchuk
Verified just as described on XP SP3 while working with instance on remote Linux server.
[17 May 2010 21:18] Alfredo Kojima
This is a duplicate of bug #52947