Bug #52947 error when I attempted to modify a server connection. (remote file selector)
Submitted: 19 Apr 2010 15:43 Modified: 20 May 2010 14:29
Reporter: Adam Reece Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.19 OSS Beta, revision 5600 OS:Microsoft Windows (7 Profiessional 64-bit)
Assigned to: Maksym Yehorov CPU Architecture:Any
Tags: remote file selector

[19 Apr 2010 15:43] Adam Reece
Description:
An unexpected error occurred when I attempted to modify a server connection.

A similar error also occurs when trying to establish an SSH session when creating a new server connection through the wizard. It also happens when I try and use the server connection.

Stack trace is as follows:

Exception = System.ArgumentOutOfRangeException
Message = Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
FullText = System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
   at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
   at System.ThrowHelper.ThrowArgumentOutOfRangeException()
   at System.Collections.Generic.List`1.get_Item(Int32 index)
   at System.Collections.ObjectModel.Collection`1.get_Item(Int32 index)
   at MySQL.Forms.TreeViewImpl.get_string(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , Int32 row, Int32 column)
   at MySQL.Forms.TreeViewImpl.get_string(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , TreeView* self, Int32 row, Int32 column)
   at MySQL.MCallback3<std::basic_string<char\,std::char_traits<char>\,std::allocator<char> >\,mforms::TreeView \*\,int\,int>.cpp_callback(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , TreeView* a1, Int32 a2, Int32 a3)
   at MySQL.Forms.ButtonImpl.button_click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
* Manage Server Instances dialog
* Selected a profile I had made earlier
* System Profile tab
* '...' Button next to the Configuration File text box
[19 Apr 2010 15:46] Adam Reece
It is worth noting that the server connection is on a remote machine, running:

* MySQL 5.1.45 community x64
* Windows Server 2003 Enterprise x64 (SP2)
[20 Apr 2010 12:32] Johannes Taxacher
verified for remote connections.
[17 May 2010 21:19] Alfredo Kojima
Marked bug #53606 as duplicate of this one
[19 May 2010 9:39] Maksym Yehorov
Fixed.
[20 May 2010 13:35] Johannes Taxacher
fix confirmed in repository
[20 May 2010 14:29] Tony Bedford
An entry has been added to the 5.2.22 changelog:

MySQL Workbench generated an exception when an attempt was made to change the configuration file in the System Profile tab of the Manage Server Instances dialog.