Bug #53448 Cannot add or edit table with out error
Submitted: 5 May 2010 20:31 Modified: 22 Mar 2011 17:52
Reporter: Richard Morris Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.1.18, 5.2.22, 5.2.33 OS:Microsoft Windows (Windows 7 X86_64)
Assigned to: CPU Architecture:Any

[5 May 2010 20:31] Richard Morris
Description:
Table editor cannot be opened due to an error with the module, tried onesuggestion to
fix it, by replacing the .dll but that didn't solve the problem. Did several un/install Make a new table, and
try to edit it resulted in the error:

Cannot load selected plugin(.\db.mysql.editors.wbp.fe.dll::DbMysqlTableEditor)
Exception has been thrown by the target of an invocation.
(Nullable object must have a value.)

Here is the system info

MySQL Workbench OSS for Windows version 5.1.18
Cairo Version: 1.8.6
Rendering Mode: GDI requested (create a diagram to confirm)
OpenGL Driver Version: Not Detected
OS: Windows XP
CPU: 2x Genuine Intel(R) CPU           T2500  @ 2.00GHz, 1.0 GB RAM
Video adapter info:
Adapter type: Mobile Intel(R) 945GM Express Chipset Family
Chip Type: Intel(R) Calistoga Graphics Controller
BIOS String: Intel Video BIOS
Video Memory: 131072 KB

How to repeat:
i just have to click on add table or edit table
[5 May 2010 20:32] Richard Morris
screen shot of error

Attachment: workbench_error.JPG (image/pjpeg, text), 124.84 KiB.

[17 May 2010 20:11] Johannes Taxacher
Could you please retry with latest version to check if the problem still exists? thanks in advance
[19 May 2010 16:12] Richard Morris
I went to control panel and removed the program.  Then I went to the website, downloads (GA)  and downloaded 5.1.18a.   I then installed and I see the same problem.
[19 May 2010 16:28] Richard Morris
I also just downloaded the 5.2 product.  When  I add or try to edit a table the an error has occured screen pops up.
[4 Jun 2010 1:00] Lukas Fendrych
I tried last version 5.2.22 rc and the same error on Windows 7 x64. On Windows XP SP3 x86 everything working perfect.
[16 Jun 2010 13:51] Alfredo Kojima
Do you have scintilla/scitext editor installed?

Btw this is a duplicate of bug #52982, which is also still unverified
[16 Jun 2010 13:55] Alfredo Kojima
Sounds related to old bug #35897, but it doesn't seem to be a regression.
[16 Jun 2010 14:42] Alfredo Kojima
Is the error popup you get the same as the one from 5.1.18? What are its contents?
[16 Jun 2010 14:52] Mike Lischke
Lukas, Richard, could you please try again and when the error dialog pops up (MySQL Workbench has encountered a problem...) right click on a free place in that dialog. A popup menu will come up allowing to copy the stacktrace and error info to the clipboard. Could you past the result here? Thank you.
[16 Jun 2010 14:55] Lukas Fendrych
Ok, there it is.

Exception = System.Reflection.TargetInvocationException
Message = Cíl vyvolání způsobil výjimku.
FullText = System.Reflection.TargetInvocationException: Cíl vyvolání způsobil výjimku. ---> System.TypeInitializationException: Inicializační metoda typu ScintillaNet.PageSettings vyvolala výjimku. ---> System.TypeInitializationException: Inicializační metoda typu ScintillaNet.PageInformation vyvolala výjimku. ---> System.ArgumentException: Písmo Arial nepodporuje styl Regular.
   v System.Drawing.Font.CreateNativeFont()
   v System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
   v System.Drawing.Font.Initialize(String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
   v System.Drawing.Font..ctor(String familyName, Single emSize)
   v ScintillaNet.PageInformation..cctor()
   --- Konec trasování zásobníku pro vnitřní výjimku ---
   v ScintillaNet.PageInformation..ctor(PageInformationBorder eBorder, InformationType eLeft, InformationType eCenter, InformationType eRight)
   v ScintillaNet.PageSettings..cctor()
   --- Konec trasování zásobníku pro vnitřní výjimku ---
   v ScintillaNet.PageSettings..ctor()
   v ScintillaNet.PrintDocument..ctor(Scintilla oScintillaControl)
   v ScintillaNet.Printing..ctor(Scintilla scintilla)
   v ScintillaNet.Scintilla..ctor(String sciLexerDllName)
   v ScintillaNet.Scintilla..ctor()
   v MySQL.Grt.Db.Sql.SqlEditor..ctor(GrtManager grtManager)
   v MySQL.GUI.Workbench.Plugins.ObjectEditorPlugin.SqlEditorHelper..ctor(GrtManager grtManager, Control parent, ProcessParserLogDelegate processParserLog)
   v MySQL.GUI.Workbench.Plugins.DbMysqlTableEditor..ctor(GrtManager GrtManager, GrtValue GrtList)
   --- Konec trasování zásobníku pro vnitřní výjimku ---
   v System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)
   v System.RuntimeMethodHandle.InvokeConstructor(Object[] args, SignatureStruct signature, RuntimeTypeHandle declaringType)
   v System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   v System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   v System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   v System.Activator.CreateInstance(Type type, Object[] args)
   v MySQL.GUI.Workbench.MainForm.OpenPlugin(GrtManager GrtManager, GrtModule GrtModule, String AssemblyName, String ClassName, GrtValue GrtList, GUIPluginFlags flags)
[16 Jun 2010 14:59] Lukas Fendrych
Some text is in Czech, provided that you have a problem, use Google Translate or ask me.
[16 Jun 2010 15:09] Mike Lischke
Lukas, awesome. Thanks for the quick reply. Yes I have already translated the text and I'm baffled. The Arial font does not support the regular style? That seems odd. Did you mess with that font somehow?

Also can you reinstall that font, e.g. using the Windows CD? Seems there are others out there who have had this problem. If you have a minute to work with us interactively then please join us in channel #workbench on freenode.org (IRC).
[16 Jun 2010 16:15] Mike Lischke
Together with Lukas we found out one reason for the crash. In his case it was a corrupted/missing Arial Regular font. After copying it from another machine WB started working as it should.

Anyone have the same problem but get a different error please add your stack trace here and we will see that we can figure out what is wrong!
[16 Jul 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[14 Mar 2011 7:49] C F
I got the same error message in Workbench 5.2.33 CE Revision 7506. It seems the error has a different source for me though. See stack trace.

db.mysql.editors.wbp.fe.dll exists and has a size of 255KB.

.Net Framework versions 1, 2, 3, 3.5 and 4 are installed with latest service packs.

System Info:
MySQL Workbench CE for Windows version 5.2.33
Configuration Directory: C:\Dokumente und Einstellungen\cfenn\Anwendungsdaten\MySQL\Workbench
Data Directory: U:\Programme\MySQL Workbench 5.2.33 CE
Cairo Version: 1.8.8
Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.
OpenGL Driver Version: 3.2.0
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 4x Intel(R) Core(TM) i5 CPU         650  @ 3.20GHz, 3.0 GiB RAM
Active video adapter: NVIDIA Quadro FX 580
Installed video RAM: 512 MB
Current video mode: 1920 x 1080 x 4294967296 Farben
Used bit depth: 32
Driver version: NULL
Installed display drivers: nv4_disp.dll
Current user language: Deutsch (Deutschland)

Stack trace:
Exception = System.IO.FileLoadException
Message = Die Datei oder Assembly "file:///U:\Programme\MySQL Workbench 5.2.33 CE\db.mysql.editors.wbp.fe.dll" oder eine Abhängigkeit davon wurde nicht gefunden. Der Vorgang wird nicht unterstützt. (Ausnahme von HRESULT: 0x80131515)
FullText = System.IO.FileLoadException: Die Datei oder Assembly "file:///U:\Programme\MySQL Workbench 5.2.33 CE\db.mysql.editors.wbp.fe.dll" oder eine Abhängigkeit davon wurde nicht gefunden. Der Vorgang wird nicht unterstützt. (Ausnahme von HRESULT: 0x80131515)
Dateiname: "file:///U:\Programme\MySQL Workbench 5.2.33 CE\db.mysql.editors.wbp.fe.dll" ---> System.NotSupportedException: Es wurde versucht, eine Assembly von einer Netzwerkadresse zu laden, was in früheren Versionen von .NET Framework zum Ausführen der Assembly als Sandkastenassembly geführt hätte. In dieser Version von .NET Framework wird die CAS-Richtlinie standardmäßig nicht aktiviert, dieser Ladevorgang kann daher gefährlich sein. Wenn Sie nicht beabsichtigen, durch diesen Ladevorgang eine Sandkastenassembly zu erstellen, aktivieren Sie den loadFromRemoteSources-Schalter. Weitere Informationen finden Sie unter "http://go.microsoft.com/fwlink/?LinkId=155569".
   bei System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   bei System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   bei System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection, Boolean suppressSecurityChecks)
   bei System.Reflection.RuntimeAssembly.InternalLoadFrom(String assemblyFile, Evidence securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm, Boolean forIntrospection, Boolean suppressSecurityChecks, StackCrawlMark& stackMark)
   bei System.Reflection.Assembly.LoadFrom(String assemblyFile)
   bei MySQL.GUI.Workbench.MainForm.OpenPlugin(GrtManager GrtManager, GrtModule GrtModule, String AssemblyName, String ClassName, GrtValue GrtList, GUIPluginFlags flags)
[16 Mar 2011 22:07] Johannes Taxacher
Is anyone else facing this problem while running MySQL workbench from a network drive (like last commenter "C F")?
[17 Mar 2011 7:58] C F
For me the problem doesn't occur when unzipping / installing workbench to a local disk.
[8 Apr 2011 7:50] Denis Neshyba
When I try to open the Alter Table Editor I get this errorstacktrace

Exception = System.IO.FileLoadException
Message = Die Datei oder Assembly "file:///P:\Programme\Mysql Workbench\db.mysql.editors.wbp.fe.dll" oder eine Abhängigkeit davon wurde nicht gefunden. Der Vorgang wird nicht unterstützt. (Ausnahme von HRESULT: 0x80131515)
FullText = System.IO.FileLoadException: Die Datei oder Assembly "file:///P:\Programme\Mysql Workbench\db.mysql.editors.wbp.fe.dll" oder eine Abhängigkeit davon wurde nicht gefunden. Der Vorgang wird nicht unterstützt. (Ausnahme von HRESULT: 0x80131515)
Dateiname: "file:///P:\Programme\Mysql Workbench\db.mysql.editors.wbp.fe.dll" ---> System.NotSupportedException: Es wurde versucht, eine Assembly von einer Netzwerkadresse zu laden, was in früheren Versionen von .NET Framework zum Ausführen der Assembly als Sandkastenassembly geführt hätte. In dieser Version von .NET Framework wird die CAS-Richtlinie standardmäßig nicht aktiviert, dieser Ladevorgang kann daher gefährlich sein. Wenn Sie nicht beabsichtigen, durch diesen Ladevorgang eine Sandkastenassembly zu erstellen, aktivieren Sie den loadFromRemoteSources-Schalter. Weitere Informationen finden Sie unter "http://go.microsoft.com/fwlink/?LinkId=155569".
   bei System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   bei System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   bei System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection, Boolean suppressSecurityChecks)
   bei System.Reflection.RuntimeAssembly.InternalLoadFrom(String assemblyFile, Evidence securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm, Boolean forIntrospection, Boolean suppressSecurityChecks, StackCrawlMark& stackMark)
   bei System.Reflection.Assembly.LoadFrom(String assemblyFile)
   bei MySQL.GUI.Workbench.MainForm.OpenPlugin(GrtManager GrtManager, GrtModule GrtModule, String AssemblyName, String ClassName, GrtValue GrtList, GUIPluginFlags flags)
[19 Apr 2011 2:42] scud zero
I using a windows 7 64 bit machine with workbench 5.2.33 CE and the following stack trace error is being generated:

Exception = System.IO.FileLoadException
Message = Could not load file or assembly 'file:///C:\SWIPE-MySQL Workbench 5.2.33\db.mysql.editors.wbp.fe.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)
FullText = System.IO.FileLoadException: Could not load file or assembly 'file:///C:\SWIPE-MySQL Workbench 5.2.33\db.mysql.editors.wbp.fe.dll' or one of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515)
File name: 'file:///C:\SWIPE-MySQL Workbench 5.2.33\db.mysql.editors.wbp.fe.dll' ---> System.NotSupportedException: An attempt was made to load an assembly from a network location which would have caused the assembly to be sandboxed in previous versions of the .NET Framework. This release of the .NET Framework does not enable CAS policy by default, so this load may be dangerous. If this load is not intended to sandbox the assembly, please enable the loadFromRemoteSources switch. See http://go.microsoft.com/fwlink/?LinkId=155569 for more information.
   at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
   at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection, Boolean suppressSecurityChecks)
   at System.Reflection.RuntimeAssembly.InternalLoadFrom(String assemblyFile, Evidence securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm, Boolean forIntrospection, Boolean suppressSecurityChecks, StackCrawlMark& stackMark)
   at System.Reflection.Assembly.LoadFrom(String assemblyFile)
   at MySQL.GUI.Workbench.MainForm.OpenPlugin(GrtManager GrtManager, GrtModule GrtModule, String AssemblyName, String ClassName, GrtValue GrtList, GUIPluginFlags flags)