Bug #53255 Installed psi headers in wrong directory
Submitted: 28 Apr 2010 15:42 Modified: 4 Aug 2010 16:50
Reporter: Kent Boortz Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.5.5 OS:Any
Assigned to: Marc Alff CPU Architecture:Any
Triage: Triaged: D2 (Serious)

[28 Apr 2010 15:42] Kent Boortz
Description:
When compiling and installing using "make install", the psi headers gets
placed into "$prefix/include/mysql/" or "/usr/local/mysql/include/"
(depending on if a normal install or a legacy TAR build), without the "psi"
sub directory part.

Note that if using the CMake build system it works, but with the GNU
autotools build it will not.

How to repeat:
Build, and install using

  % ./configure --with-plugin-perfschema
  % make install DESTDIR=/tmp/inst
  % find /tmp/inst -name "*psi*"

Suggested fix:
This is the suggested patch

--- include/Makefile.am 2010-01-26 04:39:48 +0000
+++ include/Makefile.am 2010-04-28 15:33:45 +0000
@@ -15,6 +15,8 @@
 # Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
 # MA 02111-1307, USA

+pkgpsiincludedir =     $(pkgincludedir)/psi
+
 BUILT_SOURCES =                $(HEADERS_GEN_MAKE) link_sources probes_mysql_nodtrace.h
 HEADERS_GEN_CONFIGURE =                mysql_version.h
 HEADERS_GEN_MAKE =             my_config.h
@@ -25,14 +27,15 @@ pkginclude_HEADERS =        $(HEADERS_ABI) my_d
                        my_xml.h mysql_embed.h mysql/services.h \
                        mysql/service_my_snprintf.h mysql/service_thd_alloc.h \
                        my_pthread.h my_no_pthread.h \
-                       mysql/psi/psi.h mysql/psi/mysql_thread.h \
-                       mysql/psi/mysql_file.h \
                        decimal.h errmsg.h my_global.h my_net.h \
                        my_getopt.h sslopt-longopts.h my_dir.h \
                        sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
                        m_ctype.h my_attribute.h $(HEADERS_GEN_CONFIGURE) \
                        $(HEADERS_GEN_MAKE) probes_mysql.h probes_mysql_nodtrace.h

+pkgpsiinclude_HEADERS =        mysql/psi/psi.h mysql/psi/mysql_thread.h \
+                       mysql/psi/mysql_file.h
+
 noinst_HEADERS =       config-win.h config-netware.h lf.h my_bit.h \
                        heap.h my_bitmap.h my_uctype.h \
                        myisam.h myisampack.h myisammrg.h ft_global.h\
[29 Apr 2010 8:09] Marc Alff
Verified as described when building with automake
[29 Apr 2010 8:23] Marc Alff
The patch proposed in the suggested fix works as originally intended,
and is approved as is.

Feel free to apply the patch directly to the proper build tree.

Thanks for the fix (and for fixing bugs I did create).
-- Marc
[3 May 2010 9:41] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/107164

3164 Marc Alff	2010-05-03
      Bug#53255 Installed psi headers in wrong directory
      
      Before this fix, the files:
      - mysql_thread.h
      - mysql_file.h
      - psi.h
      were installed under the include/mysql directory,
      instead of include/mysql/psi, when using automake.
      
      With this fix, these files are installed under
      include/mysql/psi, as intended.
      
      Original fix by Kent Boortz
[3 May 2010 10:03] Marc Alff
Pushed on behalf of Kent into:
- mysql-next-mr-bugfixing
- mysql-6.0-codebase-bugfixing
[7 May 2010 9:21] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100507091908-vqyhpwf2km0aokno) (version source revid:alik@sun.com-20100507091737-12vceffs11elb25g) (merge vers: 6.0.14-alpha) (pib:16)
[7 May 2010 9:23] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100507091823-nzao4h3qosau4tin) (version source revid:alik@sun.com-20100507091720-ib9r8uny2aeazvas) (pib:16)
[8 May 2010 17:11] Paul Dubois
Note in 6.0.14 changelog.

Performance Schema header files were not installed in the correct directory.
[16 Jul 2010 13:43] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/113760

3124 Marc Alff	2010-07-16
      Bug#53255 Installed psi headers in wrong directory
      
      Backport from mysql-next-mr (5.6) to mysql-trunk (5.5)
[16 Jul 2010 19:24] Marc Alff
Changing to need merge for 5.5
[16 Jul 2010 19:25] Marc Alff
Backport for 5.5 pushed in mysql-trunk-bugfixing
[22 Jul 2010 16:19] Paul Dubois
Noted in 5.5.6 changelog.
[23 Jul 2010 12:23] Bugs System
Pushed into mysql-trunk 5.5.6-m3 (revid:alik@sun.com-20100723121820-jryu2fuw3pc53q9w) (version source revid:vasil.dimov@oracle.com-20100531152341-x2d4hma644icamh1) (merge vers: 5.5.5-m3) (pib:18)
[23 Jul 2010 12:30] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100723121929-90e9zemk3jkr2ocy) (version source revid:vasil.dimov@oracle.com-20100531152341-x2d4hma644icamh1) (pib:18)
[23 Jul 2010 13:38] MC Brown
Already noted in changelog
[4 Aug 2010 8:04] Bugs System
Pushed into mysql-trunk 5.6.1-m4 (revid:alik@ibmvm-20100804080001-bny5271e65xo34ig) (version source revid:alik@sun.com-20100507093958-2y0wy6svnc3zfgqb) (merge vers: 5.6.99-m4) (pib:18)
[4 Aug 2010 8:20] Bugs System
Pushed into mysql-trunk 5.6.1-m4 (revid:alik@ibmvm-20100804081533-c1d3rbipo9e8rt1s) (version source revid:alik@sun.com-20100507093958-2y0wy6svnc3zfgqb) (merge vers: 5.6.99-m4) (pib:18)
[4 Aug 2010 16:50] Paul Dubois
Not present in any released 5.6.x version.