Bug #52821 plugin_ftparser.h and plugin_audit.h are not tested by ABI check
Submitted: 14 Apr 2010 12:35 Modified: 2 Sep 2010 16:11
Reporter: Sergey Vojtovich Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.5 OS:Any
Assigned to: Sergey Vojtovich
Triage: Triaged: D3 (Medium)

[14 Apr 2010 12:35] Sergey Vojtovich
Description:
plugin_ftparser.h and plugin_audit.h are part of public API/ABI, but they're not tested by the ABI check.

Low effort/risk fix with a nice benefit that API changes will not be unnoticeable.

How to repeat:
make abi_check

Suggested fix:
plugin_ftparser.h and plugin_audit.h should be tested by ABI check.
[14 Apr 2010 18:44] Sveta Smirnova
Thank you for the report.

Verified as described:

$make abi_check
make abi_headers="include/mysql/plugin.h include/mysql.h" do_abi_check
...
[20 Aug 2010 11:32] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/116374

3186 Sergey Vojtovich	2010-08-20
      BUG#52821 - plugin_ftparser.h and plugin_audit.h are
                  not tested by ABI check
      
      plugin_audit.h and plugin_ftparser.h are now subject
      for ABI check. plugin.h is now tested implicitly.
      
      Also fixed broken ABI check cmake rules.
     @ Makefile.am
        plugin_audit.h and plugin_ftparser.h are now subject
        for ABI check. plugin.h is now tested implicitly.
     @ cmake/abi_check.cmake
        plugin_audit.h and plugin_ftparser.h are now subject
        for ABI check. plugin.h is now tested implicitly.
        
        Also fixed broken ABI check rules.
     @ cmake/do_abi_check.cmake
        Inform sources that we do ABI check.
     @ include/mysql/plugin.h.pp
        plugin.h is now tested implicitly.
     @ include/mysql/plugin_audit.h.pp
        plugin_audit.h is now subject for ABI check.
     @ include/mysql/plugin_ftparser.h.pp
        plugin_ftparser.h is now subject for ABI check.
[27 Aug 2010 6:38] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/116952

3186 Sergey Vojtovich	2010-08-27
      BUG#52821 - plugin_ftparser.h and plugin_audit.h are
                  not tested by ABI check
      
      plugin_audit.h and plugin_ftparser.h are now subject
      for ABI check. plugin.h is now tested implicitly.
      
      Also fixed broken ABI check cmake rules.
     @ Makefile.am
        plugin_audit.h and plugin_ftparser.h are now subject
        for ABI check. plugin.h is now tested implicitly.
     @ cmake/abi_check.cmake
        plugin_audit.h and plugin_ftparser.h are now subject
        for ABI check. plugin.h is now tested implicitly.
        
        Also fixed broken ABI check rules: -DMYSQL_ABI_CHECK is
        compiler (not cmake) definition, incorrect definitions
        were passed to do_abi_check.cmake for abi_check_all rule.
     @ cmake/do_abi_check.cmake
        Inform sources that we do ABI check.
     @ include/mysql/plugin.h.pp
        plugin.h is now tested implicitly.
     @ include/mysql/plugin_audit.h.pp
        plugin_audit.h is now subject for ABI check.
     @ include/mysql/plugin_ftparser.h.pp
        plugin_ftparser.h is now subject for ABI check.
[30 Aug 2010 8:30] Bugs System
Pushed into mysql-trunk 5.6.1-m4 (revid:alik@sun.com-20100830082732-n2eyijnv86exc5ci) (version source revid:alik@sun.com-20100830082732-n2eyijnv86exc5ci) (merge vers: 5.6.1-m4) (pib:21)
[30 Aug 2010 8:33] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100830082745-n6sh01wlwh3itasv) (version source revid:alik@sun.com-20100830082745-n6sh01wlwh3itasv) (pib:21)
[30 Aug 2010 8:36] Bugs System
Pushed into mysql-5.5 5.5.7-m3 (revid:alik@sun.com-20100830082727-5ac4czrxl61w9wle) (version source revid:alik@sun.com-20100830082727-5ac4czrxl61w9wle) (merge vers: 5.5.7-m3) (pib:21)
[31 Aug 2010 20:05] Paul Dubois
Noted in 5.5.7, 5.6.1 changelogs.

The plugin_ftparser.h and plugin_audit.h include files are part of 
the public API/ABI, but they were not tested by the ABI check.