Bug #52410 Test "mysqld--help-*": further output differences
Submitted: 27 Mar 2010 18:43 Modified: 20 May 2010 16:00
Reporter: Joerg Bruehe Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:5.5.3-m3 OS:Any
Assigned to: Alexander Nozdrin CPU Architecture:Any
Triage: Triaged: D3 (Medium) / R1 (None/Negligible) / E2 (Low)

[27 Mar 2010 18:43] Joerg Bruehe
Description:
Found during the build of 5.5.3-m3:

FreeBSD seems to use different network policies:
=====
main.mysqld--help-notwin                 [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.mysqld--help-notwin
--- /PATH/mysql-test/r/mysqld--help-notwin.result
+++ /PATH/mysql-test/r/mysqld--help-notwin.reject
@@ -841,7 +841,7 @@
 myisam-use-mmap FALSE
 net-buffer-length 16384
 net-read-timeout 30
-net-retry-count 10
+net-retry-count 1000000
 net-write-timeout 60
 new FALSE
 old FALSE

mysqltest: Result content mismatch
=====

RPM builds install to a different path:
=====
main.mysqld--help-notwin                 [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.mysqld--help-notwin
--- /PATH/mysql-test/r/mysqld--help-notwin.result
+++ /PATH/mysql-test/r/mysqld--help-notwin.reject
@@ -912,7 +912,7 @@
 slave-type-conversions
 slow-launch-time 2
 slow-query-log FALSE
-socket /tmp/mysql.sock
+socket /var/lib/mysql/mysql.sock
 sort-buffer-size 2097152
 sporadic-binlog-dump-fail FALSE
 sql-mode

mysqltest: Result content mismatch
=====

On Windows, a separator line survives the Perl postprocessing:
=====
main.mysqld--help-win                    [ retry-fail ]
        Test ended at YYYY-MM-DD HH:MM:SS

CURRENT_TEST: main.mysqld--help-win
--- /PATH/mysql-test/r/mysqld--help-win.result
+++ /PATH/mysql-test/r/mysqld--help-win.reject
@@ -725,6 +725,7 @@
  connection before closing it

 Variables (--variable-name=value)
+------------------------------------------------- ------------------------
 abort-slave-event-count 0
 allow-suspicious-udfs FALSE
 auto-increment-increment 1

mysqltest: Result content mismatch
=====

How to repeat:
Run the test suite.

Suggested fix:
FreeBSD: Check the reason.

RPM: that difference to tar.gz installs is correct.

Windows: Why does Perl post-processing not eliminate that line?
[29 Apr 2010 11:25] Bjørn Munch
The value of net_retry_count is explicitly set to 1000000 for freebsd in configure.in. This was done sometime last millennium with an explanation "Adding fix for interrupted reads".  Just my observation...
[4 May 2010 16:09] Alexander Nozdrin
Joerg,

it seems the bug on Windows is not reproducible with the latest
mysql-trunk-bugfixing (built out of source).

Where can I find the binaries to reproduce this problem?
[4 May 2010 18:11] Joerg Bruehe
These differences were encountered during the 5.5.3-m3 release build,
so the published binaries (packages) should show them.
[5 May 2010 14:08] Alexander Nozdrin
Could not reproduce with downloaded mysql-noinstall-5.5.3-m3-win32.zip
on Windows XP 32bit.
[5 May 2010 14:41] Joerg Bruehe
The failure is shown in the latest log of tests during the build of 5.5.3-m3 on our 32 bit Windows host.

It also is shown in a previous log of tests during the build of 5.5.3-m3 on our 64 bit Windows host. In the latest run, the suite was not taken for machine reasons, so I can only speculate about that.
[17 May 2010 15:29] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/108454

3046 Alexander Nozdrin	2010-05-17
      Patch for Bug#52410 (Test "mysqld--help-*": further output differences).
      
      That was a pure test issue -- filter implementation in Perl did not work
      on some platform (the bug occurred on Windows Server 2008 with
      Cygwin Perl 5.10.0).
[17 May 2010 15:31] Alexander Nozdrin
Pushed into trunk-bugfixing.
[20 May 2010 10:04] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100520100225-oe4iuu5kuzsx0knq) (version source revid:alik@sun.com-20100520100057-rmn5y3o3ij726bm7) (merge vers: 6.0.14-alpha) (pib:16)
[20 May 2010 10:04] Bugs System
Pushed into 5.5.5-m3 (revid:alik@sun.com-20100520100041-rf8ujv598zf86wjt) (version source revid:alik@sun.com-20100520100041-rf8ujv598zf86wjt) (merge vers: 5.5.5-m3) (pib:16)
[20 May 2010 10:06] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100520100140-5bzrtadw4w419i3m) (version source revid:alik@sun.com-20100520100049-1njm09rkvnhmysnr) (pib:16)
[20 May 2010 16:00] Paul Dubois
No changelog entry needed.