Bug #52186 Crash loading stored passwords
Submitted: 18 Mar 2010 16:00 Modified: 31 May 2010 8:16
Reporter: Michael Kress Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.16 OSS Beta OS:Microsoft Windows (XP SP2)
Assigned to: Mike Lischke CPU Architecture:Any
Tags: memory error

[18 Mar 2010 16:00] Michael Kress
Description:
Hi,

when connecting to a database using MySQL Workbench 5.1.6. OSS Beta / SQL Development, I'm encountering the following error.
What can I do in order to connect to the database?
TIA
Michael

Exception = System.AccessViolationException
Message = Es wurde versucht, im geschützten Speicher zu lesen oder zu schreiben. Dies ist häufig ein Hinweis darauf, dass anderer Speicher beschädigt ist.
FullText = System.AccessViolationException: Es wurde versucht, im geschützten Speicher zu lesen oder zu schreiben. Dies ist häufig ein Hinweis darauf, dass anderer Speicher beschädigt ist.
   bei std.basic_string<char,std::char_traits<char>,std::allocator<char> >.{ctor}(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , SByte* )
   bei MySQL.Forms.UtilitiesImpl.load_passwords()
   bei MySQL.Forms.UtilitiesImpl.find_password(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* service, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* account, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* password)
   bei MySQL.MCallback3<bool\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > \&>.cpp_callback(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a1, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a2, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a3)
   bei MySQL.Forms.DrawBoxImpl.drawbox_mouse_double_click(Object sender, MouseEventArgs e)
   bei System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Connect to a database
[18 Mar 2010 21:54] Miguel Solorzano
Thank you for the bug report. It is a remote or local server are you trying to connect?. Thanks in advance.
[19 Mar 2010 7:02] Michael Kress
Hello, the mysql server is on a remote linux server. The mysql version on that server is 5.0.77-3.el5  (CentOS 5.4). Regards, Michael
[19 Mar 2010 8:05] Michael Kress
BTW, I tried numerous reboots and reinstallations, no success.
[19 Mar 2010 12:52] Miguel Solorzano
Thank you for the feedback. Duplicate of bug: http://bugs.mysql.com/bug.php?id=52146.
[6 Apr 2010 13:50] Alfredo Kojima
This is not a duplicate, the crash dump is different. I'm also updating the title.
[19 Apr 2010 9:24] Susanne Ebrecht
Please provide error log from server.
[19 May 2010 23:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[21 May 2010 9:53] Michael Kress
Hi, I checked the scenario looking at the server's log ( /var/log/mysqld.log ), but there was not a single message during the client's crash. If you tell me how to, I can obtain more information about the error.
Michael
[28 May 2010 18:20] Johannes Taxacher
Hi Michael,
could you try with most recent release if you still see the problem? 
thanks in advance
[31 May 2010 8:16] Michael Kress
Perfect! Works like a charm now! The fault is gone, no crashes anymore while connecting.
Thanks for the effort!
Regards
Michael