Bug #51468 mysqld_multi is broken in 5.1.44
Submitted: 24 Feb 2010 17:13 Modified: 18 Jun 2010 1:02
Reporter: Pierre Dumont Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S2 (Serious)
Version:5.1.44 OS:Linux
Assigned to: Georgi Kodinov
Tags: regression
Triage: Triaged: D2 (Serious)

[24 Feb 2010 17:13] Pierre Dumont
Description:
The mysqld_multi script does not run in version 5.1.44. This seems to be due to a error in the code (extra curly brace on line 74).

How to repeat:
root@eclectik:/usr/mysql5144/bin
# ./mysqld_multi --help
Unmatched right curly bracket at ./mysqld_multi line 171, at end of line
syntax error at ./mysqld_multi line 171, near "}"
Can't use global @_ in "my" at ./mysqld_multi line 179, near "= @_"
syntax error at ./mysqld_multi line 183, near "}"
Can't use global @_ in "my" at ./mysqld_multi line 187, near "= @_"
syntax error at ./mysqld_multi line 195, near "}"
Can't use global $1 in "my" at ./mysqld_multi line 208, near "= $1"
Illegal declaration of subroutine main::report_mysqlds at ./mysqld_multi line 235.
root@eclectik:/usr/mysql5144/bin
#

This does not happen with version 5.1.42:
root@eclectik:/usr/mysql5142/bin
# ./mysqld_multi --help
mysqld_multi version 2.16 by Jani Tolonen

Description:
mysqld_multi can be used to start, or stop any number of separate
mysqld processes running in different TCP/IP ports and UNIX sockets.

etc, etc, ...

I could not test version 5.1.43.

Suggested fix:
Remove line 74 in mysqld_multi
[24 Feb 2010 18:15] Godofredo Miguel Solorzano
miguel@hegel:~/dbs/5.1/bin$ ../libexec/mysqld --version
../libexec/mysqld  Ver 5.1.45-debug for unknown-linux-gnu on x86_64 (Source distribution)
miguel@hegel:~/dbs/5.1/bin$ 

miguel@hegel:~/dbs/5.1/bin$ ./mysqld_multi --help
Unmatched right curly bracket at ./mysqld_multi line 171, at end of line
syntax error at ./mysqld_multi line 171, near "}"
Can't use global @_ in "my" at ./mysqld_multi line 179, near "= @_"
syntax error at ./mysqld_multi line 183, near "}"
Can't use global @_ in "my" at ./mysqld_multi line 187, near "= @_"
syntax error at ./mysqld_multi line 195, near "}"
Can't use global $1 in "my" at ./mysqld_multi line 208, near "= $1"
Illegal declaration of subroutine main::report_mysqlds at ./mysqld_multi line 235.
miguel@hegel:~/dbs/5.1/bin$
[24 Feb 2010 18:53] Godofredo Miguel Solorzano
Thank you for the bug report.
[26 Feb 2010 12:50] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/101627

3359 Georgi Kodinov	2010-02-26
      Bug #51468: mysqld_multi is broken in 5.1.44
      
      Fixed a syntax error in mysqld_multi.sh
[1 Mar 2010 8:43] Bugs System
Pushed into 5.1.45 (revid:joro@sun.com-20100301083827-xnimmrjg6bh33o1o) (version source revid:joro@sun.com-20100301083738-rbk1jjrfcdzd7e1t) (merge vers: 5.1.45) (pib:16)
[2 Mar 2010 14:36] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100302142746-u1gxdf5yk2bjrq3e) (version source revid:alik@sun.com-20100301100407-ligt1mmaii79ikqt) (merge vers: 6.0.14-alpha) (pib:16)
[2 Mar 2010 14:40] Bugs System
Pushed into 5.5.3-m2 (revid:alik@sun.com-20100302072233-t3uqgjzdukt1pyhe) (version source revid:alik@sun.com-20100301090215-63o2w2y16go8n53p) (merge vers: 5.5.3-m2) (pib:16)
[2 Mar 2010 14:45] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100302072432-k8xvfkgcggkwgi94) (version source revid:alik@sun.com-20100301094536-2zc4uqyy3os8san7) (pib:16)
[7 Mar 2010 20:02] Paul Dubois
Noted in 5.1.45, 5.5.3, 6.0.14 changelogs.

mysqld_multi failed due to a syntax error in the script.
[17 Jun 2010 12:21] Bugs System
Pushed into 5.1.47-ndb-7.0.16 (revid:martin.skold@mysql.com-20100617114014-bva0dy24yyd67697) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (merge vers: 5.1.46) (pib:16)
[17 Jun 2010 13:08] Bugs System
Pushed into 5.1.47-ndb-6.2.19 (revid:martin.skold@mysql.com-20100617115448-idrbic6gbki37h1c) (version source revid:martin.skold@mysql.com-20100609140708-52rvuyq4q500sxkq) (merge vers: 5.1.45-ndb-6.2.19) (pib:16)
[17 Jun 2010 13:49] Bugs System
Pushed into 5.1.47-ndb-6.3.35 (revid:martin.skold@mysql.com-20100617114611-61aqbb52j752y116) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (merge vers: 5.1.46) (pib:16)