Bug #51324 This error came up when using Workbench
Submitted: 19 Feb 2010 14:11 Modified: 8 Mar 2010 13:45
Reporter: Corey Gaspard Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.16 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any

[19 Feb 2010 14:11] Corey Gaspard
Description:
This error poped up while using Workbench.  It doesn't seem to have caused any issues that prohibit it from working.

Exception = System.AccessViolationException
Message = Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
FullText = System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at Sql_editor.check_sql(Sql_editor* , shared_ptr<Sql_editor>* , Boolean )
   at MySQL.Grt.Db.Sql.Sql_editor.check_sql()
   at MySQL.Grt.Db.Sql.SqlEditor.CheckSyntax()
   at MySQL.Grt.Db.Sql.SqlEditor.BackgroundActionTimer(Object obj, EventArgs args)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
The bug came up as soon as I connected to a local database to do some querying.  I coppied some data from the clipboard.  I have tested copying the data from the clipboard again but was unable to recreate the problem.
[23 Feb 2010 8:35] Susanne Ebrecht
Many thanks for writing a bug report.

Please let us know step by step how we can reproduce the failure.
[1 Mar 2010 11:34] Valeriy Kravchuk
Bug #51592 was marked as a duplicate of this one.
[1 Mar 2010 11:37] Valeriy Kravchuk
Bug #50817, bug #51371 and bug #51503 are likely related/duplicates of this one.
[1 Mar 2010 11:38] MySQL Verification Team
Thank you for the bug report.
[8 Mar 2010 13:45] Sergei Tkachenko
Duplicate of the bug #51815