Bug #50780 'show binary logs' debug assertion when binary logging is disabled
Submitted: 1 Feb 2010 7:58 Modified: 18 Jun 2010 1:44
Reporter: Shane Bester (Platinum Quality Contributor) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: General Severity:S1 (Critical)
Version:5.1.43-debug, 5.1.44-debug OS:Any
Assigned to: Luis Manuel Oliveira Soares CPU Architecture:Any
Tags: regression

[1 Feb 2010 7:58] Shane Bester
Description:
Version: '5.1.43-enterprise-gpl-advanced-debug'  socket: ''  port: 3306  MySQL Enterprise Server - Advanced Edition Debug (GPL)
Assertion failed: !_entered, file G:\mysql-5.1.43-winbuild\mysql-advanced-gpl-debug-5.1.43-build\include\my_dbug.h, line 29

mysqld-debug.exe!my_sigabrt_handler()[mysqld.cc:2047]
mysqld-debug.exe!raise()[winsig.c:597]
mysqld-debug.exe!abort()[abort.c:78]
mysqld-debug.exe!_wassert()[assert.c:212]
mysqld-debug.exe!Dbug_violation_helper::~Dbug_violation_helper()[my_dbug.h:29]
mysqld-debug.exe!show_binlogs()[sql_repl.cc:1609]
mysqld-debug.exe!mysql_execute_command()[sql_parse.cc:2943]
mysqld-debug.exe!mysql_parse()[sql_parse.cc:5965]
mysqld-debug.exe!dispatch_command()[sql_parse.cc:1235]
mysqld-debug.exe!do_command()[sql_parse.cc:874]
mysqld-debug.exe!handle_one_connection()[sql_connect.cc:1127]
mysqld-debug.exe!pthread_start()[my_winthread.c:85]
mysqld-debug.exe!_callthreadstart()[thread.c:295]
mysqld-debug.exe!_threadstart()[thread.c:277]
kernel32.dll!BaseThreadStart()

How to repeat:
start debug build without --log-bin
run either of these:

show binary logs;
show master logs;
[1 Feb 2010 8:38] Valeriy Kravchuk
Verified just as described with recent 5.1.44 from bzr.
[1 Feb 2010 8:44] Valeriy Kravchuk
No assertion with 5.0.90-debug, so this is a regression bug.
[1 Feb 2010 9:37] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/98797

3338 Luis Soares	2010-02-01
      BUG#50780: 'show binary logs' debug assertion when binary 
      logging is disabled
      
      The server would hit an assertion because of a DBUG violation.
      There was a missing DBUG_RETURN and instead a plain return
      was used.
      
      This patch replaces the return with DBUG_RETURN.
[5 Feb 2010 17:52] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/99510

3369 Luis Soares	2010-02-05
      BUG#50780: 'show binary logs' debug assertion when binary 
      logging is disabled
            
      The server would hit an assertion because of a DBUG violation.
      There was a missing DBUG_RETURN and instead a plain return
      was used.
            
      This patch replaces the return with DBUG_RETURN.
[7 Feb 2010 0:12] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/99550

3371 Luis Soares	2010-02-07
      BUG#50780: 'show binary logs' debug assertion when binary 
      logging is disabled
      
      Post-push fix: disabling test when running mysqld in 
                     embedded mode.
[1 Mar 2010 8:47] Bugs System
Pushed into 5.1.45 (revid:joro@sun.com-20100301083827-xnimmrjg6bh33o1o) (version source revid:joerg@mysql.com-20100212173307-ph563zr4wmoklgwd) (merge vers: 5.1.45) (pib:16)
[2 Mar 2010 14:36] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100302142746-u1gxdf5yk2bjrq3e) (version source revid:alik@sun.com-20100225090938-2j5ybqoau570mytu) (merge vers: 6.0.14-alpha) (pib:16)
[2 Mar 2010 14:41] Bugs System
Pushed into 5.5.3-m2 (revid:alik@sun.com-20100302072233-t3uqgjzdukt1pyhe) (version source revid:alexey.kopytov@sun.com-20100209075938-mmcnyf6w631ozc45) (merge vers: 5.5.2-m2) (pib:16)
[2 Mar 2010 14:46] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100302072432-k8xvfkgcggkwgi94) (version source revid:alik@sun.com-20100224135227-rcqs9pe9b2in80pf) (pib:16)
[7 Mar 2010 20:09] Paul Dubois
Noted in 5.1.45, 5.5.3, 6.0.14 changelogs.

For debug builds, SHOW BINARY LOGS caused an assertion to be raised
if binary logging was not enabled.
[17 Jun 2010 12:21] Bugs System
Pushed into 5.1.47-ndb-7.0.16 (revid:martin.skold@mysql.com-20100617114014-bva0dy24yyd67697) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (merge vers: 5.1.46) (pib:16)
[17 Jun 2010 13:09] Bugs System
Pushed into 5.1.47-ndb-6.2.19 (revid:martin.skold@mysql.com-20100617115448-idrbic6gbki37h1c) (version source revid:martin.skold@mysql.com-20100609140708-52rvuyq4q500sxkq) (merge vers: 5.1.45-ndb-6.2.19) (pib:16)
[17 Jun 2010 13:49] Bugs System
Pushed into 5.1.47-ndb-6.3.35 (revid:martin.skold@mysql.com-20100617114611-61aqbb52j752y116) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (merge vers: 5.1.46) (pib:16)