Bug #50642 ssl certs in test suite are expiring soon.
Submitted: 26 Jan 2010 21:55 Modified: 12 Mar 2010 16:26
Reporter: Matthew Montgomery Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Packaging Severity:S2 (Serious)
Version:5.1.42 OS:Any
Assigned to: Georgi Kodinov CPU Architecture:Any
Triage: Triaged: D2 (Serious)

[26 Jan 2010 21:55] Matthew Montgomery
Description:
SSL Certificates in test suite are due to expire very soon and need to be regenerated for next release.

See also Bug #42366

How to repeat:
$ for key in `ls mysql-test/std_data/*cer*pem` ; do echo "$key" ; openssl x509 -text < $key | grep "Not After"; done
mysql-test/std_data/cacert.pem
            Not After : Jan 27 10:49:46 2014 GMT
mysql-test/std_data/client-cert.pem
            Not After : Jan 28 11:04:39 2010 GMT
mysql-test/std_data/server8k-cert.pem
            Not After : Jan 28 11:12:27 2010 GMT
mysql-test/std_data/server-cert.pem
            Not After : Jan 28 10:55:13 2010 GMT
mysql-test/std_data/untrusted-cacert.pem
            Not After : Oct 15 20:12:32 2007 GMT
[26 Jan 2010 22:40] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/98258

3240 Matthew Montgomery	2010-01-26
      Bug #50642	ssl certs in test suite are expiring soon.
[28 Jan 2010 14:56] Ingo Strüwing
Starts to affect backup trees. Blocks merge to main. Please review asap. Why is this not "patch pending"?
[29 Jan 2010 4:32] Valeriy Kravchuk
Bug #50702 was marked as a duplicate of this one.
[29 Jan 2010 5:46] [ name withheld ]
Apparently, I need to make  a calendar entry to remind myself to file another bug one year from today.  Egad, people, didn't you learn anything from the last two times?  Generate the test certificates with an expiration many years out.  This isn't that hard!
[29 Jan 2010 12:33] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/98609

2844 Georgi Kodinov	2010-01-29
      Bug #50642 : ssl certs in test suite are expiring soon.
      
      Updated the certs to expire on 2015.
[29 Jan 2010 13:44] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/98620

2844 Georgi Kodinov	2010-01-29
      Bug #50642 : ssl certs in test suite are expiring soon.
      
      Updated the certs to expire on 2015. 
      Made sure they work with both yassl and openssl.
[29 Jan 2010 13:55] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/98623

2843 Georgi Kodinov	2010-01-29
      Bug #50642 : ssl certs in test suite are expiring soon.
      
      Updated the certs to expire on 2015. 
      Made sure they work with both yassl and openssl.
[29 Jan 2010 14:27] Matthias Leich
I tried the patch on the tree mysql-5.0 and the test
   ./mysql-test-run.pl --mem --big --do-test=ssl                 
passed.
[29 Jan 2010 14:31] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/98627

2844 Georgi Kodinov	2010-01-29
      Bug #50642 : ssl certs in test suite are expiring soon.
      
      Updated the certs to expire on 2015. 
      Made sure they work with both yassl and openssl.
[1 Feb 2010 22:14] Sveta Smirnova
Bug #50804 was marked as duplicate of this one.
[2 Feb 2010 16:33] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/98973

3824 Ingo Struewing	2010-02-02
      Cherry picked revid:joro@sun.com-20100129135546-6c5agn66aehnfabw
        Bug #50642 : ssl certs in test suite are expiring soon.
        
        Updated the certs to expire on 2015. 
        Made sure they work with both yassl and openssl.
      
      Merged mysql-6.0-backup.
        Added not_embedded to new backup tests.
        Renamed *_performance_schema_table to *_log_table.
     @ mysql-test/suite/backup/t/backup_misc.test
        Merged mysql-6.0-backup.
          Added not_embedded to new backup tests.
     @ mysql-test/suite/backup/t/backup_missing_db.test
        Merged mysql-6.0-backup.
          Added not_embedded to new backup tests.
     @ sql/log.cc
        Merged mysql-6.0-backup.
          Renamed *_performance_schema_table to *_log_table.
[3 Feb 2010 12:06] Bugs System
Pushed into 5.1.41-ndb-6.3.32 (revid:jonas@mysql.com-20100203120404-izv9qxpdlpllbay1) (version source revid:jonas@mysql.com-20100203120404-izv9qxpdlpllbay1) (merge vers: 5.1.41-ndb-6.3.32) (pib:16)
[4 Feb 2010 10:15] Bugs System
Pushed into 5.0.91 (revid:joro@sun.com-20100204101329-4wg1ktw00vk63o8l) (version source revid:joro@sun.com-20100129135546-6c5agn66aehnfabw) (merge vers: 5.0.90) (pib:16)
[4 Feb 2010 10:19] Bugs System
Pushed into 5.1.44 (revid:joro@sun.com-20100204101444-2j32mhqroo0iiio6) (version source revid:joro@sun.com-20100129145427-0n79l9hnk0q43ajk) (merge vers: 5.1.43) (pib:16)
[4 Feb 2010 11:36] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/99243

3071 Jonas Oreland	2010-02-03
      ndb - commit new certs (i.e bug#50642) for telco trees
[4 Feb 2010 15:28] Paul Dubois
Noted in 5.0.91, 5.1.44 changelogs.

The SSL certificates in the test suite were about to expire. They
have been updated with expiration dates in the year 2015. 

Setting report to Need Merge pending push to 5.5.x+.
[5 Feb 2010 11:47] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100204063540-9czpdmpixi3iw2yb) (version source revid:alik@sun.com-20100130220650-3md8m8w9frcwjj9f) (pib:16)
[5 Feb 2010 11:54] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100205113942-oqovjy0eoqbarn7i) (version source revid:alik@sun.com-20100204064210-ljwanqvrjs83s1gq) (merge vers: 6.0.14-alpha) (pib:16)
[5 Feb 2010 11:59] Bugs System
Pushed into 5.5.2-m2 (revid:alik@sun.com-20100203172258-1n5dsotny40yufxw) (version source revid:alik@sun.com-20100130191336-i53i9wx67n81ridm) (merge vers: 5.5.2-m2) (pib:16)
[6 Feb 2010 1:20] Paul Dubois
Noted in 5.5.2, 6.0.14 changelogs.

Setting report to Need Merge pending push to Celosia.
[10 Feb 2010 11:27] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/99803

3384 Kent Boortz	2010-02-10
      - Changes to banner text from running "configure"
      - SSL certificate update (Bug#50642)
[10 Feb 2010 23:32] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/99884

3393 Kent Boortz	2010-02-11
      - Changes to banner text from running "configure"
      - Bumped version to 7.1.1a
      - SSL certificate update (Bug#50642)
[20 Feb 2010 9:17] Bugs System
Pushed into 6.0.14-alpha (revid:ingo.struewing@sun.com-20100218152520-s4v1ld76bif06eqn) (version source revid:ingo.struewing@sun.com-20100202163243-qd2wf9hqxul3rcs8) (merge vers: 6.0.14-alpha) (pib:16)
[23 Feb 2010 2:16] Paul Dubois
Setting report to Need Merge pending push of Celosia to release tree.
[12 Mar 2010 14:07] Bugs System
Pushed into 5.1.44-ndb-7.0.14 (revid:jonas@mysql.com-20100312135944-t0z8s1da2orvl66x) (version source revid:jonas@mysql.com-20100312115609-woou0te4a6s4ae9y) (merge vers: 5.1.44-ndb-7.0.14) (pib:16)
[12 Mar 2010 14:23] Bugs System
Pushed into 5.1.44-ndb-6.2.19 (revid:jonas@mysql.com-20100312134846-tuqhd9w3tv4xgl3d) (version source revid:jonas@mysql.com-20100312060623-mx6407w2vx76h3by) (merge vers: 5.1.44-ndb-6.2.19) (pib:16)
[12 Mar 2010 14:37] Bugs System
Pushed into 5.1.44-ndb-6.3.33 (revid:jonas@mysql.com-20100312135724-xcw8vw2lu3mijrhn) (version source revid:jonas@mysql.com-20100312103652-snkltsd197l7q2yg) (merge vers: 5.1.44-ndb-6.3.33) (pib:16)
[12 Mar 2010 16:12] Paul Dubois
Setting report to Need Merge pending push of Celosia to release tree.
[12 Mar 2010 16:26] Paul Dubois
Already fixed in earlier 5.1.x, 5.5.x.