Bug #50459 "Copy Column Names" feature from Query Browser Missing in Workbench
Submitted: 19 Jan 2010 21:43 Modified: 20 Aug 2010 11:57
Reporter: Max Davis Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:5.2.11 OSS Beta OS:Microsoft Windows
Assigned to: Alfredo Kojima CPU Architecture:Any
Tags: column names, workbench

[19 Jan 2010 21:43] Max Davis
Description:
When right clicking the column name header in Query Browser it lets you "Copy Column Names". I use this feature regularly as part of my development process. I will not be able to move to Workbench until this feature is there. Please consider adding this link in the context menu for the column headers.

How to repeat:
Right click column headers from View Data or Edit Data context.

Suggested fix:
Add "Copy Column Names" to context menu. This link should put a comma separated list of column names for the queried table into the copy/paste clipboard. This feature should behave the same as it did within Query Browser.

Another very useful feature would be an option to have Workbench list all column names within the SQL Statements pane when when doing "View Data" rather then the default * wildcard. This would greatly enhance MySQL Workbench for use as a software development tool.
[5 Mar 2010 6:36] Susanne Ebrecht
Bug #50859 is set as duplicate of this bug here.
[5 Mar 2010 6:38] Susanne Ebrecht
Bug #51734 is set as duplicate of this bug here.
[5 Mar 2010 14:31] Bob Dankert
Sorry for the duplicate bug (51734) - this is something I would really like to see as it can save a ton of time while coding.
[19 Apr 2010 19:32] Alfredo Kojima
This is already available when you open the context menu for a table in the sidebar or the "Overview".
[19 Apr 2010 19:59] Max Davis
Looks like that is in there. Thanks.
[19 Jul 2010 14:11] Ralf Neubauer
Sorry, but that doesn't solve the problem. The advice 'This is already available when you open the context menu for a table in the sidebar or the "Overview".' obviously only works for simple 'select * from mytable' queries (where you could just use 'describe mytable' or so), but obviously fails for queries like:

select * from a join b using(i) join c using(j)

or

select
   a.*,
   count(*) as cnt,
   avg(a)+sin(sum(b)) as angle
from a join b using(i)
group by j

or similar. I like using "Copy Column Names" together with "Copy Row Content" to quote some result rows for use in Bug reports or E-Mails without having to use an intermediate CSV file and having to find the rows in this file again; having an option "Copy Row Content with Column names" in the viewer's context menu would be even more useful for that.
[20 Aug 2010 11:57] Johannes Taxacher
Thank you for your bug report. This issue has already been fixed in the latest released version of that product, which you can download at

  http://www.mysql.com/downloads/
[14 Sep 2010 23:25] Leonardo Herrera
Why is this closed? This is _not_ available on last version.
[28 Jan 2011 23:53] B T
This Bug is clearly not fixed. Please reopen it

Thanks,
Billy
[28 Jan 2011 23:54] B T
Also, the column names you get when copying from the context menu are each prepended by the table name. This works, but clutters up my scripts. In the Query Browser, it simply copied the column names without prepending the table name.

I would much appreciate this being part of a fix for this bug