Bug #50171 Binary Columns not shown in Visual Studio's query builder
Submitted: 8 Jan 2010 7:59 Modified: 3 Mar 2010 14:49
Reporter: Daniel Kern Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:6.2.2.0 OS:Microsoft Windows (Server 2008)
Assigned to: Reggie Burnett CPU Architecture:Any
Tags: BINARY, Query Builder, Visual Studio

[8 Jan 2010 7:59] Daniel Kern
Description:
I changed a password field called 'senha' in an 'usuarios' (users) table from varchar to binary(64) and tried to update the Table Adapter in the Visual Studio 2008 Dataset Explorer.

The only columns shown now in the query builder are the columns before the password field. The binary column and everything after is missing.

Tried changing the type to varbinary and got the same results.

Tried setting 'respect binary flags' on or off in the connection string and nothing changed either.

Any sugestions?

I'm using:
Visual Studio 2008 Professional Edition Version 9.0.30729.1 SP.
Windows Server 2008 up-to-date.
Net Framework 3.5 SP1.
MySQL Server 5.1
Connector/NET 6.2.2.0

How to repeat:
Create a table that contains a binary field and try to use the query builder from Visual Studio 2008.
[27 Jan 2010 9:19] Tonci Grgin
SS from Win2K8SE x64

Attachment: Bug50171.jpg (image/jpeg, text), 32.47 KiB.

[27 Jan 2010 9:19] Tonci Grgin
Hi Daniel and thanks for your report.

I am sorry but I can not reproduce it...
  o CREATE TABLE bug50171(id INT, g VARCHAR(255)); test, all goes fine
  o DROP... CREATE TABLE bug50171(id INT, g BINARY(64)); test, all goes fine

MSVS2008Pro 9.0.30729.1 SP1, .NET FW 3.5 SP1 on Win2K8SEx64 with c/NET 6.2.2 installed.

With "respect binary flags" set to true column is shown as System.Byte[] (correct), when it's false column is of type System.String (correct).

I know it seems obvious to you but can you provide more info on how to reproduce this problem?
[27 Jan 2010 9:21] Tonci Grgin
SS from Win2K8SE x64

Attachment: Bug50171-1.jpg (image/jpeg, text), 21.65 KiB.

[27 Jan 2010 9:23] Tonci Grgin
Daniel, sorry I misread your post... It was Query Builder not DataSet that was causing the problem.

Verified as described (see attached image).
[26 Feb 2010 21:19] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/101731

796 Reggie Burnett	2010-02-26
      - fixed bug where binary or blob columns would prevent columns after that from appearing in the
        query builder (bug #50171)
[26 Feb 2010 21:23] Reggie Burnett
Fixed in 6.0.6, 6.1.4, 6.2.3, and 6.3.1+
[3 Mar 2010 14:49] Tony Bedford
An entry has been added to the changelogs for 6.0.6, 6.1.4, 6.2.3, 6.3.1:

Binary Columns were not displayed in the Query Builder of Visual Studio.