Bug #50074 Workbench Server Administrator should be able to schedule a backup
Submitted: 5 Jan 2010 4:19 Modified: 24 Aug 2010 9:23
Reporter: Barry Galbraith Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Workbench Severity:S4 (Feature request)
Version:5.2 OSS OS:Microsoft Windows
Assigned to:
Tags: schedule backup

[5 Jan 2010 4:19] Barry Galbraith
Description:
Server Administration needs to be able to schedule a backup of a database into a single file, just like MySQLAdministrator can do.

How to repeat:
Start Workbench
Open Server Administration
Data dump has no facility to schedule a backup.

Suggested fix:
Just adding a mysqldump command line to Task Scheduler would be good.
[5 Jan 2010 10:59] Susanne Ebrecht
Many thanks for writing a feature request.

The feature you requested already exist in MySQL Enterprise Monitor.

More information about MySQL Enterprise you will find here:
http://www.mysql.com/products/enterprise/
[5 Jan 2010 21:06] Barry Galbraith
Does that mean that Workbench DOESN'T replace MySQLAdministrator?
[1 Jun 2010 21:08] hugo campos
Yeap.. unfortunatly..
[24 Aug 2010 9:23] Valerii Kravchuk
Bug #53234, bug #54917 and bug #56119 were marked as a duplicate of this one. 

Based on internal discussion the decision about this feature request (made by product management) is still the same: we are NOT going to implement scheduled backups in MySQL Workbench.
[24 Aug 2010 9:37] ahmad b
I really sorry to hear this.
Why you discontinue MySQLAdministrator, if the replacement product (mysql workbench) can not really replace all features from the old one ?
[30 Oct 2010 19:56] R. M.
This is the dumbest thing I have ever heard.

MySQL Workbench is completely useless if it can't even do the most basic and most useful thing.

I will uninstall it now and go back to MySqlAdministrator, which is not just more stable but is also a much more useful tool.

MySQL Workbench is completely bloated with unnecessary features no one ever uses but can't schedule backups. Wow. Mysql is going downhill.
[31 Oct 2010 15:46] Paulo Habl
It seems Oracle just want make our life difficult and stop using MySQL and go to their arms. Actually I am not only uninstall workbench but start to look for alternatives for mysql, that is not Oracle either - Idont want to be part of Larry's religious saga against Microsoft.

Any suggestion for an alternative open source database?
[5 Nov 2010 9:43] sanjeewa kariyawasam
oracle trying to kil our mysql by cutting down it's arms