Bug #49900 Freeing unallocated data at line 3347, '.\handler\ha_innodb.cc' on windows
Submitted: 23 Dec 2009 20:21 Modified: 24 Dec 2009 8:10
Reporter: Shane Bester (Platinum Quality Contributor) Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB Plugin storage engine Severity:S3 (Non-critical)
Version:5.5.0-m2-debug OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D3 (Medium)

[23 Dec 2009 20:21] Shane Bester
Description:
windows 32/64 bit debug binary gives these errors when closing a table that had nothing updated:

Version: '5.5.0-m2-community-debug'  socket: ''  port: 3306  MySQL Community Server - Debug (GPL)
Error: Freeing unallocated data at line 3347, '.\handler\ha_innodb.cc'

that line is in ha_innobase::close:

my_free(upd_buff, MYF(0));

valgrind on linux reported no such problem, and neither did the debug build on linux. looks windows specific.

How to repeat:
start debug binary with safemalloc enabled on windows. run:

flush tables;
drop table if exists t1;
create table t1(a smallint,b varchar(255),key(a))engine=innodb;
update t1 set b='a' where a=1;
flush tables;
[23 Dec 2009 21:35] Miguel Solorzano
Thank you for the bug report. Verified as described:

091223 19:31:50 InnoDB Plugin 1.0.5 started; log sequence number 0
091223 19:31:50 [Note] Event Scheduler: Loaded 0 events
091223 19:31:50 [Note] bin\mysqld-debug: ready for connections.
Version: '5.5.0-m2-community-debug'  socket: ''  port: 3306  MySQL Community Server - Debug (GPL)
Error: Freeing pointer out of range at line 3347, '.\handler\ha_innodb.cc'
[24 Dec 2009 7:34] Shane Bester
i guess this is a duplicate of bug #49811
[24 Dec 2009 8:10] Sergei Golubchik
Good guess :)

It really is, that's how I found bug#49811, although it took quite a bit of debugging.