Bug #49811 inconsistent usage of SAFEMALLOC in debug compilation on windows
Submitted: 18 Dec 2009 20:36 Modified: 21 Jul 2010 19:12
Reporter: Vladislav Vaintroub Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S3 (Non-critical)
Version:5.5 OS:Any
Assigned to: Vladislav Vaintroub CPU Architecture:Any
Triage: Triaged: D1 (Critical)

[18 Dec 2009 20:36] Vladislav Vaintroub
Description:
storage\innobase\CMakeLists.txt and
plugin\semisync\CMakeLists.txt 

define -DSAFEMALLOC. Other projects do not. This leads to a mismatches when using my_malloc/my_free (memory allocated with safemalloc could not be freed without by free())

How to repeat:
Read corresponding CMakeLists.txt.
[18 Dec 2009 20:40] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/95016

2924 Vladislav Vaintroub	2009-12-18
      Bug #49811: inconsistent usage of SAFEMALLOC in debug compilation on windows
      Remove per-project SAFEMALLOCs definitions, as they result in malloc/free mismatches.
[21 Dec 2009 15:39] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20091221153807-80nxoli1tw1z9bxn) (version source revid:vvaintroub@mysql.com-20091218212246-frpxcpzra8lalib0) (merge vers: 6.0.14-alpha) (pib:15)
[21 Dec 2009 15:40] Bugs System
Pushed into 5.5.1-m2 (revid:alik@sun.com-20091221153538-ifi3mxf3y10ozxin) (version source revid:vvaintroub@mysql.com-20091218203924-y3k778bc4izodvnw) (merge vers: 5.5.0-beta) (pib:15)
[21 Dec 2009 15:41] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20091221153659-d7bt0fh6mhhclxuf) (version source revid:vvaintroub@mysql.com-20091218211356-mvp3vmiia9yogqe1) (pib:15)
[24 Dec 2009 10:55] Miguel Solorzano
Bug: http://bugs.mysql.com/bug.php?id=49900 it was marked as duplicate of this one.
[8 Jan 2010 21:01] Paul Dubois
Noted in 5.5.1, 6.0.14 changelogs.

For debug builds on Windows, SAFEMALLOC was defined inconsistently,
leading to mismatches when using my_malloc() and my_free(). 

Setting report to NDI pending push to Celosia.
[21 Jul 2010 19:12] Vladislav Vaintroub
was fixed already long ago, and available in all 5.x builds