Bug #48871 Configuration Wizard Hangs on Start Service
Submitted: 18 Nov 2009 16:06 Modified: 23 Nov 2009 15:15
Reporter: Thomas Riddle Email Updates:
Status: Not a Bug Impact on me:
Category:MySQL Server: Config Wizard Severity:S1 (Critical)
Version:5.1.41 OS:Windows (Windows XP SP2)
Assigned to: CPU Architecture:Any
Tags: configuration, freezes, hangs, service, start, wizard

[18 Nov 2009 16:06] Thomas Riddle
Downloaded and installed. Installs OK but when configuring a server instance, the configuration wizard checks off the first two boxes, but on Start Service, the configuration wizard locks up and the process must be killed. I have let it run overnight, and in the morning it is still frozen. If MySQL is not configured to start as a service, the configuration wizard succeeds.

I have tried disabling antivirus, opening the port in my firewall, disabling the firewall. I tried removing MySQL, deleting MySQL registry keys, deleting the service, and then restart and reinstall. Still same behavior.

How to repeat:
Step through the configuration wizard with any combination of options. Enable start MySQL as a service. Click Execute on last page.
[18 Nov 2009 17:09] Valeriy Kravchuk
Thank you for the problem report. Please, send the results of:

echo %TMP%
echo %TEMP%

from cmd.exe. If some directory is listed, please, check if it exists.
[18 Nov 2009 20:11] Thomas Riddle
C:\Documents and Settings\admin\Desktop>echo %TMP%

C:\Documents and Settings\admin\Desktop>echo %TEMP%

I checked if the directory exists, it does. Contained within the directory are the following files:

dwlog.dll - 1KB
libmysqlinstanceconf.dll - 1468KB
[18 Nov 2009 20:19] Thomas Riddle
I tried to upload the dll to your ftp site like the Files tab explains. The FTP is denying me upload access. The file is also larger than 500KB so I can't attach it.
[18 Nov 2009 20:20] Thomas Riddle
Here it the ftp error for ftp.mysql.com:

Response:	227 Entering Passive Mode (192,9,72,98,43,23)
Command:	STOR bug-data1-48871.zip
Response:	553 Could not create file.
[18 Nov 2009 22:28] MySQL Verification Team
Could you please provide step by step instructions how to repeat this issue?. Sometimes a simple detail make the behavior not to be repeatable. Thanks in advance.
[19 Nov 2009 14:08] Thomas Riddle
You were right. If I choose an Multifunctional or Transactional database type using InnoDB, the service fails to start. However, if I use a Non-transactional database, the service starts successfully. I looked in my event log and I received the following MySQL application errors:

The description for Event ID ( 100 ) in Source ( MySQL ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: 

Plugin 'FEDERATED' is disabled.

Plugin 'InnoDB' init function returned error.

Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

Unknown/unsupported table type: INNODB


All these errors have the same MySQL error type: 100. Does anybody know what these errors mean?
[19 Nov 2009 16:42] Thomas Riddle
I just uninstalled, deleted all mysql registry keys, and rebooted. Reinstalled version 5.1.41 msi installation.

Then I performed these exact steps:

-Installed with Typical Config
-Server Instance Configuration Wizard started
-Detailed Configuration
-Server Machine
-Multifunctional DB
-C:\Installation Path
-Decision Support
-TCP/IP Enabled : port 3306
-Strict Mode Enabled
-UTF8 Character Set
-Install as Windows Service and Launch Automatically
-Did not modify security settings
-Press Execute

MySL configuration wizard still hangs on "Start Service". The wizard does not hang if I use non-transactional database. Please advise on a fix.
[19 Nov 2009 16:50] Thomas Riddle
I looked in my MySQL .err file in the hidden application data folder and found this error:

 InnoDB :: Unable to create temporary file; errno: 2
[23 Nov 2009 13:30] Thomas Riddle
Helllooo? Does anybody read these? I can't even get MySQL configured....
[23 Nov 2009 15:15] Thomas Riddle
Finally solved it. It was a combination of McAfee blocking MySQL from registering as a service and not completely uninstalling the MySQL program.
[25 Nov 2009 11:00] Saad Shakil
I am having the same issue as of the latest 5.1 stable release.  I am on XP.
[25 Nov 2009 11:04] Saad Shakil
Following advice above and choosing 'non transactional database', the wizard was able to get to 'start service'.  Now I get this error message:

"The security settings could not be applied to the database because the connection has failed with the following error.

Error Nr. 1045
Access denied for user 'root'@'localhost' (using password: NO)

If a personal firewall is running on your machine, please make sure you have opened the TCP port 3306 for connections. Otherwise no client application can connect to the server. After you have opened the port please press [Retry] to apply the security settings.

If you are re-installing after you just uninstalled the MySQL server please note that the data directory was not removed automatically. Therefore the old password from your last installation is still needed to connect to the server. In this case please select skip now and re-run the Configuration Wizard from the start menu."
[25 Nov 2009 11:05] Saad Shakil
Firewall is completely off (relevant connection is unchecked in "Advanced" tab), and Exception was added.
[25 Nov 2009 12:06] Saad Shakil
These steps finally got me into the "mysql" command with a password on the root user:
1. create service with only non-transactional db, and without security check (uncheck both the set admin pass and create anon options)
2. ensure the mysql service is runnable (using windows task manager, look for mysql.exe)
3. stop mysql service from windows services screen (right click my computer, manage, services)
4. start the service by opening a cmd prompt(1) and going to installationdir\bin\mysqld --skip-grant-tables
4. log into mysql by opening another cmd prompt(2) and running:
mysql -u root
5. open another cmd prompt(3) and run the command "mysqladmin flush-privileges" to enable grant tables again; this is needed for step 5
5. set a password for root user by going to prompt# 2 and enterring:
 SET PASSWORD FOR root@'localhost' = PASSWORD('newpwd'); 

I had no problems with mysql in the past; however, today's experience and the many hours spent on this issue has been frustrating and disappointing.

Please fix this issue.
[17 Dec 2009 12:54] Meiji KIMURA
For the cause of the error 'The description for Event ID ( 100 ) in Source ( MySQL )
cannot be found.' 
and workaround, See Bug #48042.
[15 Sep 2010 16:58] Alexander Batishchev
5.1.50 x64
Windows Server 2008 non-R2 x64
Hangs on Start Service with any setup options
[18 Nov 2010 17:53] John Lorz
FYI to anyone still having this problem.

The installation wizard was hanging while attempting to install mysql-essential-5.0.92-win32.msi on a Gateway GT5676 running Windows 7 Ultimate. I have installed MySQL and deleted it several times over the past few years and could not get the install wizard to step past the Start Service checkbox. It would simply hang with no error messages.

The solution that worked for me was to edit the registry and remove all references to MySQL.

I rebooted and was able to successfully complete the install.
[18 Nov 2010 20:20] Alexander Batishchev
John, sounds good. But what the registry keys to edit?
[26 Nov 2010 11:25] David Ickringill
My first time trying to install MYSQL.

Having read the above replies I am lost as to which registry entries to remove??
[3 Dec 2010 19:34] Eric Eskildsen
The registry fix worked for me as well. I just searched for and deleted every key and value that contained the string "MySQL" and didn't appear to be related to another program (e.g., PHP). Then I deleted the data folder that the MySQL installation warns you isn't removed when you uninstall MySQL (for me it was C:\Documents and Settings\All Users\Application Data\MySQL\MySQL Server 5.1\data).
[3 Dec 2010 19:47] David Ickringill
Thanks for the reply. I am not too confident messing with the registry. I did manage to install on another machine and did nothing at all different, all working well! Registry editing scares me, so I will leave it for now!
[2 Mar 2011 0:52] Matthew Sadowski
View Eric Eskildsen comment at the end. Deleting the MySql directory from the Application Data folder and uninstalling/reinstalling MySql as a service everything worked well. Good work man.
[11 Mar 2011 16:30] Donald Likens
I had this problem today with version Server version: 5.5.9 MySQL Community Server (GPL). Configuration wizard
[13 Apr 2012 15:49] B Turtelboom
This actually worked =D whoppa!
[30 Jan 2013 22:35] Philippe Leclercq
I'm just facing the same bug with 5.5.29 on W2K8 Enterprise R2. Cleaning all MySQL occurences in the registry and removing all MySQL directories works !
[13 Aug 2013 20:14] pj villarta
clearing out the registry and data folders prior to reinstalling mysql did it for me too. i was trying to install mysql 5.5.33. thanks you to those who shared their solutions and workarounds. cheers!
[11 Sep 2015 3:16] VijayKumar Kovi
Clearing the Registry entries and deleting "C:\ProgramData\MySQL" folder fixed the issue for me.