Bug #48042 The description for Event ID ( 100 ) in Source ( MySQL ) cannot be found. The lo
Submitted: 14 Oct 2009 14:49 Modified: 18 Jun 2010 1:32
Reporter: Muhammad Owais Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Errors Severity:S2 (Serious)
Version:5.1 OS:Microsoft Windows
Assigned to: Vladislav Vaintroub
Tags: The description for Event ID ( 100 ) in Source ( MySQL ) cannot be found. The lo
Triage: Triaged: D4 (Minor)

[14 Oct 2009 14:49] Muhammad Owais
Description:
The description for Event ID ( 100 ) in Source ( MySQL ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Plugin 'FEDERATED' is disabled.

How to repeat:
Many times
[14 Oct 2009 16:13] Valerii Kravchuk
Thank you for the problem report. What exact version of MySQL server, 5.1.x, do you use? Please, upload also the entire MySQL error log (it is usually the <hostname>.err file in the data directory).
[15 Nov 2009 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[9 Dec 2009 19:36] Chris Calender
I see this same notification in the event viewer.  I'm not sure if it is a bug though, or expected.  But I can supply the requested information, nonetheless.

MySQL Version: 5.1.41-enterprise-gpl-advanced

Event Viewer:

The description for Event ID 100 from source MySQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

Plugin 'FEDERATED' is disabled.

The specified image file did not contain a resource section

Corresponding MySQL Error log:

091209 13:03:17  InnoDB: Starting shutdown...
091209 13:03:18  InnoDB: Shutdown completed; log sequence number 0 1407960
091209 13:03:18 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: Shutdown complete

091209 13:03:36 [Note] Plugin 'FEDERATED' is disabled.
091209 13:03:36  InnoDB: Started; log sequence number 0 1407960
091209 13:03:36 [Note] Event Scheduler: Loaded 0 events
091209 13:03:36 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.41-enterprise-gpl-advanced'  socket: ''  port: 3307  MySQL Enterprise Server - Advanced Edition (GPL)
[12 Dec 2009 0:11] Meiji KIMURA
I could reproduce this behavior by using Enterprise Advance 5.1.40sp1, so I looked into this detail.
Some binary provided by MySQL missed 'MessageTable' in the binary, so the event log viewer cannot display proper message.

We can check the windows executable file for their resources by using resource editor.

XNResourceEditor 3.0.0.1
http://www.wilsonc.demon.co.uk/d10resourceeditor.htm

When using this tool, mysql should display this resources, 
# 'abc' is the icon for Message Table.

MessageTable
+-1
  +-abc English(United States)

Id        String
C0000064  %1For more information, see Help and Support Center at http://www.mysql.com.

And enterprise binary should display the additional resource.

XP Theme Manifest
+-1
  +-1001 English(United States)

# '1001' is icon for XP Theme Manifest, and contents is ommited in this explanation.

I checked some official binaries for Windows, some binaries missed one of them, or all.
When 'MessageTable' is missed, Windows event log cannot display event message properly.

[Suggest to fix]
Please add proper resourced to 'mysqld.exe'.
[12 Dec 2009 0:32] Meiji KIMURA
[Workaround]

We can add proper 'MessageTable' by using XN Resource Editor. Here are the procedure for that.

(1) Download and run 'XN Resource Editor' (use admin priv, if you need).
(2) Open 'mysqld.exe'. (I recommend to backup original mysqld.exe for another directory.)
(3) Select 'Resource'-'Add Resource', and select 'MessageTable'.

On TreeView, you can see this.('abc' is the icon for MessageTable.)

MessageTable
+-1
  +-abc Language Neutral

(4) Select 'Lanuage Neutral' and Properties by right click menu.
(5) Select 'English(United states)' as Language.
(6) Select 'Strings'-'Add String' or push 'ins' key.
(7) Please input the text for ID(100) Message as belows,

%1For more information, see Help and Support Center at http://www.mysql.com.

(8) Select that string and 'Change ID' by right clike menu.
(9) Change ID from '00000001' to 'C0000064'.
(10) Save and exit XN Resource Editor.

I supposed that you will see the proper message on Windows event viewer.
[13 Dec 2009 9:27] Meiji KIMURA
I could add the proper string both 32-bit and 64-bit binary with XN resource editor.
[6 Apr 2010 5:18] Meiji KIMURA
Latest MySQL 5.5.0-m2's status is the same as before. It doesn't have proper resources.
[26 Apr 2010 22:11] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/106574

3358 Vladislav Vaintroub	2010-04-26
      Bug #48042 The description for Event ID ( 100 ) in Source ( MySQL ) cannot be found. 
      
      The problem is that message resource  (message.rc) is compiled as part of static library
      sql.lib rather than with executable mysqld.exe. resource files do not work in static
      libraries.
      
      The fix is to add message.rc to mysqld.exe source files list.
[27 Apr 2010 9:27] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/106590

4044 Vladislav Vaintroub	2010-04-27 [merge]
      Bug#48042: manual merge
[27 Apr 2010 9:38] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/106597

3021 Vladislav Vaintroub	2010-04-27
      Bug#48042 The description for Event ID ( 100 ) in Source ( MySQL ) cannot be found. 
            
      The problem is that message resource  (message.rc) is compiled as part of static library
      sql.lib rather than with executable mysqld.exe. resource files do not work in static
      libraries.
            
      The fix is to add message.rc to mysqld.exe source files list.
[5 May 2010 15:15] Bugs System
Pushed into 5.1.47 (revid:joro@sun.com-20100505145753-ivlt4hclbrjy8eye) (version source revid:vvaintroub@mysql.com-20100426215950-iyxbtej5bhf70hqh) (merge vers: 5.1.47) (pib:16)
[7 May 2010 9:21] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100507091908-vqyhpwf2km0aokno) (version source revid:alik@sun.com-20100507091737-12vceffs11elb25g) (merge vers: 6.0.14-alpha) (pib:16)
[7 May 2010 9:22] Bugs System
Pushed into 5.5.5-m3 (revid:alik@sun.com-20100507091655-349gwq21ursz8y4p) (version source revid:alik@sun.com-20100507091655-349gwq21ursz8y4p) (merge vers: 5.5.5-m3) (pib:16)
[7 May 2010 9:23] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100507091823-nzao4h3qosau4tin) (version source revid:alik@sun.com-20100507091720-ib9r8uny2aeazvas) (pib:16)
[13 May 2010 0:31] Paul Dubois
Noted in 5.1.47, 5.5.5, 6.0.14 changelogs.

On Windows, the server failed to find a description for Event ID 100.
[28 May 2010 5:58] Bugs System
Pushed into mysql-next-mr (revid:alik@sun.com-20100524190136-egaq7e8zgkwb9aqi) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (pib:16)
[28 May 2010 6:27] Bugs System
Pushed into 6.0.14-alpha (revid:alik@sun.com-20100524190941-nuudpx60if25wsvx) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (merge vers: 5.1.46) (pib:16)
[28 May 2010 6:55] Bugs System
Pushed into 5.5.5-m3 (revid:alik@sun.com-20100524185725-c8k5q7v60i5nix3t) (version source revid:alexey.kopytov@sun.com-20100429203306-tg0wz4y2xyx8edrl) (merge vers: 5.5.5-m3) (pib:16)
[17 Jun 2010 12:01] Bugs System
Pushed into 5.1.47-ndb-7.0.16 (revid:martin.skold@mysql.com-20100617114014-bva0dy24yyd67697) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (merge vers: 5.1.46) (pib:16)
[17 Jun 2010 12:42] Bugs System
Pushed into 5.1.47-ndb-6.2.19 (revid:martin.skold@mysql.com-20100617115448-idrbic6gbki37h1c) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (merge vers: 5.1.46) (pib:16)
[17 Jun 2010 13:28] Bugs System
Pushed into 5.1.47-ndb-6.3.35 (revid:martin.skold@mysql.com-20100617114611-61aqbb52j752y116) (version source revid:vasil.dimov@oracle.com-20100331130613-8ja7n0vh36a80457) (merge vers: 5.1.46) (pib:16)