Bug #48783 Net 6.2 Stored Procedure Name Not Showing Up in VS 2008
Submitted: 15 Nov 2009 19:16 Modified: 17 Nov 2009 17:47
Reporter: King Coffee Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.2.1 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[15 Nov 2009 19:16] King Coffee
Description:
I created a Stored Procedure in VS 2008 Connector/NET 6.2 and saved it successfully. It does not show up in VS 2008. However, it does show up in another DB management application. 

How to repeat:
I think if you install the new net 6.2.1 application and try it create and save a stored procedure in visual studio 2008, you should notice the problem.

Suggested fix:
update and release rev 6.2.2
[16 Nov 2009 8:57] Tonci Grgin
Hi King and thanks for your report.

I tried repeating with 6.2.0 and 6.2.1 and I just cant. I was using simple procedures (no parameters and with one input parameter) similar to:
CREATE PROCEDURE `bug48783`(
IN param1 INT
)
BEGIN
  SELECT SLEEP(param1);
END

My environment:
  o MySQL server 5.1.31x64 on remote OpenSolaris host
  o MySQL c/NET 6.2.0 and 6.2.1 msi installed with "Complete" option
  o Client box with Win2K8x64 SE and both VS2005 and 2008 (Pro)

Connection string is as follows:
server=opensol;User Id=root;Persist Security Info=True;database=test;Allow User Variables=True;Functions Return String=True;Ignore Prepare=False;Respect Binary Flags=False;Use Affected Rows=True;pooling=False
[16 Nov 2009 22:06] King Coffee
Sorry, I probably did not express it clearly. The Store Proceduce is saved ok, but the VS 2008 Standard Server Explorer box shows several directories, like Tables, Views, Procedures, etc. The Procedure folder is blank. I'm running on Windows Vista.

Thanks,
King
[16 Nov 2009 22:14] King Coffee
PS: I think it did show up the first time of use... but I delete it and what's when the problems started.

King
[17 Nov 2009 2:57] King Coffee
Hi,

I'm still trying to let it to recognizes store procedures. I tried runn the program with a revsion of your connection string. I get error:

Keyword not supported.
Parameter name: allow user
   variables 

I only install the c/net code via the msi file, no other configuration action.

King
[17 Nov 2009 8:50] Tonci Grgin
King, don't know what to say...

Check your web.config and/or app.config files, GAC and such. I retried test this morning, deleting, adding... all works just fine.
Are you running this as "root" user (all privileges) or from restricted MySQL account?
[17 Nov 2009 17:47] King Coffee
Hello Tonci Grgin,

First, I would like to give my greatest thanks for all the time and effort you gave me on this problem.

Sorry, I deleted the store procedure with a second MySql DB Management App.

My environment:
  o MySQL server 5.1.31x32 on local Vista workstation
  o MySQL c/NET  6.2.1 msi installed with "Complete" option
  o VS2008 (Std)

Since, the VS2008 (Pro) and the alternative MySQL Manager apps recognizes the c/NET 6.x store proceduces... I can only assume: VS2008 (Std) has a bug. It will save the proceduces but not load them!!!

Once again, thanks,

King
[18 Nov 2009 7:18] Tonci Grgin
Yes, could be. I don't think standard versions are capable of loading plug-ins.