Bug #47792 main.lock_multi_bug38691 times out sporadically on Solaris 10
Submitted: 2 Oct 2009 12:45 Modified: 14 Jan 2011 17:26
Reporter: Alexander Nozdrin Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.4.5 (mysql-trunk), 6.0-codebase-bugfixing OS:Solaris (solaris 10)
Assigned to: CPU Architecture:Any
Tags: experimental, pb2, sporadic, test failure
Triage: Triaged: D3 (Medium)

[2 Oct 2009 12:45] Alexander Nozdrin
Description:
main.lock_multi_bug38691 times out sporadically on Solaris 10

Symptoms:
--------------------------------------------------------
main.lock_multi_bug38691 w5 [ fail ] timeout after 900 seconds
        Test ended at 2009-10-01 16:05:35

Test case timeout after 900 seconds

== /export/home/pb2/test/sb_0-784310-1254400942.04/mysql-5.4.5-beta-solaris10-sparc-test/mysql-test/var/5/log/lock_multi_bug38691.log == 
SET @odl_sync_frm = @@global.sync_frm;
SET @@global.sync_frm = OFF;
DROP TABLE IF EXISTS t1,t2,t3;
CREATE TABLE t1 (
a int(11) unsigned default NULL,
b varchar(255) default NULL,
UNIQUE KEY a (a),
KEY b (b)
);
INSERT INTO t1 VALUES (1, 1), (2, 2), (3, 3);
CREATE TABLE t2 SELECT * FROM t1;
CREATE TABLE t3 SELECT * FROM t1;
# test altering of columns that multiupdate doesn't use # normal mode # PS mode # test altering of columns that multiupdate uses # normal mode # PS mode

 == /export/home/pb2/test/sb_0-784310-1254400942.04/mysql-5.4.5-beta-solaris10-sparc-test/mysql-test/var/5/tmp/analyze-timeout-mysqld.1.err ==
mysqltest: Could not open connection 'default' after 500 attempts: 2002 Can't connect to local MySQL server through socket '/export/home/pb2/test/sb_0-784310-1254400942.04/tmp/NQYJ3hc944/5/mysqld.1.sock' (146)

 - saving '/export/home/pb2/test/sb_0-784310-1254400942.04/mysql-5.4.5-beta-solaris10-sparc-test/mysql-test/var/5/log/main.lock_multi_bug38691/' to '/export/home/pb2/test/sb_0-784310-1254400942.04/mysql-5.4.5-beta-solaris10-sparc-test/mysql-test/var/log/main.lock_multi_bug38691/'
 - found 'core' (10/5)

...

 - deleting it, already saved 5
--------------------------------------------------------

How to repeat:
http://pb2.norway.sun.com/web.py?template=mysql_show_test_failure&test_failure_id=2356852&...
[2 Oct 2009 12:46] Alexander Nozdrin
Stack trace

Attachment: bug47792_stacktrace.txt (text/plain), 11.24 KiB.

[2 Oct 2009 12:46] Alexander Nozdrin
The test case made experimental.
Pushed into mysql-trunk-bugfixing.
[6 Oct 2009 16:05] Sveta Smirnova
With 6.0-codebase-bugfixing this test crashes:

t@14 (l@14) terminated by signal ABRT (Abort)
0xffffffff7e0da054: __lwp_kill+0x0008:  bcc,a,pt  %icc,__lwp_kill+0x18  ! 0xffffffff7e0da064
Current function is Dbug_violation_helper::~Dbug_violation_helper
   29       assert(!_entered);
(dbx) where
current thread: t@14
  [1] __lwp_kill(0x0, 0x6, 0x0, 0xffffffff7e2484c0, 0xffffffff7f206a00, 0x5), at 0xffffffff7e0da054 
  [2] raise(0x6, 0x0, 0xffffffff7c43f9f0, 0xffffffff7e2484c0, 0xffffffff7f206a00, 0x0), at 0xffffffff7e071ee0 
  [3] abort(0x2, 0x1d8, 0x0, 0x1f119c, 0x1, 0x0), at 0xffffffff7e04af70 
  [4] __assert(0x100f16afa, 0x100f16b04, 0x1d, 0x0, 0x1f0e54, 0x0), at 0xffffffff7e04b214 
=>[5] Dbug_violation_helper::~Dbug_violation_helper(this = 0xffffffff7c43fe37), line 29 in "my_dbug.h"
  [6] one_thread_per_connection_end(thd = 0x1046b4df8, put_in_cache = false), line 2166 in "mysqld.cc"
  [7] handle_one_connection(arg = 0x1046b4df8), line 1171 in "sql_connect.cc"

Error log:
Version: '6.0.14-alpha-debug-log'  socket: '/users/ssmirnova/src/mysql-6.0-codebase-bugfixing/mysql-test/var/tmp/mysqld.1.sock'  port: 13000  Source distribution
Assertion failed: !_entered, file ../include/my_dbug.h, line 29
Assertion failed: !_entered, file ../include/my_dbug.h, line 29

Test log:

SET @odl_sync_frm = @@global.sync_frm;
SET @@global.sync_frm = OFF;
DROP TABLE IF EXISTS t1,t2,t3;
CREATE TABLE t1 (
a int(11) unsigned default NULL,
b varchar(255) default NULL,
UNIQUE KEY a (a),
KEY b (b)
);
INSERT INTO t1 VALUES (1, 1), (2, 2), (3, 3);
CREATE TABLE t2 SELECT * FROM t1;
CREATE TABLE t3 SELECT * FROM t1;
# test altering of columns that multiupdate doesn't use
# normal mode
# PS mode
# test altering of columns that multiupdate uses
# normal mode
# PS mode
DROP TABLE t1, t2, t3;
SET @@global.sync_frm = @odl_sync_frm;
[6 Oct 2009 16:08] Sveta Smirnova
More crash output:

CURRENT_TEST: main.lock_multi_bug38691
mysqltest: In included file "./include/wait_until_count_sessions.inc": At line 108: Error running query 'SHOW STATUS LIKE 'Threads_connected'': 2013 Lost connection to MySQL server during query

The result from queries just before the failure was:
< snip >
CREATE TABLE t2 SELECT * FROM t1;
CREATE TABLE t3 SELECT * FROM t1;
# test altering of columns that multiupdate doesn't use
# normal mode
# PS mode
# test altering of columns that multiupdate uses
# normal mode
# PS mode
DROP TABLE t1, t2, t3;
SET @@global.sync_frm = @odl_sync_frm;

More results from queries before failure can be found in /users/ssmirnova/src/mysql-6.0-codebase-bugfixing/mysql-test/var/log/lock_multi_bug38691.log
...
t@14 (l@14) terminated by signal ABRT (Abort)
0xffffffff7e0da054: __lwp_kill+0x0008:  bcc,a,pt  %icc,__lwp_kill+0x18  ! 0xffffffff7e0da064
Current function is Dbug_violation_helper::~Dbug_violation_helper
   29       assert(!_entered);
current thread: t@14
  [1] __lwp_kill(0x0, 0x6, 0x0, 0xffffffff7e2484c0, 0xffffffff7f206a00, 0x5), at 0xffffffff7e0da054 
  [2] raise(0x6, 0x0, 0xffffffff7c43f9f0, 0xffffffff7e2484c0, 0xffffffff7f206a00, 0x0), at 0xffffffff7e071ee0 
  [3] abort(0x2, 0x1d8, 0x0, 0x1f119c, 0x1, 0x0), at 0xffffffff7e04af70 
  [4] __assert(0x100f16afa, 0x100f16b04, 0x1d, 0x0, 0x1f0e54, 0x0), at 0xffffffff7e04b214 
=>[5] Dbug_violation_helper::~Dbug_violation_helper(this = 0xffffffff7c43fe37), line 29 in "my_dbug.h"
  [6] one_thread_per_connection_end(thd = 0x1046b4df8, put_in_cache = false), line 2166 in "mysqld.cc"
  [7] handle_one_connection(arg = 0x1046b4df8), line 1171 in "sql_connect.cc"
current thread: t@1
=>[1] __pollsys(0x4, 0x2, 0x0, 0x0, 0xffffffff7f200200, 0x0), at 0xffffffff7e0d9c30 
  [2] _pollsys(0xffffffff7fff9930, 0x2, 0x0, 0x0, 0x0, 0x0), at 0xffffffff7e0c89fc 
 [3] _pselect(0x2, 0xffffffff7fff9930, 0xffffffff7e244710, 0xffffffff7e244710, 0x0, 0x0), at 0xffffffff7e073bf0 
  [4] _select(0x11, 0xffffffff7fffbe60, 0x0, 0x0, 0x0, 0x2), at 0xffffffff7e073f94 
  [5] handle_connections_sockets(), line 5349 in "mysqld.cc"
  [6] main(argc = 8, argv = 0xffffffff7fffe058), line 4842 in "mysqld.cc"
current thread: t@2
[6 Oct 2009 16:09] Sveta Smirnova
6.0 was compiled with ./configure CC=cc CXX=CC CFLAGS=-Xa -m64 -mt -g CXXFLAGS=-m64 -mt -g --prefix=/users/ssmirnova/sup-t5220a/build/mysql-6.0-codebase-bugfixing --with-client-ldflags=-static --with-plugins=myisam,innobase --enable-dtrace --with-debug
[6 Oct 2009 20:46] Alexander Nozdrin
This seems to be a duplicate of Bug#47474 (mysqld hits
Dbug_violation_helper assert when compiled with Sun Studio compiler).

The bug report will be moved back to Verified if the bug will re-appear
after -bugteam trees are merged in.
[5 Oct 2010 17:32] Anitha Gopi
Re opening. This bug was closed as a duplicate of BUG#47474 which has been closed, but the test wanot moved out of the experimental group. 
http://trollheim.norway.sun.com/archive/2329363.disabled_tests.html
Validate if this bug is fixed and enable the tests
[14 Oct 2010 18:59] Sveta Smirnova
I can not repeat this problem anymore. Status set to "Verified" so test marks can be fixed.
[11 Jan 2011 8:03] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/128387

3232 Anitha Gopi	2011-01-11
      Bug#47792 : Moving test out of disabled state since the problem is not seen anymore
[11 Jan 2011 8:17] Bugs System
Pushed into mysql-5.5 5.5.9 (revid:anitha.gopi@sun.com-20110111080151-jw3ebe0og2s5ilul) (version source revid:anitha.gopi@sun.com-20110111080151-jw3ebe0og2s5ilul) (merge vers: 5.5.9) (pib:24)
[11 Jan 2011 8:20] Bugs System
Pushed into mysql-trunk 5.6.2 (revid:anitha.gopi@sun.com-20110111080922-lmetle6m7fmkpcoh) (version source revid:anitha.gopi@sun.com-20110111080922-lmetle6m7fmkpcoh) (merge vers: 5.6.2) (pib:24)
[14 Jan 2011 17:26] Paul Dubois
Changes to test suite. No changelog entry needed.