Bug #47028 Cannot drag existing tables onto EER diagram
Submitted: 31 Aug 2009 18:56 Modified: 8 Jun 2011 18:09
Reporter: James Cetrangelo Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.2 alpha OS:Microsoft Windows (XP SP3)
Assigned to: CPU Architecture:Any
Tags: drag and drop, EER

[31 Aug 2009 18:56] James Cetrangelo
Description:
Can easily create and edit new tables on an EER diagram using the toolbar.  But, existing tables cannot be dragged from the catalog onto the diagram.  Drag and drop from the catalog seems to fail regardless of how the table was created.  

How to repeat:
1. Create a new model file with WB 5.2.2 alpha, or open an existing file created with an earlier version.

2. Create a new table by double clicking the "Add table" icon in the physical schemata section.  

3. Open an EER diagram.

4. Attempt to place a table onto the EER digram by dragging it from the Catalog.  

5. Notice that nothing happens.

Suggested fix:
Wait patiently for 5.2.2 beta version.
[31 Aug 2009 20:01] James Cetrangelo
You can workaround this in the meantime by copying tables from the Model section and pasting them into the EER.
[31 Aug 2009 23:53] MySQL Verification Team
Thank you for the bug report.
[3 Sep 2009 11:08] Leif Inge Sandberg
Bug appears for Windows Vista as well. Thanks for the workaround, James!
[29 Oct 2009 9:24] Greg Bowler
I am having exactly the same problem.

Computer specifications:
Windows XP SP3, 4GB Ram, nVidia GeForce 9800GTX+, 1680x1050 resolution.

When I drag the tables from the right hand pane, they turn blue meaning the mouse click has been registered, but it acts as a single click (unlike dragging other (invalid) things, that makes the mouse pointer turn into an error symbol).
[10 Nov 2009 8:56] Johannes Taxacher
Bug #48648 has been marked as duplicate of this one
[8 Jun 2011 18:09] Paul DuBois
Noted in 5.2.34 changelog.

Dragging tables from the catalog to an EER diagram failed.