Bug #46552 Can't start nodes error 2341
Submitted: 4 Aug 2009 18:19 Modified: 11 Aug 2009 11:17
Reporter: kadir özdemir Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S1 (Critical)
Version:mysql-cluster-gpl-7.0.6-linux-x86_64-gli OS:Linux (centos)
Assigned to: Jonas Oreland CPU Architecture:Any
Triage: Triaged: D1 (Critical) / R6 (Needs Assessment) / E6 (Needs Assessment)

[4 Aug 2009 18:19] kadir özdemir
Description:
Hi,
i shutdown the cluster change the data and index memory, after increase the ram on both nodes , start node servers then start the cluster and start first node, but i get this error message.

restartCreateObj(164) file: 1
restartCreateObj(167) file: 1
restartCreateObj(168) file: 1
restartCreateObj(169) file: 1
restartCreateObj(171) file: 1
restartCreateObj(172) file: 1
restartCreateObj(173) file: 1
2009-08-04 17:30:51 [ndbd] INFO     -- dbdict/Dbdict.cpp
2009-08-04 17:30:51 [ndbd] INFO     -- DBDICT (Line: 2837) 0x0000000a
2009-08-04 17:30:51 [ndbd] INFO     -- Error handler startup shutting down system
2009-08-04 17:30:51 [ndbd] INFO     -- Error handler shutdown completed - exiting
2009-08-04 17:30:51 [ndbd] INFO     -- Angel received ndbd startup failure count 1.
2009-08-04 17:30:51 [ndbd] ALERT    -- Node 2: Forced node shutdown completed. Occured during startphase 4. Caused by error 2341: 'Internal program error (failed ndbrequire)(Internal error, programming error or missing error message, please report a bug). Temporary error, restart node'.

whats the problem here?

How to repeat:
Described in description.
[4 Aug 2009 18:20] kadir özdemir
ndb_error_report

Attachment: ndb_error_report_20090804185755.tar.bz2 (application/bzip2, text), 488.12 KiB.

[10 Aug 2009 12:00] Jonas Oreland
see http://bugs.mysql.com/bug.php?id=42962
[10 Aug 2009 12:31] Jonas Oreland
can you upload your schema ?
[10 Aug 2009 17:37] Jonas Oreland
found and have a fix...now only need to write a test prg
[11 Aug 2009 8:12] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/80537

2952 Jonas Oreland	2009-08-11
      ndb - bug#46552
        Fix so that trigger ids are always *re-allocated* on SR
[11 Aug 2009 10:59] Jonas Oreland
pushed to 7.0.7

docs: a mixture of
1) create drop index (or table with index)
2) node/system restart

could cause an crash during SR
[11 Aug 2009 11:17] Jon Stephens
Documented bugfix in the NDB-7.0.7 changelog as follows:

        Creating or dropping an index (or creating or dropping a table
        having one index or more) during a node or system restart could
        lead to a crash during system restart.