Bug #46029 rpl_innodb_bug28430 times out on certain pb2 hosts
Submitted: 8 Jul 2009 7:18 Modified: 11 Mar 2014 7:26
Reporter: Georgi Kodinov Email Updates:
Status: Can't repeat Impact on me:
None 
Category:Tests: Replication Severity:S3 (Non-critical)
Version:5.1-bugteam, 5.1 OS:Any
Assigned to: Assigned Account
Tags: experimental, pb2, sporadic, test failure
Triage: Triaged: D3 (Medium)

[8 Jul 2009 7:18] Georgi Kodinov
Description:
rpl.rpl_innodb_bug28430                  w8 [ fail ]  timeout after 900 seconds
        Test ended at 2009-07-08 00:23:13

Test case timeout after 900 seconds

== /export/home/pb2/test/sb_6-630897-1247001400.61/mysql-5.1.37-solaris10-i386-test/mysql-test/var/8/log/rpl_innodb_bug28430.log == 
SET local_time= NOW();
SET cur_user = CURRENT_USER();
SET local_uuid=UUID();
WHILE ins_count > 0 DO
INSERT INTO test.byrange_tbl VALUES (NULL, NOW(), USER(), UUID(),
ins_count,'Going to test MBR for MySQL');
SET ins_count = ins_count - 1;
END WHILE;
SELECT MAX(id) FROM test.byrange_tbl INTO del_count;
WHILE del_count > 0 DO
DELETE FROM test.byrange_tbl WHERE id = del_count;
SET del_count = del_count - 2;
END WHILE;
END|
CALL test.proc_norm();
SELECT count(*) as "Master regular" FROM test.regular_tbl;
Master regular	500
CALL test.proc_bykey();
SELECT count(*) as "Master bykey" FROM test.bykey_tbl;
Master bykey	500

 == /export/home/pb2/test/sb_6-630897-1247001400.61/mysql-5.1.37-solaris10-i386-test/mysql-test/var/8/tmp/analyze-timeout-mysqld.2.err ==
mysqltest: Could not open connection 'default' after 500 attempts: 2002 Can't connect to local MySQL server through socket '/export/home/pb2/test/sb_6-630897-1247001400.61/tmp/hHn4nuW0iS/8/mysqld.2.sock' (146)

 == /export/home/pb2/test/sb_6-630897-1247001400.61/mysql-5.1.37-solaris10-i386-test/mysql-test/var/8/tmp/analyze-timeout-mysqld.1.err ==
mysqltest: Could not open connection 'default' after 500 attempts: 2002 Can't connect to local MySQL server through socket '/export/home/pb2/test/sb_6-630897-1247001400.61/tmp/hHn4nuW0iS/8/mysqld.1.sock' (146)

 - saving '/export/home/pb2/test/sb_6-630897-1247001400.61/mysql-5.1.37-solaris10-i386-test/mysql-test/var/8/log/rpl.rpl_innodb_bug28430/' to '/export/home/pb2/test/sb_6-630897-1247001400.61/mysql-5.1.37-solaris10-i386-test/mysql-test/var/log/rpl.rpl_innodb_bug28430/'
 - found 'core', moving it to '/export/home/pb2/test/sb_6-630897-1247001400.61/mysql-5.1.37-solaris10-i386-test/mysql-test/var/log/rpl.rpl_innodb_bug28430'
 - found 'core' (0/5)

Trying 'dbx' to get a backtrace
Core generated by '/export/home/pb2/test/sb_6-630897-1247001400.61/mysql-5.1.37-solaris10-i386-test/bin/mysqltest'
Output from dbx follows. Stack trace is printed for all threads in order,
above this you should see info about which thread was the failing one.
----------------------------
For information about new features see `help changes'
To remove this message, put `dbxenv suppress_startup_message 7.6' in your .dbxrc
Reading mysqltest
core file header read successfully
Reading ld.so.1
Reading libpthread.so.1
Reading libthread.so.1
Reading libstdc++.so.6.0.3
Reading libgcc_s.so.1
Reading librt.so.1
Reading libsocket.so.1
Reading libnsl.so.1
Reading libm.so.2
Reading libc.so.1
Reading libm.so.1
Reading libaio.so.1
Reading libmd.so.1
t@1 (l@1) program terminated by signal ABRT (Abort)
0xfecf53a5: __lwp_kill+0x0015:	jae      __lwp_kill+0x23	[ 0xfecf53b3, .+0xe ]
Current function is my_write_core
dbx: warning: can't find file "/export/home/pb2/build/sb_0-630652-1246996941.85/mysql-5.1.37/mysys/stacktrace.c"
dbx: warning: see `help finding-files'
current thread: t@1

How to repeat:
run the test for bug #28430 on a solaris host enough times

Suggested fix:
n/a
[8 Jul 2009 7:33] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/78181

3013 Georgi Kodinov	2009-07-08
      Bug#38998, Bug#46029, Bug#45243, Bug#46030 making tests experimental
[8 Jul 2009 13:30] Bugs System
Pushed into 5.1.37 (revid:joro@sun.com-20090708131116-kyz8iotbum8w9yic) (version source revid:joro@sun.com-20090708073149-qxyfa5vkh1m0pvol) (merge vers: 5.1.37) (pib:11)
[9 Jul 2009 7:36] Bugs System
Pushed into 5.1.37 (revid:joro@sun.com-20090708131116-kyz8iotbum8w9yic) (version source revid:joro@sun.com-20090708073149-qxyfa5vkh1m0pvol) (merge vers: 5.1.37) (pib:11)
[10 Jul 2009 11:20] Bugs System
Pushed into 5.4.4-alpha (revid:anozdrin@bk-internal.mysql.com-20090710111017-bnh2cau84ug1hvei) (version source revid:joro@sun.com-20090708121727-rekm6n1iu4vmvcfa) (merge vers: 5.4.4-alpha) (pib:11)
[26 Aug 2009 13:45] Bugs System
Pushed into 5.1.37-ndb-7.0.8 (revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (version source revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (merge vers: 5.1.37-ndb-7.0.8) (pib:11)
[26 Aug 2009 13:46] Bugs System
Pushed into 5.1.37-ndb-6.3.27 (revid:jonas@mysql.com-20090826105955-bkj027t47gfbamnc) (version source revid:jonas@mysql.com-20090826105955-bkj027t47gfbamnc) (merge vers: 5.1.37-ndb-6.3.27) (pib:11)
[26 Aug 2009 13:48] Bugs System
Pushed into 5.1.37-ndb-6.2.19 (revid:jonas@mysql.com-20090825194404-37rtosk049t9koc4) (version source revid:jonas@mysql.com-20090825194404-37rtosk049t9koc4) (merge vers: 5.1.37-ndb-6.2.19) (pib:11)
[27 Aug 2009 16:32] Bugs System
Pushed into 5.1.35-ndb-7.1.0 (revid:magnus.blaudd@sun.com-20090827163030-6o3kk6r2oua159hr) (version source revid:jonas@mysql.com-20090826132541-yablppc59e3yb54l) (merge vers: 5.1.37-ndb-7.0.8) (pib:11)
[27 Oct 2010 10:30] Sven Sandberg
Just an update to say that this still fails in 5.5 (e.g. 2010-10-11), and that there are stack traces at http://tinyurl.com/2uheq57
[7 Jan 2011 11:41] Alfranio Correia
This is not a sporadic failure in my box:

  . x86 64 bit
  . 2.6.35-24-generic #42-Ubuntu SMP 
  . gcc (Ubuntu/Linaro 4.4.4-14ubuntu5) 4.4.5
[14 Jan 2011 18:36] Mikael Ronström
Also a not sporadic failure in my box (as long as I run
with e.g. parallel=3 and e.g. with command:
perl mysql-test-run.pl --suite=rpl --do-test=rpl_innodb --parallel=3

It times out after 900 secs.

I have a six-core x86 box with Fedora Core 12 to reproduce this.
[30 Jan 2013 18:38] Sveta Smirnova
Bug #65518 was marked as duplicate of this one.
[11 Mar 2014 7:26] Erlend Dahl
We don't see this in our internal testing any more, so closing as "can't repeat".