Bug #45823 Assertion failure in file row/row0mysql.c line 1386
Submitted: 29 Jun 2009 13:38 Modified: 19 Dec 2009 10:47
Reporter: Victor Kirkebo Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Partitions Severity:S1 (Critical)
Version:5.1.31, 5.1.31sp1, 5.1.34, 5.1.34sp1, 5.1.37 OS:Any
Assigned to: V Venkateswaran CPU Architecture:Any
Tags: BTR_PCUR_ON, core dump, coredump, regression, row0mysql.c
Triage: Triaged: D1 (Critical)

[29 Jun 2009 13:38] Victor Kirkebo
Description:
The sys_rpl_combo test suite can cause mysqld to core dump after a failed assertion.

From error log:
090628 22:26:16 InnoDB: Assertion failure in thread 19125 in file row/row0mysql.c line 1386
InnoDB: Failing assertion: node->pcur->rel_pos == BTR_PCUR_ON
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
090628 22:26:16 - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

pstack core (sparc):
-----------------  lwp# 20432 / thread# 20432  --------------------
 ffffffff7dbc79a4 _lwp_kill (b, 0, 906, 10091c4a8, 1ae664, 0) + 8
 000000010027db7c handle_segfault (b, 100797, 100400, 10091c480, 1005c694a, 22da40) + 2a8
 ffffffff7dbc2aa4 __sighndlr (b, 0, ffffffff76a3cc10, 10027d8d4, 12, 0) + c
 ffffffff7dbb6910 call_user_handler (b, 0, ffffffff76a3cc10, 0, 0, 0) + 1a0
 ffffffff7dbb6df0 sigacthandler (b, 0, ffffffff76a3cc10, 100400, 191258, ffffffff7dd48000) + 4c
 --- called from signal handler with signal 11 (SIGSEGV) ---
 0000000100464b50 row_update_for_mysql (100800, 107bb2a80, 100800, 100624228, 112d72e70, 0) + 1dc
 00000001004018a4 __1cLha_innobaseKdelete_row6MpkC_i_ (107bb1de8, 107bb18b0, 100400, 31, 112d72e70, 7) + f0
 0000000100363e70 __1cHhandlerNha_delete_row6MpkC_i_ (107bb1de8, 107bb18b0, 112d715d8, ffffffff76a3d1fc, 1004017b4, 100806fe8
) + 18
 00000001003695cc __1cMha_partitionKdelete_row6MpkC_i_ (107bb15d8, 107bb18b0, 40000, 1400, 1, 1098b55c8) + 70
 0000000100363e70 __1cHhandlerNha_delete_row6MpkC_i_ (107bb15d8, 107bb18b0, 20, 0, 10036955c, 1007f36e8) + 18
 00000001003143c8 __1cMmysql_delete6FpnDTHD_pnKTABLE_LIST_pnEItem_pnLst_sql_list_XXb_b_ (1098b55c8, 107b57748, 2, 0, ffffffff
ffffe20e, 1) + 970
 0000000100291794 __1cVmysql_execute_command6FpnDTHD__i_ (1098b55c8, 100920628, 1005c837a, 1098b6ea8, 107b57748, 1098b7370) +
 5514
 0000000100293608 __1cLmysql_parse6FpnDTHD_pkcIp3_v_ (1098b55c8, 107b575c0, 1400, ffffffff76a3fc78, 1098b6ea8, 0) + 144
 000000010028ad40 __1cQdispatch_command6FnTenum_server_command_pnDTHD_pcI_b_ (100797000, 1098b55c8, 10510b5b9, ffffffff76a3fc
78, 107b5761e, 1098b6d40) + 6ec
 000000010028a480 __1cKdo_command6FpnDTHD__b_ (1098b55c8, 1778, 1400, 1098b56b0, 3, 5f) + e0
 0000000100288fcc handle_one_connection (1098b55c8, 1098b56b0, 1, 100798088, ffffffff76a3ff48, 1840) + 14c
 ffffffff7dbc29ac _lwp_start (0, 0, 0, 0, 0, 0)

pstack core (x86):
-----------------  lwp# 19125 / thread# 19125  --------------------
 fffffd7ffed7abaa _lwp_kill () + a
 0000000000a2f099 my_write_core () + 21
 00000000007a04c8 handle_segfault () + 1d8
 fffffd7ffed75386 __sighndlr () + 6
 fffffd7ffed69c82 call_user_handler () + 252
 fffffd7ffed69e9e sigacthandler (b, 0, fffffd7ffd0be170) + de
 --- called from signal handler with signal 11 (SIGSEGV) ---
 000000000098510e row_update_for_mysql () + 266
 0000000000917b9f __1cLha_innobaseKdelete_row6MpkC_i_ () + af
 000000000087eef9 __1cHhandlerNha_delete_row6MpkC_i_ () + 29
 0000000000884685 __1cMha_partitionKdelete_row6MpkC_i_ () + 75
 000000000087eef9 __1cHhandlerNha_delete_row6MpkC_i_ () + 29
 0000000000830cd0 __1cMmysql_delete6FpnDTHD_pnKTABLE_LIST_pnEItem_pnLst_sql_list_XXb_b_ () + bf0
 00000000007b07db __1cVmysql_execute_command6FpnDTHD__i_ () + 39bb
 00000000007b50ea __1cLmysql_parse6FpnDTHD_pkcIp3_v_ () + 1ca
 00000000007abd52 __1cQdispatch_command6FnTenum_server_command_pnDTHD_pcI_b_ () + 872
 00000000007ab3d3 __1cKdo_command6FpnDTHD__b_ () + d3
 00000000007aa191 handle_one_connection () + d1
 fffffd7ffed7504b _thr_setup () + 5b
 fffffd7ffed75280 _lwp_start ()

How to repeat:
This error has happened twice (the test was run three times) when running a 12 hour test as described below. The core dumps happened approx 11 hours into the test.

bzr branch bzr+ssh://username@bk-internal.mysql.com/bzrroot/server/mysql-test-extra-5.1
cd mysql-test-extra-5.1/mysql-test/qa-suite/sys_rpl_combo/
ulimit -n 32768
perl ./run_systest_rpl.pl --config=MBR.env --monitors=replication --rpl_sys_mode=MBR --duration=43200 &>MBR5.1.34sp1.out &

MBR.env settings:
MYSQL_BASEDIR="~/mysql/mysql-advanced-5.1.34sp1-solaris10-x86_64"
STRESS_TEST_WORKDIR="/tmp/sysrplcomboMBR"
PERL_PROG="/opt/csw/bin/perl"              # Solaris-specific value

Please note that the following line has also been added to pb_iuds.tst under 
# Additional server parameters :
MYSQLTEST_PARAM_4="--mysqld=--open-files-limit=32768"
[29 Jun 2009 15:15] Victor Kirkebo
The table is partitioned:

create table tb1_eng1 (
i1 int NOT NULL auto_increment, primary key (i1),
f1 int,
f2 char (15),
f3 decimal (5,3),
f4 datetime
) engine=innodb
PARTITION BY HASH(i1) PARTITIONS 2
(PARTITION part1 DATA DIRECTORY =
'/export/home/tmp/vk136562/5.1.34sp1/sysrplcomboRBR/var/master-data-partitions/tmpdata' INDEX DIRECTORY =
'/export/home/tmp/vk136562/5.1.34sp1/sysrplcomboRBR/var/master-data-partitions/tmpindex',
PARTITION part2 DATA DIRECTORY =
'/export/home/tmp/vk136562/5.1.34sp1/sysrplcomboRBR/var/master-data-partitions/tmpdata' INDEX DIRECTORY =
'/export/home/tmp/vk136562/5.1.34sp1/sysrplcomboRBR/var/master-data-partitions/tmpindex');
[30 Jun 2009 23:13] Elena Stepanova
--------
Testcase:

use test;
drop table if exists t45823;
create table t45823 ( i int not null auto_increment, primary key (i), f varchar(16) ) engine = InnoDB partition by hash (i) partitions 2;
insert into t45823 (f) values ('Autoinc-1'); 
insert into t45823 (f) values ('Autoinc-2'); 
insert into t45823 (i,f) values (-2,'Explicit -2');
insert into t45823 (f) values ('Autoinc-3');
# ERROR 1467 (HY000): Failed to read auto-increment value from storage engine
insert into t45823 (f) values ('Autoinc-4');
insert into t45823 (i,f) values (-3,'Explicit -3');
delete from t45823 where i > 1;
# ERROR 2013 (HY000): Lost connection to MySQL server during query

--------

Reproducible on Linux and Solaris, 32- and 64-bit version (did not check Windows), starting from 5.1.31.

No crash on 5.1.30.
No crash without partitions.
No crash with MyISAM, but ERROR 1032 (HY000): Can't find record in 't45823'

While the manual says that 'the behavior of the auto-increment mechanism is not defined if a user assigns a negative value to the column', hopefully there would be a possibility to produce a better outcome than error 2013.
[1 Jul 2009 4:32] Victor Kirkebo
Also see <a href="/bug.php?id=43988">bug #43988</a> which describes the first part of what is happening in Elena's new testcase. Inserting negative values into the auto_increment field of a partitioned table caused the same results for both MyISAM and InnoDB tables. In the new testcase partitioned InnoDB and MyISAM tables give different errors when the delete command is issued at the end.
[1 Jul 2009 10:27] Shane Bester
5.1.37-debug died on the insert even:

Version: '5.1.37-debug'  socket: ''  port: 3306  Source distribution
Assertion failed: next_insert_id == 0, file .\handler.cc, line 4556

mysqld.exe!my_sigabrt_handler()[mysqld.cc:2014]
mysqld.exe!raise()[winsig.c:590]
mysqld.exe!abort()[abort.c:71]
mysqld.exe!_wassert()[assert.c:212]
mysqld.exe!handler::ha_external_lock()[handler.cc:4556]
mysqld.exe!ha_partition::external_lock()[ha_partition.cc:2657]
mysqld.exe!handler::ha_external_lock()[handler.cc:4562]
mysqld.exe!unlock_external()[lock.cc:786]
mysqld.exe!mysql_unlock_tables()[lock.cc:391]
mysqld.exe!close_thread_tables()[sql_base.cc:1336]
mysqld.exe!dispatch_command()[sql_parse.cc:1588]
mysqld.exe!do_command()[sql_parse.cc:854]
mysqld.exe!handle_one_connection()[sql_connect.cc:1127]
mysqld.exe!pthread_start()[my_winthread.c:85]
mysqld.exe!_callthreadstart()[thread.c:293]
mysqld.exe!_threadstart()[thread.c:277]
kernel32.dll!FlsSetValue()
t some variables.
s may be invalid and cause the dump to abort...
t 05E635F8=insert into t45823 (f) values ('Autoinc-4')
[5 Aug 2009 14:25] Mattias Jonsson
Looks like a duplicate of bug#43988...
[16 Aug 2009 10:07] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/80858

3070 V Narayanan	2009-08-16
      Bug#45823 Assertion failure in file row/row0mysql.c line 1386
      
      Inserting a negative value in the autoincrement column of a
      partitioned innodb table was causing the value of the auto
      increment column to wrap around into a very large positive
      value. This was causing unexpected behaviour.
      
      The current patch ensures that before calculating the next
      auto increment value, the current value is within the positive
      maximum allowed limit.
     @ mysql-test/r/partition.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Contains result files for the test case.
     @ mysql-test/t/partition.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Add tests for inserting negative auto increment values into
        the partition table.
     @ sql/field.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a function that returns the upper limits of the mysql
        integral and floating point types.
     @ sql/ha_partition.cc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Ensure that the current value is lesser than the upper limit
        for the type of the field before setting the next auto increment
        value to be calculated.
[19 Aug 2009 19:59] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/81107

3074 V Narayanan	2009-08-20
      Bug#45823 Assertion failure in file row/row0mysql.c line 1386
      
      Inserting a negative value in the autoincrement column of a
      partitioned innodb table was causing the value of the auto
      increment column to wrap around into a very large positive
      value. This was causing unexpected behaviour.
      
      The current patch ensures that before calculating the next
      auto increment value, the current value is within the positive
      maximum allowed limit.
     @ mysql-test/suite/parts/inc/partition_auto_increment.inc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds tests for performing insert,update and delete on a partition
        table with negative auto_increment values.
     @ mysql-test/suite/parts/r/partition_auto_increment_archive.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the archive engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_blackhole.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the blackhole engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_innodb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the innodb engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_memory.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the memory engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_myisam.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the myisam engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_ndb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the ndb engine.
     @ sql/field.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a function that returns the upper limits of the mysql
        integral and floating point types.
     @ sql/ha_partition.cc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Ensures that the current value is lesser than the upper limit
        for the type of the field before setting the next auto increment
        value to be calculated.
     @ sql/ha_partition.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Modifies the set_auto_increment_if_higher function to
        accept the upper limit of the auto_increment column
        and uses it to ensure that the auto_increment value is
        within limits before incrementing it.
[21 Aug 2009 2:21] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/81230

3074 V Narayanan	2009-08-21
      Bug#45823 Assertion failure in file row/row0mysql.c line 1386
      
      Inserting a negative value in the autoincrement column of a
      partitioned innodb table was causing the value of the auto
      increment column to wrap around into a very large positive
      value. This was causing unexpected behaviour.
      
      The current patch ensures that before calculating the next
      auto increment value, the current value is within the positive
      maximum allowed limit.
     @ mysql-test/suite/parts/inc/partition_auto_increment.inc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds tests for performing insert,update and delete on a partition
        table with negative auto_increment values.
     @ mysql-test/suite/parts/r/partition_auto_increment_innodb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the innodb engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_memory.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the memory engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_myisam.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the myisam engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_ndb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the ndb engine.
     @ mysql-test/suite/parts/t/partition_auto_increment_archive.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a variable that allows the Archive engine to skip tests
        that involve insertion of negative auto increment values.
     @ mysql-test/suite/parts/t/partition_auto_increment_blackhole.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a variable that allows the Blackhole engine to skip tests
        that involve insertion of negative auto increment values.
     @ sql/field.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a function that returns the upper limits of the mysql
        integral and floating point types.
     @ sql/ha_partition.cc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Ensures that the current value is lesser than the upper limit
        for the type of the field before setting the next auto increment
        value to be calculated.
     @ sql/ha_partition.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Modifies the set_auto_increment_if_higher function, to
        use the upper limit of the auto_increment column,
        to ensure that the auto_increment value is within
        limits before incrementing it.
[21 Aug 2009 8:41] Mattias Jonsson
OK to push, just some minor comments for the test case.
[21 Aug 2009 12:06] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/81280

3074 V Narayanan	2009-08-21
      Bug#45823 Assertion failure in file row/row0mysql.c line 1386
      
      Inserting a negative value in the autoincrement column of a
      partitioned innodb table was causing the value of the auto
      increment column to wrap around into a very large positive
      value. This was causing unexpected behaviour.
      
      The current patch ensures that before calculating the next
      auto increment value, the current value is within the positive
      maximum allowed limit.
     @ mysql-test/suite/parts/inc/partition_auto_increment.inc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds tests for performing insert,update and delete on a partition
        table with negative auto_increment values.
     @ mysql-test/suite/parts/r/partition_auto_increment_innodb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the innodb engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_memory.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the memory engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_myisam.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the myisam engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_ndb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the ndb engine.
     @ mysql-test/suite/parts/t/partition_auto_increment_archive.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a variable that allows the Archive engine to skip tests
        that involve insertion of negative auto increment values.
     @ mysql-test/suite/parts/t/partition_auto_increment_blackhole.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a variable that allows the Blackhole engine to skip tests
        that involve insertion of negative auto increment values.
     @ sql/field.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a function that returns the upper limits of the mysql
        integral and floating point types.
     @ sql/ha_partition.cc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Ensures that the current value is lesser than the upper limit
        for the type of the field before setting the next auto increment
        value to be calculated.
     @ sql/ha_partition.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Modifies the set_auto_increment_if_higher function, to
        use the upper limit of the auto_increment column,
        to ensure that the auto_increment value is within
        limits before incrementing it.
[1 Sep 2009 12:03] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/82112

3094 V Narayanan	2009-09-01
      Bug#45823 Assertion failure in file row/row0mysql.c line 1386
      
      Inserting a negative value in the autoincrement column of a
      partitioned innodb table was causing the value of the auto
      increment counter to wrap around into a very large positive
      value. The consequences are the same as if a very large positive
      value was inserted into a column, e.g. reduced autoincrement
      range, failure to read autoincrement counter.
      
      The current patch ensures that before calculating the next
      auto increment value, the current value is within the positive
      maximum allowed limit.
     @ mysql-test/suite/parts/inc/partition_auto_increment.inc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds tests for performing insert,update and delete on a partition
        table with negative auto_increment values.
     @ mysql-test/suite/parts/r/partition_auto_increment_innodb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the innodb engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_memory.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the memory engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_myisam.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the myisam engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_ndb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the ndb engine.
     @ mysql-test/suite/parts/t/partition_auto_increment_archive.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a variable that allows the Archive engine to skip tests
        that involve insertion of negative auto increment values.
     @ mysql-test/suite/parts/t/partition_auto_increment_blackhole.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a variable that allows the Blackhole engine to skip tests
        that involve insertion of negative auto increment values.
     @ sql/ha_partition.cc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Ensures that the current value is lesser than the upper limit
        for the type of the field before setting the next auto increment
        value to be calculated.
     @ sql/ha_partition.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Modifies the set_auto_increment_if_higher function, to take
        into account negative auto increment values when doing a
        comparison.
[4 Sep 2009 3:57] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/82392

3108 V Narayanan	2009-09-04
      Bug#45823 Assertion failure in file row/row0mysql.c line 1386
      
      Inserting a negative value in the autoincrement column of a
      partitioned innodb table was causing the value of the auto
      increment counter to wrap around into a very large positive
      value. The consequences are the same as if a very large positive
      value was inserted into a column, e.g. reduced autoincrement
      range, failure to read autoincrement counter.
      
      The current patch ensures that before calculating the next
      auto increment value, the current value is within the positive
      maximum allowed limit.
     @ mysql-test/suite/parts/inc/partition_auto_increment.inc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds tests for performing insert,update and delete on a partition
        table with negative auto_increment values.
     @ mysql-test/suite/parts/r/partition_auto_increment_innodb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the innodb engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_memory.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the memory engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_myisam.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the myisam engine.
     @ mysql-test/suite/parts/r/partition_auto_increment_ndb.result
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Result file for the ndb engine.
     @ mysql-test/suite/parts/t/partition_auto_increment_archive.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a variable that allows the Archive engine to skip tests
        that involve insertion of negative auto increment values.
     @ mysql-test/suite/parts/t/partition_auto_increment_blackhole.test
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Adds a variable that allows the Blackhole engine to skip tests
        that involve insertion of negative auto increment values.
     @ sql/ha_partition.cc
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Ensures that the current value is lesser than the upper limit
        for the type of the field before setting the next auto increment
        value to be calculated.
     @ sql/ha_partition.h
        Bug#45823 Assertion failure in file row/row0mysql.c line 1386
        
        Modifies the set_auto_increment_if_higher function, to take
        into account negative auto increment values when doing a
        comparison.
[14 Sep 2009 16:03] Bugs System
Pushed into 5.4.4-alpha (revid:alik@sun.com-20090914155317-m1g9wodmndzdj4l1) (version source revid:alik@sun.com-20090914155317-m1g9wodmndzdj4l1) (merge vers: 5.4.4-alpha) (pib:11)
[16 Sep 2009 8:14] Jon Stephens
Documented bugfix in the 5.4.4 changelog as follows:

        Inserting negative values into an AUTO_INCREMENT column of a
        partitioned table could lead to apparently unrelated errors or a
        crash of the server.

Set status to NDI, waiting for push to 5.1 tree.
[2 Oct 2009 0:19] Paul Dubois
Moved 5.4 changelog entry from 5.4.4 to 5.4.3.
[6 Oct 2009 8:59] Bugs System
Pushed into 5.1.40 (revid:joro@sun.com-20091006073316-lea2cpijh9r6on7c) (version source revid:mikael@mysql.com-20090907102257-fflwgm6rp5m5kmfw) (merge vers: 5.1.39) (pib:11)
[6 Oct 2009 9:21] Jon Stephens
Also documented fix in the 5.1.40 changelog. Closed.
[18 Dec 2009 10:34] Bugs System
Pushed into 5.1.41-ndb-7.1.0 (revid:jonas@mysql.com-20091218102229-64tk47xonu3dv6r6) (version source revid:jonas@mysql.com-20091218095730-26gwjidfsdw45dto) (merge vers: 5.1.41-ndb-7.1.0) (pib:15)
[18 Dec 2009 10:50] Bugs System
Pushed into 5.1.41-ndb-6.2.19 (revid:jonas@mysql.com-20091218100224-vtzr0fahhsuhjsmt) (version source revid:jonas@mysql.com-20091217101452-qwzyaig50w74xmye) (merge vers: 5.1.41-ndb-6.2.19) (pib:15)
[18 Dec 2009 11:05] Bugs System
Pushed into 5.1.41-ndb-6.3.31 (revid:jonas@mysql.com-20091218100616-75d9tek96o6ob6k0) (version source revid:jonas@mysql.com-20091217154335-290no45qdins5bwo) (merge vers: 5.1.41-ndb-6.3.31) (pib:15)
[18 Dec 2009 11:19] Bugs System
Pushed into 5.1.41-ndb-7.0.11 (revid:jonas@mysql.com-20091218101303-ga32mrnr15jsa606) (version source revid:jonas@mysql.com-20091218064304-ezreonykd9f4kelk) (merge vers: 5.1.41-ndb-7.0.11) (pib:15)
[19 Dec 2009 10:47] Jon Stephens
No additional changelog entries needed. Closed.