Bug #45685 Event ID:100 Default storage engine (InnoDB) is not available
Submitted: 23 Jun 2009 16:11 Modified: 13 Jul 2009 9:08
Reporter: Roger David Nay Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S3 (Non-critical)
Version:5.0.67, 5.0.83 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[23 Jun 2009 16:11] Roger David Nay
Description:
Mysql installation seems to go fine, instance wizard (last tried 10.0.15.0) gives error on "Start Service" step. error on windows event viewer: "Event ID:100 Default storage engine (InnoDB) is not available".

How to repeat:
Install the 64 bit version on Windows 2008 server.

Suggested fix:
A workaround was found of substituting the 64 bit libmysql.dll file with the 32 bit version fixed the problem.
[30 Jun 2009 13:42] MySQL Verification Team
I couldn't repeat in Windows Vista 64-bit with 5.0.83 I still get that false error message I couldn't start the service (the service actually is started).
[13 Jul 2009 9:08] Tonci Grgin
Host OS: Win2K8SE x64. Notice "c:\Program Files\MySQL\" part of path which is for x64 applications.

c:\Program Files\MySQL\MySQL Server 5.0\bin>mysql -uroot -p --port=3350 test
Enter password: ********
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 3
Server version: 5.0.84-community-nt MySQL Community Edition (GPL)

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show engines;
+------------+---------+--------------------------------------------------------
--------+
| Engine     | Support | Comment
        |
+------------+---------+--------------------------------------------------------
--------+
| MyISAM     | YES     | Default engine as of MySQL 3.23 with great performance
        |
| MEMORY     | YES     | Hash based, stored in memory, useful for temporary tabl
es      |
| InnoDB     | DEFAULT | Supports transactions, row-level locking, and foreign k
eys     |
| BerkeleyDB | NO      | Supports transactions and page-level locking
        |
| BLACKHOLE  | YES     | /dev/null storage engine (anything you write to it disa
ppears) |
| EXAMPLE    | NO      | Example storage engine
        |
| ARCHIVE    | YES     | Archive storage engine
        |
| CSV        | NO      | CSV storage engine
        |
| ndbcluster | NO      | Clustered, fault-tolerant, memory-based tables
        |
| FEDERATED  | YES     | Federated MySQL storage engine
        |
| MRG_MYISAM | YES     | Collection of identical MyISAM tables
        |
| ISAM       | NO      | Obsolete storage engine
        |
+------------+---------+--------------------------------------------------------
--------+
12 rows in set (0.00 sec)

mysql> show create table date_test;
+-----------+-------------------------------------------------------------------
--------------------------------------------------------------------------------
-------------------------------+
| Table     | Create Table

                               |
+-----------+-------------------------------------------------------------------
--------------------------------------------------------------------------------
-------------------------------+
| date_test | CREATE TABLE `date_test` (
  `id` int(11) NOT NULL auto_increment,
  `created` datetime NOT NULL,
  PRIMARY KEY  (`id`)
) ENGINE=InnoDB AUTO_INCREMENT=36 DEFAULT CHARSET=latin1 |
+-----------+-------------------------------------------------------------------
--------------------------------------------------------------------------------
-------------------------------+
1 row in set (0.02 sec)

Further more, I've never had such error on Win2K8SE x64. There were problems with UAC regarding new place Wx64 put data dir into (should be C:\ProgramData...) as it's not readable by normal user. Relocating datadir also works for me (now in datadir="C:/Program Files/MySQL/MySQL Server 5.0/Data/" while 5.1 and 6.0 are in F:\MySQL\Data\MySQL Server 5.1\data and F:\MySQL\Data\MySQL Server 6.0\data respectively) .
[3 Apr 2010 23:06] Meiji KIMURA
For the cause and workaround about Event ID:100, See Bug #48042.