Bug #45549 UDF plugin_dir path separator inconsistency & cryptic ERROR 1126 message
Submitted: 17 Jun 2009 7:10 Modified: 3 Feb 2012 15:38
Reporter: Roel Van de Paar Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: User-defined functions ( UDF ) Severity:S2 (Serious)
Version:5.0, 5.1.28 OS:Microsoft Windows
Assigned to: Kristofer Pettersson CPU Architecture:Any
Tags: Contribution, regression

[17 Jun 2009 7:10] Roel Van de Paar
Description:
Several issues seen:
o mysqld adds a '/' to the plugin_dir
o mysqld adds '/plugin' to the plugin_dir when not specified in my.ini
o '/' does not seem to work correctly ('/' and '\\' should work instead of '\' which is not allowed in syntax)

5.1.31 tests:

----------------------- No setting for plugin_dir in my.ini

mysql> show variables like '%plug%';
+---------------+---------------------------+
| Variable_name | Value                     |
+---------------+---------------------------+
| plugin_dir    | C:\mysql5.1.31\lib/plugin |
+---------------+---------------------------+
1 row in set (0.00 sec)

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'C:\mysql5.1.31\lib/plugin/lib_mysqludf_xql.dll' (errno: 2 )

----------------------- plugin_dir="C:/mysql5.1.31/lib/plugin" in my.ini

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'C:/mysql5.1.31/lib/plugin/lib_mysqludf_xql.dll' (errno: 2 )

----------------------- plugin_dir="C:\\mysql5.1.31\\lib\\plugin\\" in my.ini

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'C:\mysql5.1.31\lib\plugin\/lib_mysqludf_xql.dll' (errno: 2 )

----------------------- plugin_dir="C:\\mysql5.1.31\\lib\\plugin" in my.ini iirc

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'C:\mysql5.1.31\lib\plugin/lib_mysqludf_xql.dll' (errno: 2 )

----------------------- plugin_dir="C:" in my.ini

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'C:/lib_mysqludf_xql.dll' (errno: 2 )

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME '\\lib_mysqludf_xql.dll';
ERROR 1124 (HY000): No paths allowed for shared library

----------------------- plugin_dir="/" in my.ini

mysql> show variables like '%plug%';
+---------------+------------------+
| Variable_name | Value            |
+---------------+------------------+
| plugin_dir    | C:\mysql5.1.31\/ |
+---------------+------------------+
1 row in set (0.02 sec)

----------------------- plugin_dir="" in my.ini

mysql> show variables like '%plug%';
+---------------+-----------------+
| Variable_name | Value           |
+---------------+-----------------+
| plugin_dir    | C:\mysql5.1.31\ |
+---------------+-----------------+
1 row in set (0.02 sec)

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'C:\mysql5.1.31\/lib_mysqludf_xql.dll' (errno: 2 )

mysql> CREATE FUNCTION lib_mysqludf_xql_info RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'lib_mysqludf_xql.dll' (errno: 2 )

5.1.35 tests (test files lib_mysqludf_xql.dll (and libxml2.dll) were present in C:\, C:\mysql5.1.35\, C:\mysql5.1.35\bin\, C:\mysql5.1.35\lib\ and C:\mysql5.1.35\lib\plugins\)

----------------------- plugin_dir="\\" in my.ini

mysql> show variables like '%plug%';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| plugin_dir    | \     |
+---------------+-------+
1 row in set (0.00 sec)

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library '\/lib_mysqludf_xql.dll' (errno: 2 )

----------------------- No setting for plugin_dir in my.ini

mysql> show variables like '%plug%';
+---------------+---------------------------+
| Variable_name | Value                     |
+---------------+---------------------------+
| plugin_dir    | C:\mysql5.1.35\lib/plugin |
+---------------+---------------------------+
1 row in set (0.01 sec)

mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'C:\mysql5.1.35\lib/plugin/lib_mysqludf_xql.dll' (errno: 2 )

5.0.77 test:

----------------------- No setting for plugin_dir in my.ini

mysql> show variables like '%plug%';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| plugin_dir    |       |
+---------------+-------+
1 row in set (0.00 sec)

mysql> CREATE FUNCTION lib_mysqludf_xql_info RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
ERROR 1126 (HY000): Can't open shared library 'lib_mysqludf_xql.dll' (errno: 0 )

How to repeat:
o Download UDF here:
  http://mysqludf.com/lib_mysqludf_xql/lib_mysqludf_xql-0.9.7-dll.zip
o Try to use UDF:
  mysql> INSTALL PLUGIN lib_mysqludf_xql SONAME 'lib_mysqludf_xql.dll';
o Tested on 5.0.77, 5.1.31, 5.1.35.
o No workaround found yet

Interesting sidenote:
http://forums.mysql.com/read.php?71,232118,232494#msg-232494
Translated to English:
http://translate.google.com/translate?js=n&prev=_t&hl=en&ie=UTF-8&u=http%3A%2F%2Fforums.my...

Documentation on INSTALL PLUGIN:
http://dev.mysql.com/doc/refman/5.1/en/install-plugin.html

Suggested fix:
Fix coding
[17 Jun 2009 7:11] Roel Van de Paar
Also note bug #39116
[19 Jun 2009 20:19] Andrew Hutchings
Problem appears to be due to this line in sql_udf.cc which seems to assume Unix type paths:

strxnmov(dlpath, sizeof(dlpath) - 1, opt_plugin_dir, "/", udf->dl, NullS);
[20 Jun 2009 10:43] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/76760

2952 Andrew Hutchings	2009-06-20
      Bug #45549 Windows UDF does not work because of '/' to plugin_dir path addition bug
      
      Fix plugin and udf paths to work in Windows by using FN_LIBCHAR instead of '/' and formating the default plugin_dir variable for the OS in use.
[22 Jun 2009 18:28] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/76859

2953 Andrew Hutchings	2009-06-22
      Bug #45549 Windows UDF does not work because of '/' to plugin_dir path addition bug
      
      Get sensible error codes for dlopen() in Windows.
[22 Jun 2009 19:22] Andrew Hutchings
Got lib_mysqludf_xql.dll working, it was failing due to missing library files.

2 patches commited to this bug fix some possible path problems, mainly cosmetic (default should work OK), and displays proper error codes for the dlopen() substitute when using UDFs and plugins in Windows.

Note:  When using my patch Windows Error 126 can mean the dll is missing or one of its dependencies is missing
[22 Jun 2009 22:32] Roel Van de Paar
Setting more correct title and severity. 

Would be good to have path inconsistency fixed and windows errors made clearer.

Some more info on windows paths:
---------
The “\” path name separator character

Path name components in Windows are separated by the “\” character, which is also the escape character in MySQL. If you are using LOAD DATA INFILE or SELECT ... INTO OUTFILE, use Unix-style file names with “/” characters:

mysql> LOAD DATA INFILE 'C:/tmp/skr.txt' INTO TABLE skr;
mysql> SELECT * INTO OUTFILE 'C:/tmp/skr.txt' FROM skr;

Alternatively, you must double the “\” character:

mysql> LOAD DATA INFILE 'C:\\tmp\\skr.txt' INTO TABLE skr;
mysql> SELECT * INTO OUTFILE 'C:\\tmp\\skr.txt' FROM skr;
--------- http://dev.mysql.com/doc/refman/5.1/en/windows-vs-unix.html
[6 Aug 2009 0:13] Fernando Beleski
any news on this?

I am using older versions under Windows because of this bug...
[6 Aug 2009 0:34] Roel Van de Paar
Fernando,

Can you describe in detail the issue(s) that you are seeing? Thanks.
[6 Aug 2009 12:56] Fernando Beleski
sorry, wrong message submitted, please delete it...
[23 Dec 2009 18:07] Olivier Olivier
Hi, 

I just try with 5.1.41/Windows XP-SP3 and found no improvments.

Tried to set plugin variable with slash, backslash, double backslash, re-installed mysql in mysql folder instead of "program files" to avoid spaces in folder name, tried to create function under dos and cygwin, no change.

I don't agree with severity, it's critical as it's not possible to add UDF.

Olivier
[23 Dec 2009 18:17] Andrew Hutchings
Hello Oliver,

Can you please use the file monitor in the following utility to see what mysqld is trying to do when loading your UDF?:

http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
[23 Dec 2009 19:08] Olivier Olivier
Here are the results. I wonder if the problem is really related to "file not found" as it seems that the plugin_dir is well searched at the beginning. I also discovered that I was not using the right compiler for windows, which the could be another error cause that I'm trying to correct but the contents of the .so file aren't used at this time aren't they ?.

20:03:35,6921031	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	CreationTime: 23/12/2009 18:29:01, LastAccessTime: 23/12/2009 20:00:04, LastWriteTime: 22/12/2009 19:07:24, ChangeTime: 23/12/2009 19:17:49, AllocationSize: 8 192, EndOfFile: 18 408, FileAttributes: AC
20:03:35,6922479	mysqld.exe	3652	IRP_MJ_CREATE	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	Desired Access: Execute/Traverse, Synchronize, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Delete, AllocationSize: n/a, OpenResult: Opened
20:03:35,6923410	mysqld.exe	3652	FASTIO_ACQUIRE_FOR_SECTION_SYNCHRONIZATION	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	SyncType: SyncTypeCreateSection, PageProtection: PAGE_EXECUTE
20:03:35,6923480	mysqld.exe	3652	FASTIO_QUERY_INFORMATION	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	Type: QueryStandardInformationFile, AllocationSize: 8 192, EndOfFile: 18 408, NumberOfLinks: 1, DeletePending: False, Directory: False
20:03:35,6923539	mysqld.exe	3652	FASTIO_RELEASE_FOR_SECTION_SYNCHRONIZATION	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6923593	mysqld.exe	3652	FASTIO_ACQUIRE_FOR_SECTION_SYNCHRONIZATION	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	SyncType: SyncTypeOther
20:03:35,6923637	mysqld.exe	3652	FASTIO_RELEASE_FOR_SECTION_SYNCHRONIZATION	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6924504	mysqld.exe	3652	IRP_MJ_CLEANUP	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6924624	mysqld.exe	3652	IRP_MJ_CLOSE	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6925980	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	CreationTime: 23/12/2009 18:29:01, LastAccessTime: 23/12/2009 20:03:35, LastWriteTime: 22/12/2009 19:07:24, ChangeTime: 23/12/2009 19:17:49, AllocationSize: 8 192, EndOfFile: 18 408, FileAttributes: AC
20:03:35,6927301	mysqld.exe	3652	IRP_MJ_CREATE	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	Desired Access: Execute/Traverse, Synchronize, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Delete, AllocationSize: n/a, OpenResult: Opened
20:03:35,6928120	mysqld.exe	3652	FASTIO_ACQUIRE_FOR_SECTION_SYNCHRONIZATION	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	SyncType: SyncTypeCreateSection, PageProtection: PAGE_EXECUTE
20:03:35,6928206	mysqld.exe	3652	FASTIO_ACQUIRE_FOR_CC_FLUSH	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6928282	mysqld.exe	3652	FASTIO_RELEASE_FOR_CC_FLUSH	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6928333	mysqld.exe	3652	FASTIO_RELEASE_FOR_SECTION_SYNCHRONIZATION	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6928386	mysqld.exe	3652	FASTIO_ACQUIRE_FOR_SECTION_SYNCHRONIZATION	C:\Mysql\lib\plugin\libphonex.	SUCCESS	SyncType: SyncTypeOther
20:03:35,6928431	mysqld.exe	3652	FASTIO_RELEASE_FOR_SECTION_SYNCHRONIZATION	C:\Mysql\lib\plugin\libphonex.	SUCCESS	
20:03:35,6929333	mysqld.exe	3652	IRP_MJ_CLEANUP	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6929462	mysqld.exe	3652	IRP_MJ_CLOSE	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	
20:03:35,6930870	mysqld.exe	3652	Load Image	C:\Mysql\lib\plugin\libphonex.so	SUCCESS	Image Base: 0x10000000, Image Size: 0x9000
20:03:35,6932820	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\Mysql\bin\cygwin1.dll	NAME NOT FOUND	
20:03:35,6934123	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\WINDOWS\system32\cygwin1.dll	NAME NOT FOUND	
20:03:35,6936139	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\WINDOWS\system\cygwin1.dll	NAME NOT FOUND	
20:03:35,6937139	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\WINDOWS\cygwin1.dll	NAME NOT FOUND	
20:03:35,6939001	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\Documents and Settings\All Users\Application Data\MySQL\MySQL Server 5.1\data\cygwin1.dll	NAME NOT FOUND	
20:03:35,6940573	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\arcgis\ArcSDE\ora10gexe\bin\cygwin1.dll	NAME NOT FOUND	
20:03:35,6942462	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	D:\oracle\product\10.2.0\db_1\BIN\cygwin1.dll	NAME NOT FOUND	
20:03:35,6942876	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	D:\oracle\product\10.2.0\db_2\bin\cygwin1.dll	PATH NOT FOUND	
20:03:35,6943641	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\Program Files\ImageMagick-5.5.8-Q16\cygwin1.dll	NAME NOT FOUND	
20:03:35,6944842	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\WINDOWS\system32\cygwin1.dll	NAME NOT FOUND	
20:03:35,6945809	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\WINDOWS\cygwin1.dll	NAME NOT FOUND	
20:03:35,6947294	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\WINDOWS\system32\wbem\cygwin1.dll	NAME NOT FOUND	
20:03:35,6948825	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\WINDOWS\system32\windowspowershell\v1.0\cygwin1.dll	NAME NOT FOUND	
20:03:35,6950256	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\arcgis\ArcSDE\ora10gexe\bin\cygwin1.dll	NAME NOT FOUND	
20:03:35,6950839	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\Program Files\Fichiers communs\Ulead Systems\MPEG\cygwin1.dll	PATH NOT FOUND	
20:03:35,6951985	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	C:\Program Files\QuickTime Alternative\QTSystem\cygwin1.dll	NAME NOT FOUND	
20:03:35,6953578	mysqld.exe	3652	FASTIO_NETWORK_QUERY_OPEN	D:\oracle\sql\cygwin1.dll	NAME NOT FOUND
[23 Dec 2009 19:31] Andrew Hutchings
Hi Oliver,

In your case it cannot find the dependency 'cygwin1.dll' in any of the paths searched in that output.
[24 Dec 2009 11:46] Olivier Olivier
Thanks Andrew, the problem was there. It was searching cygwin.dll. I added it and it's ok. I suggest that the error message returns the searched file.
[25 Jan 2010 10:05] Usoa Sasigain
Hello,

How could I get a working mysql version for UDF plugin? I have Windows XP as operative system and don't know how to go through this bug.

Thank you very much
[25 Jan 2010 10:25] Andrew Hutchings
Usoa: it should work fine, please see my comments from 23rd December if you get an error
[25 Jan 2010 10:51] Usoa Sasigain
Hi Andrew,

nice to get so quick response. I have looked to all the post around this bug but couldn't make to work it. 

I downloaded this mysql version http://dev.mysql.com/downloads/mysql/5.1.html#downloads and installed, not making any change. 

And I get this error:
"Can't open shared library 'C:\plugin/lib_mysqludf_xql.dll' (errno: 2 )" 
I guess with the wrong slash between plugin and the dll name.

when I try to run "install plugin lib_mysqludf_xql soname 'lib_mysqludf_xql.dll'" comand at mysql shell.

Could you give me some clue about what's going on. Thank you very much.
[25 Jan 2010 11:07] Andrew Hutchings
Hello Usoa,

Please use this tool to try and find out what this plugin is missing (there will be a library it tries to open which it is missing):

http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

Most likely reason is it cannot find 'libxml2.dll'.

The slashes in the path should not make a difference.
[25 Jan 2010 13:11] Usoa Sasigain
Ok, I have used the tool you suggested and place correctly some missing libraries. But I'm blocked again, now the error is the next:

ERROR 1127 (HY000): Can't find symbol '_mysql_plugin_interface_version_' in library.

And I can't add here the log get from the tool because it says that it's too long.

Thank you very much
[25 Jan 2010 13:22] Andrew Hutchings
Hi Usoa,

You need the following in your CMake Makefile:

ADD_DEFINITIONS("-DMYSQL_DYNAMIC_PLUGIN")
[25 Jan 2010 13:46] Usoa Sasigain
Sorry but, could you explain that a little bit more? where I could find the CMake Makefile? 

Sorry but I'm not familiar to all this things. Once again thank you for your help.
[25 Jan 2010 13:47] Sergei Golubchik
No, you don't.

You are loading a UDF, not a plugin.
You need to use a syntax for loading UDFs - CREATE FUNCTION, see
http://dev.mysql.com/doc/refman/5.1/en/udf-compiling.html
[25 Jan 2010 14:33] Usoa Sasigain
Thank you very much Andrew and Sergei. 

Just in case it can help someone, with the help of Andrew and the tool suggested by him I added some libraries that I was missing. 

And after that with the help of Sergei I have left aside the "install plugin ..." command and use the "create function..." ones, exactly the next ones:

CREATE FUNCTION lib_mysqludf_xql_info RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_textdecl RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_pi RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_dtd RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_element RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_forest RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_concat RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE AGGREGATE FUNCTION xql_agg RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_comment RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_cdata RETURNS STRING SONAME 'lib_mysqludf_xql.dll';
CREATE FUNCTION xql_encode RETURNS STRING SONAME 'lib_mysqludf_xql.dll';

Thank you very much for your help and quick answers for both of you!
[26 Mar 2010 6:44] Peter Yau
MySQL Community Edition 5.1.45 Win32 (mysql-5.1.45-win32.msi)
Tried to install the below fulltext plugin :
Simple N-Gram fulltext plugin for MySQL (http://sites.google.com/site/mysqlbigram/home)
The file is put at C:\MySQL51\lib\plugin\bi_gramlib.so

mysql> install plugin bi_gram SONAME 'bi_gramlib.so';
ERROR 1126 (HY000): Can't open shared library 'C:\MySQL51\lib/plugin/bi_gramlib.so' (errno: 2 )

Using Process Monitor, the above command generate the below logs :
14:41:46.4268818	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql	SUCCESS	CreationTime: 2009/03/14 22:46:29, LastAccessTime: 2010/03/26 14:37:16, LastWriteTime: 2010/03/26 14:09:50, ChangeTime: 2010/03/26 14:09:50, AllocationSize: 0, EndOfFile: 0, FileAttributes: D
14:41:46.4270796	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql\plugin.MYI	SUCCESS	CreationTime: 2008/11/14 18:31:32, LastAccessTime: 2010/03/26 14:37:16, LastWriteTime: 2008/11/14 18:31:32, ChangeTime: 2009/06/12 11:16:51, AllocationSize: 4,096, EndOfFile: 1,024, FileAttributes: A
14:41:46.4272720	mysqld.exe	2068	CreateFile	C:\MySQL51\Data\mysql\plugin.MYI	SUCCESS	Desired Access: Generic Read/Write, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened
14:41:46.4274391	mysqld.exe	2068	ReadFile	C:\MySQL51\Data\mysql\plugin.MYI	SUCCESS	Offset: 0, Length: 24
14:41:46.4276120	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql	SUCCESS	CreationTime: 2009/03/14 22:46:29, LastAccessTime: 2010/03/26 14:41:46, LastWriteTime: 2010/03/26 14:09:50, ChangeTime: 2010/03/26 14:09:50, AllocationSize: 0, EndOfFile: 0, FileAttributes: D
14:41:46.4277621	mysqld.exe	2068	ReadFile	C:\MySQL51\Data\mysql\plugin.MYI	SUCCESS	Offset: 0, Length: 347
14:41:46.4279244	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql	SUCCESS	CreationTime: 2009/03/14 22:46:29, LastAccessTime: 2010/03/26 14:41:46, LastWriteTime: 2010/03/26 14:09:50, ChangeTime: 2010/03/26 14:09:50, AllocationSize: 0, EndOfFile: 0, FileAttributes: D
14:41:46.4281020	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql\plugin.MYD	SUCCESS	CreationTime: 2008/11/14 18:31:32, LastAccessTime: 2010/03/26 14:03:58, LastWriteTime: 2008/11/14 18:31:32, ChangeTime: 2009/06/12 11:16:51, AllocationSize: 0, EndOfFile: 0, FileAttributes: A
14:41:46.4283099	mysqld.exe	2068	CreateFile	C:\MySQL51\Data\mysql\plugin.MYD	SUCCESS	Desired Access: Generic Read/Write, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened
14:41:46.4285024	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql	SUCCESS	CreationTime: 2009/03/14 22:46:29, LastAccessTime: 2010/03/26 14:41:46, LastWriteTime: 2010/03/26 14:09:50, ChangeTime: 2010/03/26 14:09:50, AllocationSize: 0, EndOfFile: 0, FileAttributes: D
14:41:46.4286488	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql	SUCCESS	CreationTime: 2009/03/14 22:46:29, LastAccessTime: 2010/03/26 14:41:46, LastWriteTime: 2010/03/26 14:09:50, ChangeTime: 2010/03/26 14:09:50, AllocationSize: 0, EndOfFile: 0, FileAttributes: D
14:41:46.4287996	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql	SUCCESS	CreationTime: 2009/03/14 22:46:29, LastAccessTime: 2010/03/26 14:41:46, LastWriteTime: 2010/03/26 14:09:50, ChangeTime: 2010/03/26 14:09:50, AllocationSize: 0, EndOfFile: 0, FileAttributes: D
14:41:46.4289751	mysqld.exe	2068	QueryOpen	C:\MySQL51\Data\mysql\plugin.TRG	NAME NOT FOUND	
14:41:46.4291212	mysqld.exe	2068	QueryOpen	C:\MySQL51	SUCCESS	CreationTime: 2009/03/14 22:46:18, LastAccessTime: 2010/03/26 14:41:46, LastWriteTime: 2010/03/26 14:06:30, ChangeTime: 2010/03/26 14:06:30, AllocationSize: 0, EndOfFile: 0, FileAttributes: D
14:41:46.4292446	mysqld.exe	2068	CreateFile	C:\MySQL51\my.ini	SUCCESS	Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: Opened
14:41:46.4294022	mysqld.exe	2068	ReadFile	C:\MySQL51\my.ini	SUCCESS	Offset: 0, Length: 4,096
14:41:46.4295810	mysqld.exe	2068	ReadFile	C:\MySQL51\my.ini	SUCCESS	Offset: 4,096, Length: 4,096
14:41:46.4297277	mysqld.exe	2068	ReadFile	C:\MySQL51\my.ini	SUCCESS	Offset: 8,192, Length: 695
14:41:46.4298294	mysqld.exe	2068	ReadFile	C:\MySQL51\my.ini	END OF FILE	Offset: 8,887, Length: 4,096
14:41:46.4299246	mysqld.exe	2068	CloseFile	C:\MySQL51\my.ini	SUCCESS	
14:41:46.4301006	mysqld.exe	2068	QueryOpen	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	CreationTime: 2010/03/26 09:50:36, LastAccessTime: 2010/03/26 14:36:21, LastWriteTime: 2010/03/26 09:42:11, ChangeTime: 2010/03/26 11:02:09, AllocationSize: 16,384, EndOfFile: 16,171, FileAttributes: A
14:41:46.4302512	mysqld.exe	2068	CreateFile	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	Desired Access: Execute/Traverse, Synchronize, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Delete, AllocationSize: n/a, OpenResult: Opened
14:41:46.4303699	mysqld.exe	2068	CreateFileMapping	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	SyncType: SyncTypeCreateSection, PageProtection: PAGE_EXECUTE
14:41:46.4303808	mysqld.exe	2068	QueryStandardInformationFile	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	AllocationSize: 16,384, EndOfFile: 16,171, NumberOfLinks: 1, DeletePending: False, Directory: False
14:41:46.4303987	mysqld.exe	2068	CreateFileMapping	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	SyncType: SyncTypeOther
14:41:46.4305180	mysqld.exe	2068	CloseFile	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	
14:41:46.4306985	mysqld.exe	2068	QueryOpen	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	CreationTime: 2010/03/26 09:50:36, LastAccessTime: 2010/03/26 14:41:46, LastWriteTime: 2010/03/26 09:42:11, ChangeTime: 2010/03/26 11:02:09, AllocationSize: 16,384, EndOfFile: 16,171, FileAttributes: A
14:41:46.4308432	mysqld.exe	2068	CreateFile	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	Desired Access: Execute/Traverse, Synchronize, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: n/a, ShareMode: Read, Delete, AllocationSize: n/a, OpenResult: Opened
14:41:46.4309602	mysqld.exe	2068	CreateFileMapping	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	SyncType: SyncTypeCreateSection, PageProtection: PAGE_EXECUTE
14:41:46.4309700	mysqld.exe	2068	QueryStandardInformationFile	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	AllocationSize: 16,384, EndOfFile: 16,171, NumberOfLinks: 1, DeletePending: False, Directory: False
14:41:46.4309803	mysqld.exe	2068	CreateFileMapping	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	SyncType: SyncTypeOther
14:41:46.4311320	mysqld.exe	2068	CloseFile	C:\MySQL51\lib\plugin\bi_gramlib.so	SUCCESS	
14:41:46.4413397	mysqld.exe	2068	TCP Receive	localhost:3308 -> localhost:2221	SUCCESS	Length: 50
14:41:46.4460056	mysqld.exe	2068	TCP Send	localhost:3308 -> localhost:2221	SUCCESS	Length: 88

Please help as It do not seems to missing dependency file and this plugin is proved to be usable in other websites.  Thanks a lot.
[12 Oct 2010 19:04] Pele pelevet
I am having the same exact issue 
i am running mysql on windows vista and i coudnt figure out how to fix it thru this bundle file that is post as a patch can you guys help me ?
[12 Oct 2010 19:04] Pele pelevet
I am having the same exact issue 
i am running mysql on windows vista and i coudnt figure out how to fix it thru this bundle file that is post as a patch can you guys help me ?
[3 Feb 2012 15:38] Paul DuBois
Noted in 5.5.21, 5.6.5 changelogs.

On Windows, the server incorrectly constructed the full path name of
the plugin binary for INSTALL PLUGIN and CREATE FUNCTION ... SONAME.
[3 Feb 2012 15:38] Paul DuBois
Noted in 5.5.21, 5.6.5 changelogs.

On Windows, the server incorrectly constructed the full path name of
the plugin binary for INSTALL PLUGIN and CREATE FUNCTION ... SONAME.