Bug #45122 The driver is not registered in Visual Studio 2010 RC
Submitted: 27 May 2009 9:11 Modified: 15 Feb 2010 19:58
Reporter: Morten Andersen Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S3 (Non-critical)
Version:6.0.3 OS:Microsoft Windows (7 BETA 1)
Assigned to:

[27 May 2009 9:11] Morten Andersen
Description:
After installing the driver, it does not show up when you try to configure a connection to the server. Only the default drivers is visible.

How to repeat:

1. Install MySQL Connector using the windows installer
2. Start Visual Studio 2010 and try to add a connection using the driver

This is only tested from a fresh install of win7, using a fresh install of vs2010.
[28 May 2009 17:30] Reggie Burnett
We will fix this but VS 2010 is not RC yet. It is beta 1 and there will be significant changes in beta 2.  We are currently testing with VS 2010 and will fully support it as it gets nearer to release.
[28 Jan 2010 6:22] scott frolich
Is there any way to manually register the driver with Visual Studio 2010 or are users of 2010 totally out of luck?
[12 Feb 2010 18:18] Luis Sieira
Same problem here. So? Does anybody know wether there is a way to manually configure the connector?
[15 Feb 2010 19:58] Reggie Burnett
We are addressing VS 2010 compat with out 6.3 release.  Alpha 1 of that should be available today.
[26 Feb 2010 6:59] Bugs System
THe same problem exists on 2010 RC with connector 6.3.0. The Mysql datasource is not registered, only the defaults still show. Installed everything clean tonight -- no dice.
[12 Mar 2010 14:19] Albert Mata
I've managed to use latest GA 6.2.2 with VS2010RC.
Just add the DbProviderFactory to machine config manually for framework 4 in %SystemRoot%\Microsoft.NET\Framework\v4.0.30128\Config\machine.config
<DbProviderFactories>
<add name="MySQL Data Provider" invariant="MySql.Data.MySqlClient" description=".Net Framework Data Provider for MySQL" type="MySql.Data.MySqlClient.MySqlClientFactory, MySql.Data, Version=6.2.2.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" />
</DbProviderFactories>
[12 Apr 2010 9:20] Andreas Wickberg
Thanks a lot, this was extremely good information. It solved my problems in just under 30 seconds.
[14 Apr 2010 3:35] ling bo
Albert Mata,

Your workround doesn't work for me, i also made the same changes (except version and token) in machine.config. 

So could you remember you modified some other staffs ?
[26 May 2010 0:41] amit malhotra
It is annoying now that with the released version of VS.Net 2010 it is not working. I've to show the demo to the client while proving that no separate development is required in case you will change the DB from MS to MYSQL.
[31 May 2010 2:37] David Baines
Is there a way of manually registering the driver with VS2010?

Do we have a timeframe for the releae of 6.3?

thanks

Dave
[31 May 2010 2:38] David Baines
Is there a way of manually registering the driver in VS2010?

Do we have a timeframe for the release of ver 6.3 of the driver?

thanks

Dave
[31 May 2010 5:44] Tonci Grgin
Bug#54087 was marked as duplicate of this report.
[21 Dec 2010 16:40] David Hanson
This issue still exists under Windows 7 64-Bit and Visual Studio 2010 (official production release version).  MySql Connector 6.3.5 is being used and there is no driver registered in Visual Studio 2010.
[12 Apr 2011 1:07] Cenay Nailor
I have Windows 7 64 bit, Visual Studio 2010 Express and MySql Connector 6.3.5 and when I attempt to add a database connection, it is still not listed as an option. 

Am I completely crazy?
[12 Apr 2011 14:33] David Hanson
Just to let everyone know, I experienced the same issue several months ago when I was originally getting started with using MySQL Connector/Net with Visual Studio 2010.  I eventually got it working.  I will share what I recall doing in case it helps anyone else here:

- Reboot your computer
- Uninstall the MySQL Connector/Net
- Launch Visual Studio
- Exit Visual Studio
- Reboot your computer
- Install MySQL Connector/Net (do NOT launch VS first!)
- Reboot your computer
- Start Visual Studio

This worked for me.  Hopefully you will have the same luck!

David Hanson