Bug #43597 Fix for Bug #43410 breaks build on Power Mac due to incomplete sys/resource.h
Submitted: 12 Mar 2009 14:25 Modified: 19 Mar 2009 15:10
Reporter: Bjørn Munch Email Updates:
Status: Closed Impact on me:
None 
Category:Tools: MTR / mysql-test-run Severity:S7 (Test Cases)
Version:5.1 6.0 OS:Mac OS X
Assigned to: Bjørn Munch CPU Architecture:Any
Tags: mtr

[12 Mar 2009 14:25] Bjørn Munch
Description:
Build breaks in Pushbuild:

In file included from safe_process.cc:48:
/usr/include/sys/resource.h:81: error: field `ru_utime' has incomplete type
/usr/include/sys/resource.h:82: error: field `ru_stime' has incomplete type

This is caused by the system header file sys/resource.h neglecting to include sys/time.h

How to repeat:
Build 5.1 or 6.0 on powermacg5

Suggested fix:
Include sys/time.h ourselves in safe_process.cc, before sys/resource.h
[12 Mar 2009 14:29] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/69046

2769 Bjorn Munch	2009-03-12
      Bug #43597 Fix for Bug #43410 breaks build on Power Mac due to incomplete sys/resource.h
      Added include of sys/time.h
      modified:
        mysql-test/lib/My/SafeProcess/safe_process.cc
[12 Mar 2009 15:08] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/69048

2769 Bjorn Munch	2009-03-12
      Bug #43597 Fix for Bug 43410 breaks build on Power Mac due to incomplete sys/resource.h
      Added include of sys/time.h
      modified:
        mysql-test/lib/My/SafeProcess/safe_process.cc
[12 Mar 2009 15:52] Bjørn Munch
Pushed to 6.0-mtr and 5.1-mtr
[19 Mar 2009 12:52] Bugs System
Pushed into 5.1.34 (revid:alik@sun.com-20090319121953-frpl3uvd05v07sho) (version source revid:bjorn.munch@sun.com-20090312150713-cx9hrlrzqb0rze3x) (merge vers: 5.1.33) (pib:6)
[19 Mar 2009 12:55] Bugs System
Pushed into 6.0.11-alpha (revid:alik@sun.com-20090319122149-fpfkb3vxi7gk3guh) (version source revid:bjorn.munch@sun.com-20090312151527-9c3jrrtkby0rwk9f) (merge vers: 6.0.11-alpha) (pib:6)
[19 Mar 2009 15:10] Paul Dubois
Test suite change. No changelog entry needed.
[9 May 2009 16:41] Bugs System
Pushed into 5.1.34-ndb-6.2.18 (revid:jonas@mysql.com-20090508185236-p9b3as7qyauybefl) (version source revid:jonas@mysql.com-20090508185236-p9b3as7qyauybefl) (merge vers: 5.1.34-ndb-6.2.18) (pib:6)
[9 May 2009 17:38] Bugs System
Pushed into 5.1.34-ndb-6.3.25 (revid:jonas@mysql.com-20090509063138-1u3q3v09wnn2txyt) (version source revid:jonas@mysql.com-20090509063138-1u3q3v09wnn2txyt) (merge vers: 5.1.34-ndb-6.3.25) (pib:6)
[9 May 2009 18:36] Bugs System
Pushed into 5.1.34-ndb-7.0.6 (revid:jonas@mysql.com-20090509154927-im9a7g846c6u1hzc) (version source revid:jonas@mysql.com-20090509154927-im9a7g846c6u1hzc) (merge vers: 5.1.34-ndb-7.0.6) (pib:6)