Bug #4337 Access Violation when r-click on table
Submitted: 29 Jun 2004 23:30 Modified: 1 Dec 2004 13:40
Reporter: Bob Dankert Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:1.0.1a OS:Microsoft Windows (Win XP Pro SP2)
Assigned to: Michael G. Zinner CPU Architecture:Any

[29 Jun 2004 23:30] Bob Dankert
Description:
When I right-click to pull up the context menu of a table in the right-hand side listing, it immediately gives an access violation (see attached picture).  No menu is ever displayed.  (This may be correlated with the other access violation I am receiveing, bug #4329).

How to repeat:
Right-click on a table in the schemata view
[29 Jun 2004 23:31] Bob Dankert
Access Violation

Attachment: error.GIF (image/gif, text), 9.46 KiB.

[30 Jun 2004 9:06] Ulrich Bayer
Thank you for taking the time to write so many bug-reports!
[2 Jul 2004 22:16] [ name withheld ]
I've the same problem: first just after I clicked the 'OK' button of the connection window, It says
"Access violation at address 00974BD0 in module 'libmysqlqb.dll'. Read of address 00000000".

Then when a do a right click in the 'Schemata' tab I get:
"Access violation at address 00485A5F in module 'MySQLQueryBrowser.exe'. Read of address 00000039".

I don't remember when it started do that. But since, my 'Functions' tab is empty.

MySQL Query Browser 1.0.1-alpha.
MySQL 4.1.3-beta-win
Windows XP Pro SP1.

Laurent DEBACKER.
[13 Jul 2004 1:20] Miguel Heredia
It was working ok and then it started to show this same error.

Posible things I did:

1) It was a fresh install when it worked, after deleting anonymous users started to fail (or maybe when i was changing and moving values on mysqladmin and Mysqlcc)

2) Windows did an automatic update more or less the same time it started to fail, I got XP Sp1

Possible cause:
I guess it has something to do with the menus that apear when you right click on the table to drop it in the select,update,insert boxes, cause they dont appear anymore

Workaround ? If you change the mode to script editor (View->Script Editor) you can still create new tables and indexes.
[13 Jul 2004 1:25] Miguel Heredia
Tried both : 1.0.1 and 1.0.2 same results, Access violation at adress  003B4BD0 in module libmysqlqb.dll Read of adress: 00000000
[14 Jul 2004 12:16] Michael G. Zinner
This may have been related to Bug #4329 which now is fixed completely. Please verify the fix of this bug in the next release.