Bug #4329 Access Violation while opening Query Browser
Submitted: 29 Jun 2004 18:33 Modified: 12 Jul 2004 18:33
Reporter: Bob Dankert Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Query Browser Severity:S1 (Critical)
Version:1.0.1a OS:Microsoft Windows (Win XP Pro)
Assigned to: Michael G. Zinner CPU Architecture:Any

[29 Jun 2004 18:33] Bob Dankert
Description:
I received an error while opening query browser.  This was working fine yesterday without error, and the program still opens up.  See the screen shot for the error details.

How to repeat:
Open Query Browser
[29 Jun 2004 18:34] Bob Dankert
Access Violation

Attachment: error.JPG (image/pjpeg, text), 13.73 KiB.

[29 Jun 2004 22:27] Dean Ellis
Verifying this... I did not see it initially, but after it appeared (after using inline help) it has occurred consistently.
[5 Jul 2004 17:36] Raphael Matthias Krug
It also appeared at my system after I had openend the inline-help. I work on NT 4.0 SP 6a
[6 Jul 2004 18:03] Michael G. Zinner
Thanks for reporting. The problem seems to be caused by corrupted XML setting files which has been fixed in the new 1.0.2 release.

Could you go to the directory c:\Documents and Settings\USERNAME\Application Data\MySQL and delete the following files:

mysqlqb_history.xml
mysqlqb_options.xml
mysqlqb_bookmark.xml

Then uninstall the 1.0.1 version and install the 1.0.2 version and verify if the issues have been addressed? Thanks a lot.
[6 Jul 2004 18:09] Bob Dankert
This has resolved the issue, thanks a lot for these great products!
[12 Jul 2004 15:52] Stéphane Paquette
I have the same problem. I actually run the version 1.0.2 alpha. It works fine the first time and then I have the error every time I start the Query browser. Is there another version available for Windows XP Pro?
[12 Jul 2004 16:09] Stéphane Paquette
I deleted the xml files and it seems to be ok now. Thanks.
[12 Jul 2004 18:33] Michael G. Zinner
Thanks for pointing out that this was still an issue with 1.0.2

The bug also occured in 1.0.2 when there has been no schema selected and doing a select like SELECT * FROM 'a'.'b'; so it was written to the history XML file.

This has now been fixed in the source repository and will be in the 1.0.3 release.
[23 Nov 2004 9:33] David Welch
I am using 1.1.1.1 gamma and I am getting this error as soon as I log on to a mySQL server. This is true on three different Win 2003 and 2000 installations.

I have tried deleted the xml files just in case but in short the product is unusable.
[31 Mar 2005 1:11] Ernesto Rodriguez Ageitos
Same problem with 1.1.6. It works fine on my local computer (Windows XP), but I received this error trying to run the program on our server (Windows 2003, MySQL 4.1.10a).
[5 Apr 2005 17:20] Stéphane Nadeau
I have the same problem when I try to run mySQLQueryBrowser on the server. Tell me acces violation at adress 005B1054 in module mySQLQueryBrowser.exe, Read of adress 00000000... and the CPU run 50% to 85%.
Can't do anything with the Query Browser
[5 Apr 2005 21:45] David Bonnett
Unable to run Query Browser at all. I get the Access Violation immediately on open (QB 1.1.6 on Win XP Pro SP 1). Talking to a local database via localhost.
Deleting the xml prefs makes no difference.
[27 May 2005 14:41] nik martin
On W2K Advanced server, My SQL Query version 1.1.9.0 crashes on startup with an access violation, and then consumes 100% cpu.  The machine is locked up HARD
[18 Jun 2005 21:39] Ray Hookway
I get an access violation when trying to start the Query Browser on Windows Server 2003 SP1. This happens with both versions 1.1.6 and 1.1.10 of the Browser. The problem persists after removing the .xml files.
[29 Jun 2005 12:15] Ernesto Rodriguez Ageitos
Not very sure about what happened, I suposse a Windows update or similar, but now Query Browser works fine in the same machine I reported a couple of months ago.
[1 Feb 2006 21:39] Lonnie Best
I'm using windows 2003 server enterprise ed. I tried deleting the xml files specified above (and reinstalled QB), but I haven't yet got query browser version 1.1.19 to work on the server.

After I login to a database (using query brower) my processor untilization jumps up to about 50% and stays there. When I right click on items in the tree, the "right click menu" only displays for a fraction of a second before disappearing.

I'm trying to think what this could be..... I am running MS SQL Server 2005 on this same box, think it might be angry about my migration attempts?
[10 Apr 2006 13:02] Yahoo Serious
I also get this in 1.1.20 .
Have removed all the xml files (but not reinstalled QB), but I haven't gotten rid of it. After I startup (no database) my processor untilization jumps up to about 80% and stays there. When I click on a menu or in query tab the untilization sinks to 0%.  But it will jump right back up, at yet not identified moments.
If I right click iin the tree, the first time it only displays for a fraction of a second before disappearing. The second time seems fine.
(We run MySQL 4.1.11 on Linux and an ODBC 3.51 connection.  I also have MySQL Admin on my Win2000 PC.)

PS: why does this still have the status closed, do I need to open a new bug-item?
[10 Apr 2006 15:45] Yahoo Serious
Workaround:
It seems that for any decrease of CPU, one needs to click in a query-edit-text.

To right click in the tree, first click the item (it only displays for a fraction of
a second before disappearing). Then click in a query-edit-text. Then right-click the item in the tree again, this should get you to the context-menu.
[23 May 2006 11:10] thang
Hi,

I am having the same problem.  I am using Win 2003 server and version 1.1.2 of the query browser.  I haven't once been able to use the query browser.  The error has appeared since the first installation.  I tried reinstalling and deleting XML files with no luck.

The work around described is really confusing.  Right click on the schemata tree, then click on the text, then right click on the tree again?  The menu appears for about 100 ms.  I wasn't fast enough to catch anything useful.

Any help will be very much appreciated.
[23 May 2006 12:01] Yahoo Serious
Maybe the workaround just does not do the job for you, then you are out of luck.  But I'll try to be more explicit (in step two):
- Right click on the schemata tree on the item of which you want a submenu, 
- Left click on the Sql-query-area, which is the upper edit-box on the left. If you've never gotten QB to work, it is the edit-area on top. When you start it's sort of in the toolbar. F11 (or the View-menu) can tile it with the result-window and it gets the title "SQL query area". (Maybe it only does the job in this tiled position?)
-  Right click on the schemata tree on the item of which you want a submenu again.

The menu then stayed. For me. With my settings and circumstances.  

However, I can;t observe anything anymore: the bug (both CPU and click-problem) vanished at my system, if I check it now.  Hard to say what did it though, because I had ignored and forgotten it and I just now noticed. And a lot has changed in my situation: addition of connections on other machines, more history, other bugs, change of server-settings, change of local settings, newer driver, etc.