Bug #4241 system_mysql_db_fix.test fails
Submitted: 22 Jun 2004 1:51 Modified: 25 Jun 2004 13:08
Reporter: Sergey Petrunya Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:5.0-bk OS:
Assigned to: Ramil Kalimullin

[22 Jun 2004 1:51] Sergey Petrunya
Description:
system_mysql_db_fix.test fails in 5.0 

How to repeat:
Run ./mysql-test-run t/system_mysql_db_fix.test 

and get:

 TEST                           RESULT
------------------------------------------
system_mysql_db_fix            [ fail ]

Errors are (from /home/psergey/mysql-5.0-root/mysql-test/var/log/mysqltest-time) :
/home/psergey/mysql-5.0-root/client/mysqltest: At line 79: Result length mismatch
(the last lines may be the most important ones)
Below are the diffs between actual and expected results:
-------------------------------------------------------
*** r/system_mysql_db.result    2004-05-30 00:17:46.000000000 +0300
--- r/system_mysql_db.reject    2004-06-22 03:01:02.000000000 +0300
***************
*** 8,14 ****
  help_relation
  help_topic
  host
- proc
  tables_priv
  user
  show create table db;
--- 8,13 ----
-------------------------------------------------------
Please follow the instructions outlined at
http://www.mysql.com/doc/en/Reporting_mysqltest_bugs.html
to find the reason to this problem and how to report this.

Aborting: system_mysql_db_fix failed. To continue, re-run with '--force'.
[25 Jun 2004 10:32] Sergey Petrunya
The test passes if MySQL is not installed or the correct version of MySQL is installed.
[25 Jun 2004 12:16] Ramil Kalimullin
The cause of the bug is that we use the last found mysql_fix_privilege_tables.sql which is in the installation dir.

ChangeSet
  1.1996 04/06/25 15:09:26 ram@gw.mysql.r18.ru +1 -0
  a fix (bug #4241: system_mysql_db_fix.test fails)
[25 Jun 2004 13:08] Ramil Kalimullin
Thank you for your bug report. This issue has been committed to our
source repository of that product and will be incorporated into the
next release.

If necessary, you can access the source repository and build the latest
available version, including the bugfix, yourself. More information 
about accessing the source trees is available at
    http://www.mysql.com/doc/en/Installing_source_tree.html