Bug #42173 "named_pipes" system variable not properly defined on Windows
Submitted: 16 Jan 2009 21:20 Modified: 26 Aug 2009 2:31
Reporter: Timothy Smith Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: General Severity:S3 (Non-critical)
Version:6.0.9 OS:Microsoft Windows
Assigned to: Timothy Smith CPU Architecture:Any
Tags: named_pipes windows __NT__ _win32, regression
Triage: Triaged: D2 (Serious) / R1 (None/Negligible) / E1 (None/Negligible)

[16 Jan 2009 21:20] Timothy Smith
Description:
SHOW VARIABLES LIKE 'named_pipe' => Empty set

It should show a boolean value.

How to repeat:
In 6.0.8, the __NT__ pre-processor symbol was removed from all code, many places switched to use _WIN32 instead.

In 6.0.9, merging in a change caused an #ifdef __NT__ to sneak back in.  This means that a part of the code was missing - the part that defines the named_pipe system variable.

Suggested fix:
Use _WIN32 instead of __NT__ in set_var.cc; add test case to check for this system variable.
[16 Jan 2009 21:35] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/63485

2965 Timothy Smith	2009-01-16
      Fix bug #42173: "named_pipes" system variable not properly defined on Windows
      
      During a merge, some __NT__ crept back into the source code.  Remove all
      references to __NT__.  Add a test case to ensure that the 'named_pipe' system
      variable exists on Windows.
[16 Jan 2009 21:45] Vladislav Vaintroub
Change looks good. Thanks for catching it!
[16 Jan 2009 23:50] Patrick Crews
We want to make sure that we update:
http://dev.mysql.com/doc/refman/6.0/en/windows-source-build-cmake.html

So that the __NT__ option is properly updated to reflect these changes.
[10 Jul 2009 7:13] Sveta Smirnova
Bug does not exists in version 5.0 and 5.1
[17 Aug 2009 19:49] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/80922

2862 Timothy Smith	2009-08-17
      Add test case for Bug#42173, "named_pipes" system variable not properly defined on Windows
      
      The actual bug was already fixed, but no test case had been added.
[24 Aug 2009 13:53] Bugs System
Pushed into 5.4.4-alpha (revid:alik@sun.com-20090824135126-2rngffvth14a8bpj) (version source revid:timothy.smith@sun.com-20090817192610-sb8mw0uoholl1ods) (merge vers: 5.4.4-alpha) (pib:11)
[26 Aug 2009 2:31] Paul Dubois
Noted in 5.4.4 changelog.

The named_pipe system variable was not properly defined in Windows.
For example, SHOW VARIABLES did not display the variable.
[20 May 2010 11:16] Lars Heill
No need to backport to other versions - from dev:

"Since fixed, system vars had a big rework done.  All of them are tested [in] sys_vars, and also with mysqld--help-win in the main suite.
And named pipe works as designed in 5.5."