Bug #41622 func_str fails sporadically on pushbuild with timeout
Submitted: 19 Dec 2008 7:10 Modified: 5 Jan 2009 12:08
Reporter: Sven Sandberg Email Updates:
Status: Duplicate Impact on me:
None 
Category:Tests: Server Severity:S7 (Test Cases)
Version:6.0 OS:Any
Assigned to: CPU Architecture:Any
Tags: func_str, pushbuild, sporadic, test failure
Triage: Triaged: D3 (Medium)

[19 Dec 2008 7:10] Sven Sandberg
Description:
func_str fails sporadically on pushbuild with timeout:

main.func_str                            [ fail ]  timeout after 900 seconds
        Test ended at 2008-12-13 01:52:20

Test case timeout after 900 seconds

== /dev/shm/var-embedded-102/log/func_str.log == 
SUBSTR('foo',1,CAST(0 AS UNSIGNED))

CREATE TABLE t1 (a varchar(10), len int unsigned);
INSERT INTO t1 VALUES ('bar', 2), ('foo', 0);
SELECT SUBSTR(a,1,len) FROM t1;
SUBSTR(a,1,len)
ba

DROP TABLE t1;
CREATE TABLE t1 AS SELECT CHAR(0x414243) as c1;
SELECT HEX(c1) from t1;
HEX(c1)
414243
DROP TABLE t1;
CREATE VIEW v1 AS SELECT CHAR(0x414243) as c1;
SELECT HEX(c1) from v1;
HEX(c1)
414243
DROP VIEW v1;
End of 5.0 tests

 - saving '/dev/shm/var-embedded-102/log/main.func_str/' to '/dev/shm/var-embedded-102/log/main.func_str/'

Retrying test, attempt(2/3)...

How to repeat:
https://intranet.mysql.com/secure/pushbuild/showpush.pl?dir=bzr_mysql-6.0-rpl&order=123 sapsrv1/embedded
xref: http://tinyurl.com/424g32
[5 Jan 2009 12:08] Alfranio Correia
This is a duplicate of BUG#41861 which will be possible to fix after BUG#40399 has been fixed.