Bug #41548 ALTER TABLESPACE does not work.
Submitted: 17 Dec 2008 14:19 Modified: 15 May 2009 13:11
Reporter: Rafal Somla Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Falcon storage engine Severity:S3 (Non-critical)
Version:6.0-bzr OS:Any
Assigned to: Sergey Vojtovich CPU Architecture:Any
Tags: F_ERROR HANDLING, Tablespace
Triage: Triaged: D4 (Minor)

[17 Dec 2008 14:19] Rafal Somla
Description:
I get strange error when trying to execute ALTER TABLESPACE.

How to repeat:
mysql> create tablespace `foo` add datafile 'ts.dat' engine=falcon;
Query OK, 0 rows affected (0.02 sec)

mysql> alter tablespace `foo` add datafile 'ts1.dat' engine=falcon;
ERROR 1178 (42000): The storage engine for the table doesn't support
[17 Dec 2008 14:22] Rafal Somla
When this bug is fixed, please update backup_bml test as indicated in the comments (once it is pushed).
[17 Dec 2008 15:21] Valeriy Kravchuk
Thank you for a bug report. Verified just as described with recent 6.0.9 from bzr:

openxs@suse:/home2/openxs/dbs/6.0> bin/mysql -uroot test
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 6.0.9-alpha-debug Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> create tablespace foo add datafile 'ts1.dat' engine=falcon;
Query OK, 0 rows affected (0.04 sec)

mysql> alter tablespace foo add datafile 'ts2.dat' engine=falcon;
ERROR 1178 (42000): The storage engine for the table doesn't support
[17 Dec 2008 16:41] Ann Harrison
This is not a bug - Falcon currently allows only one file
per tablespace.  If you want to change files, the right way
to do it is to delete the tablespace and recreate it.
[18 Dec 2008 7:11] Rafal Somla
Ann, thanks for explaining! In that case the only thing which remains to be fixed is the non-informative error message "The storage engine for the table doesn't support".
[18 Dec 2008 8:54] Valeriy Kravchuk
Error message should be made more clear (and, maybe, documentation should be fixed to reflect current limitation and possible workaround).
[25 Dec 2008 13:53] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/62325

2953 Sergey Vojtovich	2008-12-25
      BUG#41548 - ALTER TABLESPACE does not work.
      
      Vague error message was returned when an engine doesn't
      support some specific tablespace command.
[29 Dec 2008 10:07] Alexander Barkov
The patch http://lists.mysql.com/commits/62325 is Ok to push.

(I agree with Kevin's suggestion to add tests for all unsupported operations)
[29 Dec 2008 10:59] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/62400

2954 Sergey Vojtovich	2008-12-29
      BUG#41548 - ALTER TABLESPACE does not work.
      
      Vague error message was returned when an engine doesn't
      support some specific tablespace command.
[13 Feb 2009 7:24] Bugs System
Pushed into 6.0.10-alpha (revid:alik@sun.com-20090211182317-uagkyj01fk30p1f8) (version source revid:svoj@mysql.com-20081229095726-tbekc6eero607ter) (merge vers: 6.0.10-alpha) (pib:6)
[15 May 2009 13:11] MC Brown
An entry has been added to the 6.0.10 changelog: 

The ALTER TABLESPACE statement would fail on Falcon tablespaces because of incorrect assumption about TABLESPACE support for the Falcon engine.