Bug #41383 Test commit1_innodb fails with binlog-format=row
Submitted: 11 Dec 2008 1:25 Modified: 21 Jan 2009 16:20
Reporter: Patrick Crews Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.1+ OS:Any
Assigned to: Andrei Elkin CPU Architecture:Any
Tags: ps-protocol, row-based, Tests
Triage: Triaged: D3 (Medium)

[11 Dec 2008 1:25] Patrick Crews
Description:
The test main.commit_1innodb fails when run with binlog-format=row:

Logging: ./mtr --timer --force --mysqld=--binlog-format=row commit_1innodb
081210 20:21:03 [Warning] Setting lower_case_table_names=2 because file system for /var/folders/Pt/PtJd7NDTGgyOk3+iDGXrQk+++TI/-Tmp-/lGOVp1lW94/ is case insensitive
MySQL Version 5.1.31
Using binlog format 'row'
Using ndbcluster when necessary, mysqld supports it
Setting mysqld to support SSL connections
Binaries are debug compiled
<snip>
Installing Master Database
Saving snapshot of installed databases
=======================================================

TEST                           RESULT         TIME (ms)
-------------------------------------------------------

main.commit_1innodb            [ fail ]

<snip>
@@ -772,8 +772,8 @@
 insert t1 set a=4;
 # Sic: a bug. Binlog did not register itself this time.
 call p_verify_status_increment(1, 0, 1, 0);
-SUCCESS
-
+ERROR
+Expected commit increment: 1 actual: 2
 release savepoint a;
 rollback;
 call p_verify_status_increment(0, 0, 0, 0);

mysqltest: Result content mismatch

Stopping All Servers
Restoring snapshot of databases
Resuming Tests

-------------------------------------------------------
Stopping All Servers
Failed 1/1 tests, 0.00% were successful.

How to repeat:
Run the test with the parameter described above.

From the mysql-test directory, execute the following command:

./mysql-test-run --force --mysqld=--binlog-format=row

Observe the failure will occur as shown above.

Suggested fix:
Determine if this is a weakness of the test or if this is undocumented  or unexpected behavior of the server.
[12 Dec 2008 12:52] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/61479

2737 Andrei Elkin	2008-12-12
      Bug #41383 Test commit1_innodb fails with binlog-format=row
      
      The test explicitly warned on existence of a bug in its 27th part.
      The expected values of prepare and commit counters changed, corrected, by
      fixes to bug#40221.
      Notice, that binlog does not have to register for a statement with
      the statement binlog-format because the statement rollback does not need
      to do anything in that mode. It's not so with the ROW format which was
      bug#40221 concern.
      
      Fixed with correcting the expected values of the mentioned counters and
      explained that with comments in the test.
[12 Dec 2008 13:16] Patrick Crews
Ok to push.
[12 Dec 2008 22:25] Andrei Elkin
pushed to bt.
[15 Jan 2009 6:34] Bugs System
Pushed into 5.1.31 (revid:joro@sun.com-20090115053147-tx1oapthnzgvs1ro) (version source revid:azundris@mysql.com-20081230114838-cn52tu180wcrvh0h) (merge vers: 5.1.31) (pib:6)
[16 Jan 2009 3:47] Paul Dubois
Test case changes. No changelog entry needed.

Setting report to NDI pending push into 6.0.x.
[19 Jan 2009 11:22] Bugs System
Pushed into 5.1.31-ndb-6.2.17 (revid:tomas.ulin@sun.com-20090119095303-uwwvxiibtr38djii) (version source revid:tomas.ulin@sun.com-20090115073240-1wanl85vlvw2she1) (merge vers: 5.1.31-ndb-6.2.17) (pib:6)
[19 Jan 2009 13:00] Bugs System
Pushed into 5.1.31-ndb-6.3.21 (revid:tomas.ulin@sun.com-20090119104956-guxz190n2kh31fxl) (version source revid:tomas.ulin@sun.com-20090119104956-guxz190n2kh31fxl) (merge vers: 5.1.31-ndb-6.3.21) (pib:6)
[19 Jan 2009 15:56] Jon Stephens
Setting status back to NDI pending merge to 6.0 tree.
[19 Jan 2009 16:05] Bugs System
Pushed into 5.1.31-ndb-6.4.1 (revid:tomas.ulin@sun.com-20090119144033-4aylstx5czzz88i5) (version source revid:tomas.ulin@sun.com-20090119144033-4aylstx5czzz88i5) (merge vers: 5.1.31-ndb-6.4.1) (pib:6)
[20 Jan 2009 18:53] Bugs System
Pushed into 6.0.10-alpha (revid:joro@sun.com-20090119171328-2hemf2ndc1dxl0et) (version source revid:azundris@mysql.com-20081230114916-c290n83z25wkt6e4) (merge vers: 6.0.9-alpha) (pib:6)
[21 Jan 2009 16:20] Paul Dubois
Test case changes. No changelog entry needed.