Bug #41223 cannot remove server from self-created goup: Error U0002: You must log in to ...
Submitted: 4 Dec 2008 11:53 Modified: 5 Dec 2008 14:22
Reporter: Carsten Segieth Email Updates:
Status: Closed Impact on me:
Category:MySQL Enterprise Monitor: Web Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: Josh Sled CPU Architecture:Any

[4 Dec 2008 11:53] Carsten Segieth
Trying to remove a server from a self created group I only get a yellow message box after clicking on the 'remove' button on the white "Remove Server from Group" confirmation dialog:

  An Error Occurred
    * U0002 You must log in to access the requested resource.

This happens even if I just refreshed the 'Manage Servers' page or did other actions that definitely require to be logged in to the dashboard.

How to repeat:
I can reproduce this 'always' in my current setup, a check with an other install still needs to be done. These were my steps:
- installed dashboard
- started several agents and stopped them after a while
- removed nearly all servers from the dashboard
- started new build of the agents
- created groups, added some servers here and there
- tried to remove a server from a group where it has been added to by mistake, failed with error U0002
- tried with other servers in other groups, failed with error U0002
Happens both for active and stopped servers.

Deleting a stopped server completely from the dashboard works.
[4 Dec 2008 16:06] Carsten Segieth
work around:
delete the entire group, create a new one and add all servers except the one(s) where the remove command failed
[4 Dec 2008 22:03] Josh Sled
revno: 6520
revision-id: jsled@asynchronous.org-20081204193221-5kagz0h6z9ixp592
parent: jsled@asynchronous.org-20081201164555-d1g6evuzyi7wxlt7
committer: Josh Sled <jsled@asynchronous.org>
branch nick: 2.0
timestamp: Thu 2008-12-04 14:32:21 -0500
  Bug#41223: fix CSRF handling for "removeServerFromGroup" popup.
[5 Dec 2008 14:22] Carsten Segieth
remove from group tested OK with