Bug #41022 Workbench crashes on Vista with a DEP error
Submitted: 25 Nov 2008 18:06 Modified: 9 Jun 2009 6:56
Reporter: Andy Shellam Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.0.27 OS:Windows (Vista 32-bit SP1)
Assigned to: Mike Lischke CPU Architecture:Any

[25 Nov 2008 18:06] Andy Shellam
After installing on a cleanly-built Vista 32-bit SP1 PC, when Workbench starts it shows the splash screen for approx 3 seconds before crashing.

It says the dreaded "Windows encountered a problem in this application..." then offers a Debug option.  When I click Debug, it says "Windows encountered a problem in this application.... Data Execution Prevention closed this program."

Workbench is completely unusable unless I disable DEP completely.

I tried to downgrade to 5.0.26 but encountered the same issue.

How to repeat:
Start Workbench - wait 3 seconds and it crashes.  Attempt to debug and get the DEP message.

Suggested fix:
Allow Workbench to run when DEP is enabled on Vista.
[25 Nov 2008 22:25] MySQL Verification Team
Thank you for the bug report. Duplicate of bug: http://bugs.mysql.com/bug.php?id=40592
[25 Nov 2008 22:43] Andy Shellam
This isn't a duplicate of the afore-mentioned bug, which is for the installation/upgrade process.

The bug I have reported is a crash when Workbench starts from a clean install of 5.0.27, not from an upgrade.
[26 Nov 2008 10:58] Susanne Ebrecht
Many thanks for writing a bug report.

Unfortunately, we tried to reproduce this on more then 10 independent Vista machines and couldn't reproduce it.

Not Workbench related my colleagues have had trouble with DEP by using other software, it seems that DEP is buggy here.

On other software usually totally de-installing the software and install it again helped.

So you could give it a try and re-install it.

For a deeper analysation we need the core dump/stack trace from the crash.
[26 Nov 2008 21:05] Andy Shellam
Thanks for the reply - I'm a software developer by profession myself so I can fully understand that you cannot fix an issue you cannot reproduce yourself.

On the mailing list Mike advised that you're always fixing memory leaks and invalid pointers and that one of these might be the cause, and to keep trying future updates of Workbench.

I have un-installed and re-installed Workbench, I've even tried downgrading to previous versions and can tell you that none of these helped.

If you can advise me how I can get a core dump from my PC, I'll certainly re-enable DEP and get it to crash again if it will help you.  Interestingly I don't have any issues with DEP on anything but Workbench, and I've been running Vista for near-18 months.
[27 Nov 2008 14:52] Susanne Ebrecht
Many thanks for your feedback.

Unfortunately, I think what you already pasted is the only stuff you will get under windows.

I can't verify this bug report at the moment. So I will let it in status open and give it into development.

If you by accident will figure out more, please let us know.
[1 Dec 2008 23:03] Javier Rodriguez
I have the same problem with Workbench in Windows Vista 64 bits. As Andy Shellam stated when DEP is enabled the Workbench crash at startup and, if you try to debug the application, you obtain an error message saying that the application was stopped due to DEP violation.
[20 Jan 2009 14:48] Steve Morton
I am running Windows Vista Home Premium SP1. I just upgraded to Workbench 5.0.29 from 5.0.23. I discovered under 5.0.23 that this problem can be resolved by changing the Windows Theme from the Windows Vista Theme to the Windows Clasic Theme. I normally run my laptop using eht Windows Vista Theme and I think the deault install of windows vista installs this way. I was hoping that version 5.0.29 corrected this issue, but it has not.

Give a try. On you desktop right click and select Personalization and then select Theme. Change Windows Vista to Windows Clasic. Then launch Workbench and it will run. When done switch back to the Windows Vista theme.
[21 Jan 2009 17:33] Steve Morton
Here is a little more information on this issue. As I stated above I was able to get around this issue by changing the Windows Theme to Windows Clasic. I decided to change back to Windows Vista Theme after I started Workbench. I then went through the sakila tutorial found in the manual. Everything seems to function normally without issues.

It appears the Vista DEP issue is only incountered with the initial startup of Workbench and it's splash screen. Once started switching back to the Windows Vista Theme seems not to cause any problems.

Hope this helps in isolating this issue.
[24 Jan 2009 19:09] Henri Bogaarts
I have the same DEP error on my notebook running vista ultimate with sp1.
I tried the sollution steve morton gave and it indead works.
However this is ofcourse no sollution but a work arround.

So a sollution is still very needed!
[24 Mar 2009 13:30] Susanne Ebrecht
This is a duplicate of bug #40592
[24 Mar 2009 18:56] Andy Shellam
Sorry but this bug is not a duplicate of #40592 - that was an issue with the installer.  This bug is an issue where Workbench wouldn't even start.

5.1 beta doesn't appear to have this issue on my machine - can anyone else who experienced it also confirm the same?
[25 Mar 2009 4:45] Steve Morton
I downloaded and installed the 5.1 beta Windows installer file on my Windows Vista Laptop (same one as mentioned in my earlier post on this bug). Still using the Windows Vista Theme this 5.1 beta still has the same DEP error. If you apply the work around I mentioned earlier 5.1 beta will execute.

After doing some research on Windows Vista it appears that Microsoft designed the Windows Vista Theme as a security layer. The best that I can understand is the the Windows Vista Theme does or prevents applications from doing something like accessing protected areas of Windows or making changes to folders under Program Files. It is my suspesion that MySQL Workbench OSS is initilizing modules during the time that the splash screen appearance on the screen simular to what Dreamweaver CS3 does as well as other Adobe produces. It is during this initilizing time that MySQL Workbench OSS is executing a command that Windows Vista Theme will not allow for security reasons. This could be something as simple as it requireing an Administrators Permission to execute or an attempt to create a temp folder under the Program Files folder. If you look at the modify dates and times for the folders under C:\Program Files\MySQL\MySQL Workbench 5.1 OSS\ you will notice that they have changed to the last time you accessed MySQL Workbench OSS successfully. I could not find a file which had the dates changed, but it appears that for some reason the folders modify dates and times are being changed. Only speculation here, but MySQL Workbench OSS may be changeing this with each successfull opening of the program.

Anyway, bug is still there. At least on my machine.

[25 Mar 2009 5:48] Steve Morton
Hi all,

Have made some progress here with this bug. It seems to be caused by windows Vista having aero enabled.

Try this:

Under Personalize, click on colors and 
appearance, then on the line for classic appearance properties. Switch from 
Windows Aero to Windows Vista Basic.

Then go execute MySQL Workbench 5.1 beta or 5.0 and both will work now.

The problem seems to be associated with the new Windows Visat Aero feature.

For those of you who don't know what Aero is - its the feature that gives Vista windows that "see through" effect. With Aero disabled you will lose that look.

Andy, hopefully this will help the MySQL Devleopers focus in on the bug.


[25 Mar 2009 17:04] Andy Shellam
Hi Steve,

Thanks for replying back with your findings.  Interestingly Windows Aero is the default theme on my PC, the transparency effects are turned on, as is DEP, and Workbench OSS (both 5.0.30 and 5.1.9 beta) runs perfectly happily.

This laptop that it's now running OK on is a different machine to what I was using when I reported the bug, however I still have access to that machine - which is the identical Windows version to my laptop - also with Aero and DEP turned on that refuses to run Workbench - both 5.0.30 and 5.1.9 beta - it doesn't actually crash any more, just sits on the splash screen forever.

Obviously my old PC and yours have something in common that my laptop doesn't.  What that is I have no idea...!

[25 Mar 2009 17:09] Andy Shellam
I've just tried running Workbench on my old PC as an Administrator (browse to "C:\Program Files\MySQL\MySQL Workbench 5.0(5.1) OSS", right-click MySQLWorkbench.exe, Run as Administrator) - the app still just hangs on the splashscreen - no error.

The memory usage in Task Manager climbs to 39MB within 2 seconds of opening, then no further increase and no CPU usage.
[31 Mar 2009 9:37] Susanne Ebrecht
Steve: Many thanks for your great help. I will look if development could do a fix of it or if we will document it.
[3 Apr 2009 11:07] Susanne Ebrecht
Bug #40592 is the Workbench SE version of this bug here.

Bug #40592 is set as duplicate of this bug here.

Also I changed category to MySQL Workbench because it hits OSS and SE.
[5 Apr 2009 15:35] Alfredo Kojima
Does this problem occur only with the msi installed Workbench? 
Can it be repeated with the .zip workbench unpacked in your own desktop?
[6 Apr 2009 3:03] Steve Morton
I downloaded the beta non-install zip file to my computer and unpacked. Found the executable file for workbench within the unzipped folder and executed it. Had the same results as with the Windows install.

I am attempted to use MS Visual Studio Express C++ to build a compiled version. I don't own the full version of MSVS, but have found the Express version on Microsoft and will see if I can compile a version. Been a while since I've done this so it make me a few days to remember how.

[3 Jun 2009 12:57] Mike Lischke
Andy, have you ever tried to disable the splash screen? You can pass "-nologo" as command line parameter and the splash screen won't show up. Does WB still hang with that set?
[3 Jun 2009 14:36] Steve Morton

I tried the -nologo switch on both the 5.0 and 5.1 versions of Workbench OSS. The results were the same with the same error occuring.

My thoughts are that the splash screen is not the problem. The conflict is with an app or module which is being initilized during the splashscreen startup. There is probably a memeory area which is beign accessed by the startup app or module which Vista security is not allowing because the app or module does not have permission to do so. Just guessing.

[5 Jun 2009 12:49] Valery Mosyagin
I had same problem Bug #45348. I can start Workbench after setting less Graphic hardware acceleration. Using Filemon I found WB hangs after reading some ATI OpenGL dlls. It seems problem with OpenGL and WB.
I use Windows XP Professional SP3.

[5 Jun 2009 13:28] Steve Morton
My Laptop does have an ATI Radeon X1270. I did a search for update drivers and it does have the latest drivers installed. It appears that the bug is when a certion option is chosen for Windows (see my post above). I also did a Google on ATI OpenGL and it appears that ATI is not native for XP, but is suspose to be native for Vista. I have run accross the ATI OpenGL conflect with some apps in my reading in the past but I do not remember what the issues were, but it appears that some issue occur around displaying graphic images. Adobe After Effects CS3 seems to have that issue as OpenGL does not support some effects.

I found filemon and have downloaded it. I'll install it and run a test and see if I get the same issues. Will report back here when done.

[5 Jun 2009 14:57] MySQL Verification Team
I couldn't repeat anymore this issue on Vista Home Premium.
[5 Jun 2009 15:41] Steve Morton
Brief update... Filemon does not install on Windows Vista, they recommended Process Monitor same vendor. Installed it and ran both cases with and with out Aero active. First lots of data to scroll though, attempting to isolate just WB in the output. After searching I could not reproduce a OpenGL issue that I could reconize from the output. There were a lot of Buffer Overflows and Names Not Found, but not specific cause of error. Again that I could reconize. I continue to review Process Monitor help to see if I can isolate a specific cause for the error. Will update here if I find anything conclusive.

[9 Jun 2009 6:56] Mike Lischke
Thank you all for your reports and help to find a solution for this problem. As it appears (see also Bug #44051) this crash appears much less frequent with MySQL Workbench 5.1 or newer. Since we have a hard time to reproduce it at all (it seems to require a very special setup to show up) I'll close this report.

And since we generally focus on 5.1 rather than 5.0 we would like to continue investigating this problem for 5.1. So, please test with the soon to be released WB 5.1 RC1 and create a new bug report if you still see a crash with as much info attached as possible. Thanks again.
[30 Jan 2010 12:28] Gustavo Santos
This problem is apparently fixed on 5.1.18 rev 4456, but the 5.2 versions are having the old behaviour again.