Bug #40989 ndb_partition_error2 needs maintenance
Submitted: 24 Nov 2008 17:35 Modified: 22 Dec 2017 10:36
Reporter: Matthias Leich Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Cluster Severity:S3 (Non-critical)
Version:5.1 OS:Any
Assigned to: Magnus Blåudd
Tags: disabled
Triage: Needs Triage: D4 (Minor)

[24 Nov 2008 17:35] Matthias Leich
Description:
The execution of ndb_partition_error2 is since some
time disabled:

./mysql-test-run.pl ndb_partition_error2
TEST                     RESULT       TIME (ms)
----------------------------------------------------
ndb.ndb_partition_error2 [ disabled ] HF is not sure
                if the test can work as internded on 
                all the platforms

An attempt to run this test gives 
suspicious results:

./mysql-test-run.pl --enable-disabled ndb_partition_error2
TEST                     RESULT      TIME (ms)
-------------------------------------------------------

ndb.ndb_partition_error2 [ skipped ] Test requires: 'true'
-------------------------------------------------------
Stopping All Servers

The test itself tries to replay
  Bug#27359 Partitions: memory allocation error message

This above shows that this test is in a bad state.
Regarding disabled.def:
- The comment is vague and it should better point to
  some open bug
- there is till now no information if this test
  can really not work as intended on any platform 
Regarding the testing code itself:
  It is not runnable even on a "less problematic main"
  platform like Linux.
  
The tests above where executed on tree 5.1-bugteam
(Nov 2008), testing box with Linux OpenSuSE 11.0.

How to repeat:
See above

Suggested fix:
Please
1. modify this test so that it is basically runnable
2. correct suite/ndb/t/disabled.def depending on the
   outcome of 1.
   Variant 1) The test runs fine on all platforms
              -> remove this test from disabled.def
   Variant 2) The test runs fine on most platforms
              -> Report a new bug for failing platforms
                 Modify the test so that it's
                 execution on the problematic platforms
                 gets skipped.
                 Remove this test from disabled.def
   Variant 3) The test does not run on any platform
              -> Report a new bug
                 Correct disabled.def
[22 Dec 2017 10:36] Magnus Blåudd
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at

    http://dev.mysql.com/doc/en/installing-source.html
[3 Jan 11:31] Jon Stephens
Fixed in NDB 8.0.1. Affects testing only. Closed.