Bug #40930 rpl.rpl_extraCol_falcon fails doing STOP SLAVE
Submitted: 21 Nov 2008 16:12 Modified: 23 Sep 2009 0:19
Reporter: John Embretsen Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S1 (Critical)
Version:6.0.9-bzr OS:Microsoft Windows
Assigned to: John Embretsen CPU Architecture:Any
Tags: falcon, pushbuild, test failure

[21 Nov 2008 16:12] John Embretsen
Description:
Failure in Pushbuild 2 on platform 'win x86 max' in mysql-6.0-falcon-team branch.

rpl.rpl_extraCol_falcon 'row'  [ fail ]

mysqltest: In included file ".\extra\rpl_tests\rpl_extraSlave_Col.test": At line 101: query 'STOP SLAVE' failed: 2013: Lost connection to MySQL server during query

The result from queries just before the failure was:
< snip >
Last_Error	Table definition on master and slave does not match: Column 2 size mismatch - master has size 10, test.t2 on slave has size 6. Master's column size should be <= the slave's column size.
(...)

How to repeat:
mysql-6.0-falcon-team branch:

mysql-test-run.pl --force --mysqld=--binlog-format=mixed
[21 Nov 2008 16:30] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/59573

2915 John H. Embretsen	2008-11-21
      Bug#40926, Bug#40927, Bug#40930: Disabling rpl falcon tests that fail in Pushbuild 
      until failures have been properly analyzed and possibly fixed.
      
      rpl.rpl_extraCol_falcon: Fails on Windows in Pushbuild 2 during STOP SLAVE (bug 40930).
      rpl.rpl_relay_space_falcon: Fails in Pushbuild due to binlog-format settings (bug 40927).
      rpl.rpl_truncate_falcon: Fails in Pushbuild due to binlog-format settings (bug 40926).
[11 Dec 2008 14:20] Bugs System
Pushed into 6.0.9-alpha  (revid:john.embretsen@sun.com-20081121162938-nucuraj75uw26jp8) (version source revid:hky@sun.com-20081127084516-nbu7693932vcz2st) (pib:5)
[8 May 2009 12:56] John Embretsen
Still waiting for PB2+MTR2 stability on Windows X64 platform before I continue analyzing this bug.

Bug#42641 seems to be the blocker.
[18 Sep 2009 7:18] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/83682

2789 John H. Embretsen	2009-09-18
      Bug#40930 - rpl.rpl_extraCol_falcon fails doing STOP SLAVE.
      Applying fix for bug 40796 to 6.0-falcon-team branch, which should solve this issue.
      Re-enabling test cases that were disabled due to that bug.
      rpl_extraCol_falcon
      rpl_extraColmaster_innodb
      rpl_extraColmaster_myisam
     @ mysql-test/suite/rpl/t/disabled.def
        Re-enabling test cases that were disabled due to bug 40796.
     @ vio/vio.c
        Fix for bug no 40796 - Crash due to heap corruption in rpl.rpl_extraColmaster_myisam.
        Original patch at http://lists.mysql.com/commits/79294.
[18 Sep 2009 7:41] John Embretsen
Alfranio Correia gave notice that this may be a duplicate of Bug#40796. Setting status to "In progress" while applying fix for that bug to the 6.0-falcon-team branch.
[18 Sep 2009 7:43] John Embretsen
Patch pushed to mysql-6.0-falcon-team, revision
2789 john.embretsen@sun.com-20090918071754-yuae6219spopw605
[18 Sep 2009 12:44] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/83717

2790 John H. Embretsen	2009-09-18
      Bug#40930 - rpl.rpl_extraCol_falcon fails doing STOP SLAVE
      Apply the real fix for 40796 (the culprit bug) - the previously applied fix was "placebo" (hinted by Vlad V.).
      Ported to 6.0-falcon-team by leaving out (unused) changes for instance manager (which was removed in 6.0, wl#4085).
      Original patch: http://lists.mysql.com/commits/80781
[18 Sep 2009 13:54] John Embretsen
Latest patch (bugfix ported from 5.x) pushed to mysql-6.0-falcon-team branch as revision 2790 john.embretsen@sun.com-20090918124356-hs4840ngbh6wecvv.
[23 Sep 2009 0:20] Omer Barnir
Duplicate of bug#40796 (not a falcon bug but showing in a Falcon test)