Bug #39958 Test "windows" lacks a cleanup
Submitted: 9 Oct 2008 18:50 Modified: 10 Nov 2008 17:42
Reporter: Joerg Bruehe Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version:5.0 OS:Microsoft Windows
Assigned to: Georgi Kodinov CPU Architecture:Any
Triage: Triaged: D3 (Medium) / R1 (None/Negligible) / E1 (None/Negligible)

[9 Oct 2008 18:50] Joerg Bruehe
Description:
Test "windows" ends with these lines:

===== start quote
#
# Bug #27811: The variable 'join_tab' is being used without being defined
#
CREATE TABLE t1 (a int, b int); INSERT INTO t1 VALUES (1,1);
EXPLAIN SELECT * FROM t1 WHERE b =  (SELECT max(2));

--echo End of 5.0 tests.
===== end quote

As a result, it leaves table "test.t1" in the database.

Now if the test suite is run
- on a Windows platform (so that this test is executed)
- in a "classic" build (without InnoDB, so test "xa" is skipped),
the next test executed is "xml" and it will fail: "Table already exists"

(Skipping test "xa" is necessary to provoke the problem, because that test was coded defensive: it starts with a "drop table if exists t1" and also does a final cleanup.)

This failure has been reported as bug#37988 which has been declared "Not a bug", because each test has to do a cleanup.
So the fault is with test "windows".

How to repeat:
Run the test suite on a Windows machine without InnoDB
(or otherwise skip test "xa").

Suggested fix:
Add a cleanup:

DROP TABLE t1
[16 Oct 2008 11:16] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/56365

2707 Georgi Kodinov	2008-10-16
      Bug #39958: Test "windows" lacks a cleanup
      
      Added the missing DROP TABLE
[24 Oct 2008 8:42] Bugs System
Pushed into 5.0.72  (revid:kgeorge@mysql.com-20081016111627-gxbfyxpdpl3krs4i) (version source revid:kgeorge@mysql.com-20081020132607-0xfdc16b9p1xrd83) (pib:5)
[24 Oct 2008 14:11] Paul Dubois
Test case changes. No changelog entry needed.

Setting report to NDI pending push into 5.1.x, 6.0.x.
[10 Nov 2008 10:50] Bugs System
Pushed into 6.0.8-alpha  (revid:kgeorge@mysql.com-20081016111627-gxbfyxpdpl3krs4i) (version source revid:kgeorge@mysql.com-20081017102817-ozu17n4s2j05sns1) (pib:5)
[10 Nov 2008 11:35] Bugs System
Pushed into 5.1.30  (revid:kgeorge@mysql.com-20081016111627-gxbfyxpdpl3krs4i) (version source revid:kgeorge@mysql.com-20081017084923-g4yvgeo0xi74ltt0) (pib:5)
[10 Nov 2008 17:42] Paul Dubois
Test case changes. No changelog entry needed.
[19 Jan 2009 11:21] Bugs System
Pushed into 5.1.31-ndb-6.2.17 (revid:tomas.ulin@sun.com-20090119095303-uwwvxiibtr38djii) (version source revid:tomas.ulin@sun.com-20090108105244-8opp3i85jw0uj5ib) (merge vers: 5.1.31-ndb-6.2.17) (pib:6)
[19 Jan 2009 12:59] Bugs System
Pushed into 5.1.31-ndb-6.3.21 (revid:tomas.ulin@sun.com-20090119104956-guxz190n2kh31fxl) (version source revid:tomas.ulin@sun.com-20090119104956-guxz190n2kh31fxl) (merge vers: 5.1.31-ndb-6.3.21) (pib:6)
[19 Jan 2009 16:05] Bugs System
Pushed into 5.1.31-ndb-6.4.1 (revid:tomas.ulin@sun.com-20090119144033-4aylstx5czzz88i5) (version source revid:tomas.ulin@sun.com-20090119144033-4aylstx5czzz88i5) (merge vers: 5.1.31-ndb-6.4.1) (pib:6)