Bug #39707 Falcon fails to start when --falcon-page-size=1K
Submitted: 28 Sep 2008 10:14 Modified: 8 Jan 2009 17:01
Reporter: Philip Stoev Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Falcon storage engine Severity:S2 (Serious)
Version:6.0-falcon-team OS:Any
Assigned to: Hakan Küçükyılmaz
Tags: regression
Triage: Triaged: D3 (Medium)

[28 Sep 2008 10:14] Philip Stoev
Description:
When starting Falcon with --falcon-page-size=1K (which is a valid value according to our documentation), Falcon refuses to start:

080928 13:13:18 [ERROR] Falcon: Exception 'Maximum key length can be exceeded on index OBJECT_PRIVILEGES on table SYSTEM.PRIVILEGES' during initialization
080928 13:13:18 [ERROR] Plugin 'Falcon' init function returned error.
080928 13:13:18 [ERROR] Plugin 'Falcon' registration as a STORAGE ENGINE failed.

How to repeat:
$ perl mysql-test-run.pl --start-and-exit --mysqld=--falcon --mysqld=--falcon-page-size=1K --mysqld=--default-storage-engine=falcon
[28 Sep 2008 11:14] Hakan Küçükyılmaz
This is a regression. We once disabled 1k page sizes due to index problems. Minimum page size should be 2k.

That's why we have the basic regression tests:
  - falcon_page_size_2.test
  - falcon_page_size_4.test
  - falcon_page_size_8.test
  - falcon_page_size_16.test
  - falcon_page_size_32.test

I will fix Falcon to have a minimal page size of 2k again.
[28 Sep 2008 11:33] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/54623

2839 Hakan Kuecuekyilmaz	2008-09-28
      Fixed Bug#39707	Falcon fails to start when --falcon-page-size=1K
      
      Minimum falcon_page_size is 2k.
[28 Sep 2008 11:39] Valerii Kravchuk
Not repeatable with recent 6.0.8-bzr. I can start Falcon with 1K page size there.
[28 Sep 2008 16:02] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/54629

2839 Hakan Kuecuekyilmaz	2008-09-28
      Fixed Bug#39707	Falcon fails to start when --falcon-page-size=1K
      
      Minimum falcon_page_size is 2k.
[29 Sep 2008 15:16] Kevin Lewis
I agree that the minimum page size for Falcon aught to be 2k, not 1k.  We decided this some time ago, but somehow, StorageParameters.h still indicated 1k.  The patch is correct.
[3 Oct 2008 21:05] Omer Barnir
triage: setting that to CHECKED
[8 Jan 2009 17:01] MC Brown
A note has been added to the 6.0.6 changelog: 

The minimum page size accepted by FALCON has been increased from 1K to 2K.