Bug #38934 slave slave until does not work with --replicate-same-server-id
Submitted: 21 Aug 2008 10:04 Modified: 2 Feb 2009 15:27
Reporter: Andrei Elkin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version:5.1 OS:Any
Assigned to: Andrei Elkin
Tags: start slave until
Triage: Triaged: D2 (Serious)

[21 Aug 2008 10:04] Andrei Elkin
Description:
Slave sql thread does not apply events prescribed by the until position.

How to repeat:
make a new rpl_stm_until-slave.opt file with the content:

--replicate-same-server-id --disable-log-slave-updates

run:

./mtr  rpl_stm_until

to see:

rpl.rpl_stm_until 'stmt'                 [ fail ]

CURRENT_TEST: rpl.rpl_stm_until
mysqltest: At line 52: query 'select * from t1' failed: 1146: Table 'test.t1' doe
[10 Sep 2008 9:58] Andrei Elkin
Johnathon, I am not sure if `OS' is really any. The failure was noticed on my 32 bit ubuntu as well as by Tomas somewhere on his boxes.

I am about to fix it, so it a patch we shall see if there is bits specifics.

Thanks!
[19 Sep 2008 15:28] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/54371

2680 Andrei Elkin	2008-09-19
      Bug#38934 slave slave until does not work with --replicate-same-server-id
      
      Slave did not perform any event recorded into the relay log from some different master
      when it was started with --replicate-same-server-id.
      The reason appeared to be a consequence of BUG@38734 which stopped the sql thread at its
      startup time.
[10 Dec 2008 13:09] Andrei Elkin
The latest patch is landed on bug#38734 page (bzr post-commit trigger bug? - needs investigation why)
[10 Dec 2008 13:44] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/61212

2705 Andrei Elkin	2008-12-10
      Bug#38934 slave slave until does not work with --replicate-same-server-id
      Bug#38540 rpl_server_id2 uses show slave status unnecessarily
            
      Slave did not perform any event recorded into the relay log from some
      different master when it was started with --replicate-same-server-id.
      The reason appeared to be a consequence of BUG#38734 which stopped the
      sql thread at its startup time.
      
      The real fixes for the current bug are in the patch for BUG#38734.
      This changeset carries only a regression test for the bugs. 
      Bug#38540 gets fixed too by means of eliminating an extra show slave status.
[19 Dec 2008 18:59] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/62159

2705 Andrei Elkin	2008-12-19
      Bug#38934 slave slave until does not work with --replicate-same-server-id
      Bug#38540 rpl_server_id2 uses show slave status unnecessarily
                  
      Slave did not perform any event recorded into the relay log from some
      different master when it was started with --replicate-same-server-id.
      The reason appeared to be a consequence of BUG#38734 which stopped the
      sql thread at its startup time.
            
      The real fixes for the current bug are in the patch for BUG#38734.
      This changeset carries only a regression test for the bugs.  Bug#38540
      gets fixed too by means of eliminating an extra show slave status.
[19 Dec 2008 20:21] Andrei Elkin
pushed to rpl.
[7 Jan 2009 14:26] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/62605

2709 He Zhenxing	2009-01-07 [merge]
      Auto merge
[30 Jan 2009 13:29] Bugs System
Pushed into 6.0.10-alpha (revid:luis.soares@sun.com-20090129165607-wiskabxm948yx463) (version source revid:luis.soares@sun.com-20090129163120-e2ntks4wgpqde6zt) (merge vers: 6.0.10-alpha) (pib:6)
[30 Jan 2009 15:09] Bugs System
Pushed into 5.1.32 (revid:luis.soares@sun.com-20090129165946-d6jnnfqfokuzr09y) (version source revid:zhenxing.he@sun.com-20090107142538-aeoxq3lddk0g4uff) (merge vers: 5.1.31) (pib:6)
[2 Feb 2009 15:27] Jon Stephens
Documented bugfix in the 5.1.32 and 6.0.10 changelogs. See Bug #38734 for details.
[17 Feb 2009 14:57] Bugs System
Pushed into 5.1.32-ndb-6.3.23 (revid:tomas.ulin@sun.com-20090217131017-6u8qz1edkjfiobef) (version source revid:tomas.ulin@sun.com-20090203133556-9rclp06ol19bmzs4) (merge vers: 5.1.32-ndb-6.3.22) (pib:6)
[17 Feb 2009 16:44] Bugs System
Pushed into 5.1.32-ndb-6.4.3 (revid:tomas.ulin@sun.com-20090217134419-5ha6xg4dpedrbmau) (version source revid:tomas.ulin@sun.com-20090203133556-9rclp06ol19bmzs4) (merge vers: 5.1.32-ndb-6.3.22) (pib:6)
[17 Feb 2009 18:20] Bugs System
Pushed into 5.1.32-ndb-6.2.17 (revid:tomas.ulin@sun.com-20090217134216-5699eq74ws4oxa0j) (version source revid:tomas.ulin@sun.com-20090201210519-vehobc4sy3g9s38e) (merge vers: 5.1.32-ndb-6.2.17) (pib:6)