Bug #38778 partition_mgm_lcN_ndb tests crashes ndb nodes
Submitted: 13 Aug 2008 19:27 Modified: 17 May 2009 12:19
Reporter: Mattias Jonsson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Cluster: Cluster (NDB) storage engine Severity:S2 (Serious)
Version:6.0 OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Triage: D1 (Critical)

[13 Aug 2008 19:27] Mattias Jonsson
Description:
partition_mgm_lc[012]_ndb test passes, but master1 crashes!
see master1.err:

It works in 5.1-bugteam, but fails on 6.0-bugteam

(gdb) bt
#0  0x91c0c08a in __assert_rtn ()
#1  0x007338ea in my_write_core (sig=10) at stacktrace.c:307
#2  0x000f31e7 in handle_segfault (sig=10) at mysqld.cc:2657
#3  <signal handler called>
#4  0x00713901 in alloc_root (mem_root=0x4, length=46) at my_alloc.c:177
#5  0x0031cae4 in ndbcluster_prepare_rename_share (share=0x0, new_key=0x2068af0 "./mysql_test_db/tableb") at ha_ndbcluster.cc:8785
#6  0x00341b8d in ndb_binlog_thread_handle_schema_event_post_epoch (thd=0x2027c18, post_epoch_log_list=0xb06dee64, post_epoch_unlock_list=0xb06dee58) at ha_ndbcluster_binlog.cc:2197
#7  0x00346903 in ndb_binlog_thread_func (arg=0x0) at ha_ndbcluster_binlog.cc:4874
#8  0x91b566f5 in _pthread_start ()
#9  0x91b565b2 in thread_start ()

How to repeat:
Use latest mysql-6.0-bugteam and enable parts.partition_mgm_lcN_ndb and run them.
It looks like they pass, but there will be note in the warning log-file and ugly stuff in master1.err

warnings -file:
master1.err: parts.partition_mgm_lc1_ndb: Attempting backtrace. You can use the following information to find out

excerpt from master1.err:
0   mysqld                              0x00734854 my_print_stacktrace + 44^@
1   mysqld                              0x000f3c00 handle_segfault + 894^@
2   libSystem.B.dylib                   0x91b9209b _sigtramp + 43^@
3   ???                                 0xffffffff 0x0 + 4294967295^@
4   mysqld                              0x0031dae4 _Z31ndbcluster_prepare_rename
_shareP19st_ndbcluster_sharePKc + 60^@
5   mysqld                              0x00342b8d _Z29ndbcluster_show_status_bi
nlogP3THDPFbS0_PKcjS2_jS2_jE12ha_stat_type + 2381^@
6   mysqld                              0x00347903 ndb_binlog_thread_func + 1101
3^@
7   libSystem.B.dylib                   0x91b566f5 _pthread_start + 321^@
8   libSystem.B.dylib                   0x91b565b2 thread_start + 34^@
080813 22:24:32 - mysqld got signal 10 ;

Suggested fix:
N/A
[3 Oct 2008 14:55] Mattias Jonsson
one related bug is bug#37719, where the fix was to use a case sensitive charset in hash_init:

-  if (hash_init(&archive_open_tables, system_charset_info, 32, 0, 0,
+  if (hash_init(&archive_open_tables, &my_charset_bin, 32, 0, 0,

(might not fix the crash, but helps with strange behavior with only differences in case.)
[17 May 2009 12:19] Jonas Oreland
i close this as duplicate of bug#44919, bug#40709 & bug#19899