Bug #38723 MySQL Configuration Wizard on Vista unreadable
Submitted: 11 Aug 2008 15:23 Modified: 17 Aug 2009 16:35
Reporter: igor defaye Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Config Wizard Severity:S3 (Non-critical)
Version:1.0.12.0 OS:Microsoft Windows (Vista)
Assigned to: Iggy Galarza
Tags: Configuration Wizard, vista
Triage: Triaged: D3 (Medium)

[11 Aug 2008 15:23] igor defaye
Description:
After installing MySQL 5.0.51b win32. A message invites you to configure the server instance. But the window opens shrinked around 100x100 px.
The window cannot be resized. Closing the window dans opening the service instance configuration wizard again does not help. 
This seems to happen only when Vista decides to open the popup window at the bottom of the screen so that the full popup would not fit and is then shrinked. I've tried closing and opening several times, but still the same issue. 

Tested with :MySQL Server Instance Configuration Wizard 1.0.12.0

I haven't found any bug repports on this. There are some talks on the web but with no given solution.

How to repeat:
Launch the configuration wizard in such a way that Vista opens it at the bottom of the screen. I don't know how Vista manages this, either according to the opened windows behind or by the last popuped window position.

Suggested fix:
I've finaly succeeded by doing a WINDOWS+M to minimize all windows in the back then launching the configuration MySQL Server Instance Configuration Wizard. The window appeared at the middle of the screen unshrinked.
[11 Aug 2008 15:28] igor defaye
This is what happens

Attachment: mysql5tinysigh.jpg (image/pjpeg, text), 8.38 KiB.

[11 Aug 2008 17:38] Miguel Solorzano
Thank you for the bug report. I can't repeat on Windows Vista Ultimate, which are your video settings?. Thanks in advance.
[11 Aug 2008 18:30] igor defaye
Video settings are 1280x1024 32bits
Windows Vista Pro.
GC : Intel G965 Express Chipset

I've had the very same problem with MySQL 5 GUI Tools installer. The fist part was ok, then a popup came out shrink, I could only see some pieces of text and the button 'next'.
It seems a commun problem with the installer you are using.
[15 Sep 2008 12:29] Matus Mlynarcik
I have same problem with mysql-5.1.28-rc win32 on Windows Vista Business

Video settings are 1280x800 32bits
GC : Intel G965 Express Chipset
[6 Nov 2008 13:57] Yngve Svendsen
I reproduced this in 5.0.72 on Vista x64 by using the "Show desktop" button on the taskbar to minimize all windows just when the actual copying of files starts, i.e. when the "Please wait while the Setup Wizard install MySQL Server..." and the associated status bar appears.

This always seems to cause either one of these two problems:
1: the "MySQL Enterprise" subscription window comes up sized approx. 60 x 40 px, so contents are essentially not visible, except for the Next and Cancel buttons. After clicking Cancel, the config wizard appears in a similarly sized window, so only the upper left hand illustration is visible. No clickable buttons, no way to resize the window, no scoll bars. Only option is to close the window.
2: The "MySQL Enterprise" subsciption windows appears on the taskbar, but it is not possible to maximize or restore the actual window. Clicking the taskbar entry for the window has no effect. This makes it appear as though the installer hangs, since the installer window is visible and waiting for the subscription window to finish.
[6 Nov 2008 14:45] Miguel Solorzano
Screen size

Attachment: screen-installer.png (image/png, text), 84.51 KiB.

[6 Nov 2008 14:46] Miguel Solorzano
Thank you for the feedback. I was able to repeat following the below steps how was commented before:

"I reproduced this in 5.0.72 on Vista x64 by using the "Show desktop" button on the taskbar
to minimize all windows just when the actual copying of files starts, i.e. when the
"Please wait while the Setup Wizard install MySQL Server..." and the associated status bar
appears."

I attached a picture.
[4 Dec 2008 15:00] Iggy Galarza
Bug#36120 describes two disparate symptoms. The second symptom partial duplicate of this report.
[7 Jan 2009 12:23] christian westman
I had the same problem and the following seemed to fix it.

When trying to execute C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld.exe I got the following error:

C:\Program Files\MySQL\MySQL Server 5.1\bin>mysqld.exe
090107 13:15:24 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.1\data\xx.lower-test
090107 13:15:24 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.1\data\xx.lower-test
mysqld.exe: Can't change dir to 'C:\Program Files\MySQL\MySQL Server 5.1\data\'
(Errcode: 2)
090107 13:15:24 [ERROR] Aborting

090107 13:15:24 [Note] mysqld.exe: Shutdown complete

Sure enough the directory C:\Program Files\MySQL\MySQL Server 5.1\ did not contain a 'data' directory, so I created a 'data' directory

After that I had no problem executing mysqld.exe and when opening the MySQL Service Instance Config Wizard I got a normal usable window
[8 Jan 2009 17:43] Andrew Wedmore
I had this problem, using Windows Vista Ultimate on a machine with a screen resolution of 1920 x 1200.  The problem occurred both when the wizard was launched during the installation and also when I tried to run it separately afterwards from the start button.

An effective work-round was to lower my screen resolution to 1280 x 800 and then run the wizard.  It appeared at the correct size.

When I put the screen res back to 1920 x 1200, the Wizard continued to run at the correct size.
[24 May 2009 13:56] Peter Laursen
I just noticed that on my environment (Vista 32 bit - two different 17" laptops both with Nvidia graphics and 1440*900 screen resolution) this does *not* happen if the Wizard (MySQLInstanceConfig.exe) is started manually from Windows Explorer.  But it does most of the times when invoked from the installer.
[17 Jul 2009 0:45] Patrick Crews
Ok to push.  Was unable to duplicate the problem with the test .msi
[17 Aug 2009 16:35] MC Brown
A note has been added to the respective changelogs: 

During installation on Windows, the MySQL Instance Configuration Wizard window could be opened at a size too small to be usable.
[13 Dec 2009 10:46] Roberto Marquez
This is an issue with the Program Data Directory.  I fixed it by setting the permission for my user to allow access to this directory.
[26 Jan 2010 15:11] Daniel Wainwright
I have the same problem and have tried lowering the screen resolution, unfortunately the problem still exists and I have no idea how to fix it. Can anyone point me in the right direction?
[3 Mar 2010 9:52] Matthew Zalewski
I had the same problem - Tried Windows+M and changing the resolution, but nothing changed. 
Using Windows Explorer, give 'Everyone' full access to the MySql folder - hopefully this fixes the problem (worked for me)